Re: PPPOE with DHCP and VRF + OSPF

From: garry baker <baker.garry_at_gmail.com>
Date: Fri, 20 Aug 2010 18:45:28 +0300

try this command on the Client router and you will see the problem:
'sh ip ospf database router adv-router 192.168.16.6'

you should see "Adv Router is not-reachable" and you will see a strange
Router Interface address looking something like 0.0.0.14 (or some number
that is not an IP on your router or you did not set as router-id under the
ospf process)

aslo 'show ip ospf int br' and look at the ospf network types, Server will
be broadcast on the f0/0 and on the Cleint will be p2p on the
dialer-interface

it is due to the unnumbered interface on the Server you are using:
interface Virtual-Template1
 ip vrf forwarding ABC
 ip unnumbered FastEthernet0/0

change this to the IP of the F0/0 interface and it will start working

see this article for a more detailed explanation:

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009481a.shtml#r4

HTH
garry

--
Garry L. Baker
"There is no 'patch' for stupidity." - www.sqlsecurity.com
On Fri, Aug 20, 2010 at 3:55 PM, Gaurav Thukral <pearlgaurav_at_gmail.com>wrote:
> Hi,
>
> I am having a issue with PPPOE using DHCP and PPPOE server interface in
> VRF,
> also running OSPF over this PPPOE link. I Just using two router topology (
> http://www.ccie18473.net/dynamips/dynamips.htm#pppoe-old-dhcp-vrf).
>  I am able to get IP address for dialer interface from DHCP server, also my
> OSPF session is coming up fine, but the issue is that whereas server is
> able
> to get ospf routes from client, client is not having any ospf routes from
> server.
>
> Please if someone take a look and let me know if I am missing something
> here.
>
>
>
> Server config :-
>
>
>
> no ip dhcp use vrf connected
> ip dhcp excluded-address 192.168.16.2 192.168.16.254
> !
> ip dhcp pool PPPOE
>   network 192.168.16.0 255.255.255.0
> !
> !
> ip vrf ABC
>  rd 1:1
> !
> ip vrf forwarding
> !
> no ip ips deny-action ips-interface
> vpdn enable
> !
> vpdn-group CISCO
>  accept-dialin
>  protocol pppoe
>  virtual-template 16
>
> username LAB password 0 LAB
>
> interface Loopback0
>  ip vrf forwarding ABC
>  ip address 1.1.1.1 255.255.255.255
> !
> interface FastEthernet0/0
>  ip vrf forwarding ABC
>  ip address 192.168.16.6 255.255.255.0
>  duplex auto
>  speed auto
>  pppoe enable
> !
>
> !
> interface Virtual-Template 1
>  ip vrf forwarding ABC
>  ip unnumbered FastEthernet0/0
>  peer default ip address dhcp-pool PPPOE
>  ppp authentication chap
> !
> router ospf 100 vrf ABC
>  log-adjacency-changes
>  network 1.1.1.1 0.0.0.0 area 0
>  network 192.168.16.6 0.0.0.0 area 0
>
>
>
> Client config :-
>
>
> !
> interface Loopback0
>  ip address 2.2.2.2 255.255.255.255
> !
> interface FastEthernet0/0
>  no ip address
>  duplex auto
>  speed auto
>  pppoe enable
>  pppoe-client dial-pool-number 1
> !
> interface Dialer1
>  mtu 1492
>  ip address dhcp
>  encapsulation ppp
>  dialer pool 1
>  no peer neighbor-route
>  ppp chap hostname LAB
>  ppp chap password 0 LAB
> !
> router ospf 100
>  log-adjacency-changes
>  network 2.2.2.2 0.0.0.0 area 0
>  network 192.168.16.1 0.0.0.0 area 0
> !
>
>
>
> Server side :-
>
> Router#sh ip ospf neighbor
>
> Neighbor ID     Pri   State           Dead Time   Address         Interface
> 192.168.16.1        0   FULL/  -        00:00:35    192.168.16.1
> Virtual-Access2.1
> Router#
>
> Router#sh ip
> os
> Router#sh ip ospf
> da
> Router#sh ip ospf
> database
>
>            OSPF Router with ID (192.168.16.6) (Process ID 100)
>
>                Router Link States (Area 0)
>
> Link ID         ADV Router      Age         Seq#       Checksum Link count
> 192.168.16.1      192.168.16.1      722         0x8000001D 0x000717 3
> 192.168.16.6      192.168.16.6      485         0x80000019 0x00D3FF 3
> Router#
> Router#sh ip  route vr
> Router#sh ip  route vrf ABC
>
> Routing Table: ABC
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
>       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>       E1 - OSPF external type 1, E2 - OSPF external type 2
>       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
>       ia - IS-IS inter area, * - candidate default, U - per-user static
> route
>       o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is not set
>
>     1.0.0.0/32 is subnetted, 1 subnets
> C       1.1.1.1 is directly connected, Loopback0
>     2.0.0.0/32 is subnetted, 1 subnets
> O       2.2.2.2 [110/2] via 192.168.16.1, 00:08:10, Virtual-Access2.1
>     192.168.0.0/16 is variably subnetted, 2 subnets, 2 masks
> S       192.168.16.1/32 is directly connected, Virtual-Access2.1
> C       192.168.16.0/24 is directly connected, FastEthernet0/0
> Router#
>
>
> Client Side :-
>
> Router#sh ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
>       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>       E1 - OSPF external type 1, E2 - OSPF external type 2
>       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
>       ia - IS-IS inter area, * - candidate default, U - per-user static
> route
>       o - ODR, P - periodic downloaded static route
>
>
> Gateway of last resort is not set
>
>     2.0.0.0/32 is subnetted, 1 subnets
> C       2.2.2.2 is directly connected, Loopback0
>     192.168.0.0/24 is subnetted, 1 subnets
> C       192.168.16.0 is directly connected, Dialer1
> Router#sh ip ospf nei
> Router#sh ip ospf neighbor
>
> Neighbor ID     Pri   State           Dead Time   Address         Interface
> 192.168.16.6        0   FULL/  -        00:00:39    192.168.16.6
> Dialer1
> Router#
>
> Router#sh ip ospf database
>
>            OSPF Router with ID (192.168.16.1) (Process ID 100)
>
>                Router Link States (Area 0)
>
> Link ID         ADV Router      Age         Seq#       Checksum Link count
> 192.168.16.1      192.168.16.1      784         0x8000001D 0x000717 3
> 192.168.16.6      192.168.16.6      550         0x80000019 0x00D3FF 3
> Router#
>
> Thanks & Regards,
> Gaurav
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Fri Aug 20 2010 - 18:45:28 ART

This archive was generated by hypermail 2.2.0 : Wed Sep 01 2010 - 11:20:52 ART