sparse OIL problem

From: masroor ali <masror.ali_at_gmail.com>
Date: Thu, 12 Aug 2010 16:48:00 +0500

hi,

R6-----------------R4
         | |
         | |
         R1 |
           \ |
            \ /
                R5
                 |
                 |
                SW2
                 |
                SW4

I am running sprase-mode with static RP address, which is R5 lo0, when I
ping from R6 to group 224.20.20.20 which is configured at vlan 10 int of
SW4, I get the below debug message at R4,

*Mar 1 02:10:48.127: IP(0): s=155.1.146.6 (Ethernet0/1) d=224.20.20.20
id=18, ttl=254, prot=1, len=114(100), mroute olist null

please find the attached configuration for reference.

-- 
Regards,
Masroor Ali
Rack1SW4#show runn
Rack1SW4#show running-config 
Building configuration...
Current configuration : 2088 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW4
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing 
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.10.10 255.255.255.255
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
 description To R4 E0/1 
 switchport access vlan 146
!
interface FastEthernet1/5
!
interface FastEthernet1/6
 description To R6 E0/1
 switchport mode trunk
!
interface FastEthernet1/7
 description To SW1 F1/13
 switchport mode trunk
!
interface FastEthernet1/8
 description To SW1 F1/14
 switchport mode trunk
!         
interface FastEthernet1/9
 description To SW1 F1/15
 switchport mode trunk
!
interface FastEthernet1/10
 description To SW2 F1/13
 no switchport
 ip address 155.1.108.10 255.255.255.0
 ip pim sparse-mode
!
interface FastEthernet1/11
 description To SW2 F1/14
 switchport mode trunk
!
interface FastEthernet1/12
 description To SW2 F1/15
 switchport mode trunk
!
interface FastEthernet1/13
 description To SW3 F1/13
 switchport mode trunk
!
interface FastEthernet1/14
 description To SW3 F1/14
 switchport mode trunk
!
interface FastEthernet1/15
 description To SW3 F1/15
 switchport mode trunk
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 155.1.10.10 255.255.255.0
 ip igmp join-group 224.10.10.10
 ip igmp join-group 224.20.20.20
!
router eigrp 100
 network 150.1.0.0
 network 155.1.0.0
 no auto-summary
!
ip http server
ip forward-protocol nd
!         
!
ip pim rp-address 150.1.5.5
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
alias exec s show ip int bri
alias exec sr show runn
alias exec c configure terminal
alias exec r show ip route
alias exec v show vlan-switch  
!
line con 0
Rack1R6#show run
Rack1R6#show running-config 
Building configuration...
Current configuration : 1594 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R6
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing 
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback6
 ip address 150.1.6.6 255.255.255.255
!
interface Ethernet0/0
 no ip address
 full-duplex
!
interface Ethernet0/1
 no ip address
 full-duplex
!
interface Ethernet0/1.67
 encapsulation dot1Q 67
 ip address 155.1.67.6 255.255.255.0
!
interface Ethernet0/1.146
 encapsulation dot1Q 146
 ip address 155.1.146.6 255.255.255.0
 ip pim sparse-mode
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 100
 network 150.1.0.0
 network 155.1.0.0
 no auto-summary
!
ip http server
ip forward-protocol nd
!
!
ip pim rp-address 150.1.5.5
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
alias exec s show ip int bri
alias exec sr show runn
alias exec c configure terminal
alias exec r show ip route
alias exec v show vlan-switch  
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
!
end
Rack1R4#show runn
Rack1R4#show running-config 
Building configuration...
Current configuration : 1820 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R4
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing 
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.4.4 255.255.255.255
!
interface Ethernet0/0
 ip address 204.12.1.4 255.255.255.0
 full-duplex
!
interface Ethernet0/1
 ip address 155.1.146.4 255.255.255.0
 ip pim sparse-mode
 full-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 ip address 155.1.0.4 255.255.255.0
 ip hello-interval eigrp 100 30
 ip hold-time eigrp 100 60
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 155.1.0.1 405 broadcast
 frame-relay map ip 155.1.0.2 405 broadcast
 frame-relay map ip 155.1.0.3 405 broadcast
 frame-relay map ip 155.1.0.5 405 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1/1
 ip address 155.1.45.4 255.255.255.0
 ip pim sparse-mode
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 100
 network 150.1.0.0
 network 155.1.0.0
 no auto-summary
!
ip http server
ip forward-protocol nd
!
!
ip pim rp-address 150.1.5.5
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
alias exec s show ip int bri
alias exec sr show runn
alias exec c configure terminal
alias exec r show ip route
alias exec v show vlan-switch  
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
!
end
*Mar  1 02:21:14.599: IP(0): s=155.1.146.6 (Ethernet0/1) d=224.20.20.20 id=19, ttl=254, prot=1, len=114(100), mroute olist null
Rack1R4#
Rack1R4#
Rack1R4#
Rack1R4#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.20.20.20), 00:00:07/stopped, RP 150.1.5.5, flags: SP
  Incoming interface: Serial1/1, RPF nbr 155.1.45.5
  Outgoing interface list: Null
(155.1.146.6, 224.20.20.20), 00:00:07/00:02:52, flags: PT
  Incoming interface: Ethernet0/1, RPF nbr 155.1.146.6
  Outgoing interface list: Null
(*, 224.0.1.40), 01:27:17/00:02:40, RP 150.1.5.5, flags: SJCL
  Incoming interface: Serial1/1, RPF nbr 155.1.45.5
  Outgoing interface list:
    Ethernet0/1, Forward/Sparse, 01:03:58/00:02:51
Rack1R4#show ip rou
Rack1R4#show ip route 155.1.146.6
Routing entry for 155.1.146.0/24
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Redistributing via eigrp 100
  Routing Descriptor Blocks:
  * directly connected, via Ethernet0/1
      Route metric is 0, traffic share count is 1
Rack1R5#show runn
Rack1R5#show running-config 
Building configuration...
Current configuration : 1871 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R5
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing 
ip multicast rpf interval 6
ip multicast rpf backoff 10 200
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.5.5 255.255.255.255
!
interface Ethernet0/0
 ip address 155.1.58.5 255.255.255.0
 ip pim sparse-mode
 full-duplex
!
interface Ethernet0/1
 ip address 155.1.5.5 255.255.255.0
 full-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 ip address 155.1.0.5 255.255.255.0
 ip hello-interval eigrp 100 30
 ip hold-time eigrp 100 60
 ip pim sparse-mode
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 155.1.0.1 501 broadcast
 frame-relay map ip 155.1.0.2 501 broadcast
 frame-relay map ip 155.1.0.3 501 broadcast
 frame-relay map ip 155.1.0.4 501 broadcast
 no frame-relay inverse-arp
!
interface Serial1/1
 ip address 155.1.45.5 255.255.255.0
 ip pim sparse-mode
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!         
router eigrp 100
 network 150.1.0.0
 network 155.1.0.0
 no auto-summary
!
ip http server
ip forward-protocol nd
!
!
ip pim rp-address 150.1.5.5
!
!
!
!
control-plane
!
!
!
!
!
!
!
!         
alias exec s show ip int bri
alias exec sr show runn
alias exec c configure terminal
alias exec r show ip route
alias exec v show vlan-switch  
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
!
end
Blogs and organic groups at http://www.ccie.net
Received on Thu Aug 12 2010 - 16:48:00 ART

This archive was generated by hypermail 2.2.0 : Wed Sep 01 2010 - 11:20:52 ART