Re: BGP Not Advertising Locally Connected Network

From: Alexei Monastyrnyi <alexeim73_at_gmail.com>
Date: Tue, 25 May 2010 09:48:07 +1000

LG,
on R2 you have to have it like this
interface Loopback2
 ip address 172.16.2.1 255.255.255.0
!
router bgp 200
 network 172.16.2.0 mask 255.255.255.0
 network 172.16.4.0 mask 255.255.255.0 backdoor
and on R4 like this
interface Loopback4
 ip address 172.16.4.1 255.255.255.0
!
router bgp 400
 network 172.16.2.0 mask 255.255.255.0 backdoor
 network 172.16.4.0 mask 255.255.255.0
I just used a different set of loopbacks since it is not a good idea to play
with the ones you are using for peering.

HTH
A.

On 25 May 2010 02:39, Carlos G Mendioroz <tron_at_huapi.ba.ar> wrote:

> LG,
> can you please show the complete configuration, or at least
> the interfaces IP addresses ?
>
> Cause your network command is for 172.16.104.0/24 and I thought it might
> be that your loopback is on the 172.16.102.0/24 or even some other mask.
>
> -Carlos
>
> Carlos G Mendioroz @ 24/05/2010 11:02 -0300 dixit:
> > What about 102 != 104 ?
> >
> > Ladee Geek @ 24/05/2010 10:07 -0300 dixit:
> >> Hi All -
> >>
> >> this is a very very simple set up of eBgp peering via loopbacks and then
> >> advertising the local loopbacks. The idea is to get the candidate to
> >> realize the recursive routing issue and to use the backdoor command for
> the
> >> network statements. The problem is, my routers are not advertising the
> >> loopbacks? Any ideas?
> >>
> >>
> >> R4 <--> R2
> >>
> >> router bgp 400
> >> no synchronization
> >> bgp router-id 172.16.104.1
> >> bgp log-neighbor-changes
> >> network 172.16.104.0 mask 255.255.255.0 backdoor
> >> neighbor 172.16.102.1 remote-as 200
> >> neighbor 172.16.102.1 ebgp-multihop 255
> >> neighbor 172.16.102.1 update-source Loopback104
> >> no auto-summary
> >>
> >> R4#s bgp sum
> >> BGP router identifier 172.16.104.1, local AS number 400
> >> BGP table version is 1, main routing table version 1
> >> Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
> >> State/PfxRcd
> >> 172.16.102.1 4 200 38 38 1 0 0
> >> 00:36:35 0
> >>
> >>
> >> R4#sho ip bgp - you notice NOTHING is in the table
> >>
> >> R4#
> >>
> >> R4#sho ip bgp neighbors 172.16.102.1 advertised-routes
> >> Total number of prefixes *0 *
> >>
> >> interface Loopback104
> >> ip address 172.16.104.1 255.255.255.0
> >> ip pim sparse-mode
> >> ip igmp join-group 239.255.1.1
> >> ip ospf network point-to-point
> >>
> >>
> >> R4#show ip route 172.16.102.0
> >> Routing entry for 172.16.102.0/24
> >> Known via "ospf 1", distance 110, metric 20, type extern 2, forward
> metric
> >> 3
> >> Redistributing via rip
> >> Advertised by rip metric 15
> >> Last update from 172.16.10.6 on FastEthernet0/1, 00:41:06 ago
> >> Routing Descriptor Blocks:
> >> * 172.16.10.6, from 172.16.102.1, 00:41:06 ago, via FastEthernet0/1
> >> Route metric is 20, traffic share count is 1
> >>
> >
>
> --
> Carlos G Mendioroz <tron_at_huapi.ba.ar> LW7 EQI Argentina
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Tue May 25 2010 - 09:48:07 ART

This archive was generated by hypermail 2.2.0 : Tue Jun 01 2010 - 07:09:53 ART