Jeffrey,
How did you diagnose it as a routing loop? Does it happen while R1 is down
or after R1 comes back up?
On Thu, Apr 15, 2010 at 9:37 PM, Jeffrey Pazahanick <jeffpaz_at_gmail.com>wrote:
> I have a situation where I'm trying to advertise only 4 host routes
> from a /24 network to my BGP neighbors.
> As an example,
>
> #R1
> interface g0/0
> ip addr 1.1.1.2 255.255.255.0
> standby ip 1.1.1.1
>
> router bgp 1
> network 1.1.1.4 mask 255.255.255.255
> network 1.1.1.5 mask 255.255.255.255
> network 1.1.1.7 mask 255.255.255.255
> network 1.1.1.9 mask 255.255.255.255
>
> With a single router, a static route to the interface worked fine..
>
> ip route 1.1.1.4 255.255.255.255 g0/0
> ip route 1.1.1.5 255.255.255.255 g0/0
> ip route 1.1.1.7 255.255.255.255 g0/0
> ip route 1.1.1.9 255.255.255.255 g0/0
>
> When adding a redundant router, things initially work as well..
>
> #R2
> interface g0/0
> ip addr 1.1.1.3 255.255.255.0
> standby ip 1.1.1.1
>
> router bgp 1
> network 1.1.1.4 mask 255.255.255.255
> network 1.1.1.5 mask 255.255.255.255
> network 1.1.1.7 mask 255.255.255.255
> network 1.1.1.9 mask 255.255.255.255
>
> ip route 1.1.1.4 255.255.255.255 g0/0
> ip route 1.1.1.5 255.255.255.255 g0/0
> ip route 1.1.1.7 255.255.255.255 g0/0
> ip route 1.1.1.9 255.255.255.255 g0/0
>
> The issue arises when R1 fails, R2 has a CEF routing loop..
>
> Troubleshooting Cisco Express Forwarding Routing Loops
> Document ID: 26083
>
> http://www.cisco.com/en/US/partner/tech/tk827/tk831/technologies_tech_note09186a00800cdf2e.shtml
>
> The link says the solution is to point the statics to the next hop;
> which I can't, as they are local.
>
> Is there another way to advertise these host routes?
>
> I've been trying to use inject-maps, but my own routers are the route
> source, and it doesn't appear to work.
>
> Ideas?
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
>
-- Bryan Bartik CCIE #23707 (R&S, SP), CCNP Sr. Support Engineer - IPexpert, Inc. URL: http://www.IPexpert.com Blogs and organic groups at http://www.ccie.netReceived on Fri Apr 16 2010 - 10:29:56 ART
This archive was generated by hypermail 2.2.0 : Sat May 01 2010 - 09:49:57 ART