Hi All
I have a scenario in which the redistribution from level-2 into level-1 is
working fine, however, from my L1-L2 router, I have 2 L2 neighbors and I
want to filter out one of these L2 neighbor's routes from being
redistributed into level-1.
Setup is.
R1
-
-
- (L2)
-
- (L1)
R3 -------------------------R4
-
-
- (L2)
-
-
R2
On R3, I have this configuration but R4 still receives all routes.
R3#sh run
Building configuration...
Current configuration : 1305 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
clns filter-set CLNS deny 49.0001.0000.0000.0001.00
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 150.1.13.3 255.255.255.0
ip router isis
duplex auto
speed auto
clns enable
isis circuit-type level-2-only
!
interface FastEthernet1/0
ip address 150.1.23.3 255.255.255.0
ip router isis
duplex auto
speed auto
isis circuit-type level-2-only
!
interface FastEthernet2/0
ip address 150.1.34.3 255.255.255.0
ip router isis
duplex auto
speed auto
isis circuit-type level-1
!
router isis
net 49.0034.0000.0000.0003.00
redistribute isis ip level-2 into level-1 route-map CLNS
passive-interface Loopback0
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
route-map CLNS permit 10
match clns address CLNS
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
Blogs and organic groups at http://www.ccie.net
Received on Sat Jan 30 2010 - 08:37:54 ART
This archive was generated by hypermail 2.2.0 : Thu Feb 04 2010 - 20:28:42 ART