Re: Dual DMVPN cloud with 1 hub terminating two tunnels, equal

From: jeremy co <jeremy.cool14_at_gmail.com>
Date: Fri, 27 Nov 2009 12:29:59 +1100

Hi,

I still have problem and couldn't fix it.

(spoke) R2 ---------R7 -------------R6 (spoke) with 2 tunnel setup. running
EIGRP 101 inside dmvpn. and eigrp 1 on R2 Lan side

Problem is I have 2 equal path regardless that I changed both Bandwidth and
delay.

R2:

interface Tunnel0
 bandwidth 1000
 ip address 200.0.0.2 255.255.255.0
 no ip redirects
 ip nhrp map 200.0.0.7 7.7.7.7
 ip nhrp map multicast 7.7.7.7
 ip nhrp network-id 127
 ip nhrp nhs 200.0.0.7
 delay 10
 tunnel source Loopback0
 tunnel mode gre multipoint
interface Tunnel1
 bandwidth 10
 ip address 201.0.0.2 255.255.255.0
 no ip redirects
 ip nhrp map 201.0.0.7 7.7.7.71
 ip nhrp map multicast 7.7.7.71
 ip nhrp network-id 201
 ip nhrp nhs 201.0.0.7
 delay 1000
 tunnel source Loopback1
 tunnel mode gre multipoint

router eigrp 1
 network 10.0.23.2 0.0.0.0
 no auto-summary
router eigrp 101
 redistribute eigrp 1 metric 1 1 1 1 1
 network 200.0.0.2 0.0.0.0
 network 201.0.0.0
 auto-summary

R7:

interface Tunnel0
 bandwidth 1000
 ip address 200.0.0.7 255.255.255.0
 no ip redirects
 no ip next-hop-self eigrp 101
 ip nhrp map multicast dynamic
 ip nhrp network-id 127
 no ip split-horizon eigrp 101
 no ip split-horizon
 tunnel source Loopback0
 tunnel mode gre multipoint
interface Tunnel1
 bandwidth 10
 ip address 201.0.0.7 255.255.255.0
 no ip redirects
 no ip next-hop-self eigrp 101
 ip nhrp map multicast dynamic
 ip nhrp network-id 201
 no ip split-horizon eigrp 101
 no ip split-horizon
 tunnel source Loopback1
 tunnel mode gre multipoint

router eigrp 101
 network 200.0.0.7 0.0.0.0
 network 201.0.0.0
 no auto-summary

R6:

interface Tunnel0
 ip vrf forwarding intl
 ip address 200.0.0.6 255.255.255.0
 no ip redirects
 ip nhrp map multicast dynamic
 ip nhrp map 200.0.0.7 7.7.7.7
 ip nhrp map multicast 7.7.7.7
 ip nhrp network-id 127
 ip nhrp nhs 200.0.0.7
 tunnel source Loopback0
 tunnel mode gre multipoint
interface Tunnel1
 ip vrf forwarding intl
 ip address 201.0.0.6 255.255.255.0
 no ip redirects
 ip nhrp map multicast dynamic
 ip nhrp map 201.0.0.7 7.7.7.71
 ip nhrp map multicast 7.7.7.71
 ip nhrp network-id 201
 ip nhrp nhs 201.0.0.7
 tunnel source Loopback1
 tunnel mode gre multipoint

router eigrp 101
 auto-summary
 !
 address-family ipv4 vrf intl
 network 200.0.0.6 0.0.0.0
 network 201.0.0.0
 no auto-summary
 autonomous-system 101
 exit-address-family

R6:

C 200.0.0.0/24 is directly connected, Tunnel0
C 201.0.0.0/24 is directly connected, Tunnel1
     142.4.0.0/24 is subnetted, 1 subnets
D EX 142.4.64.0 [170/2585600256] via 201.0.0.2, 00:19:13, Tunnel1
                   [170/2585600256] via 200.0.0.7, 00:19:13, Tunnel0
     10.0.0.0/24 is subnetted, 2 subnets
D EX 10.0.23.0 [170/2585600256] via 201.0.0.2, 00:19:13, Tunnel1
                  [170/2585600256] via 200.0.0.7, 00:19:13, Tunnel0
D EX 10.0.35.0 [170/2585600256] via 201.0.0.2, 00:19:13, Tunnel1
                  [170/2585600256] via 200.0.0.7, 00:19:13, Tunnel0

Regards,

Jeremy

On Thu, Nov 26, 2009 at 7:03 PM, ajaz nawaz <ajaz.nawaz_at_gmail.com> wrote:

> What does the cef table look like?
> have you tried changing the eigrp lb method to 'per-packet'
>
> Ajaz Nawaz
> CCIE#15721
>
> 2009/11/25 jeremy co <jeremy.cool14_at_gmail.com>
>
>> Hi,
>>
>> I ran Dual DMVPN cloud with 1 hub terminating two tunnels
>> topology;everything works fine except after changing BW on tunnel
>> interfaces
>> ,still I have equal cost path problem on spoke, so I got two path toward
>> destinations from spoke to another spoke.
>>
>>
>> Hub:
>>
>> interface Tunnel0
>> bandwidth 1000
>> ip address 200.0.0.7 255.255.255.0
>> no ip redirects
>> no ip next-hop-self eigrp 101
>> ip nhrp map multicast dynamic
>> ip nhrp network-id 127
>> no ip split-horizon eigrp 101
>> no ip split-horizon
>> tunnel source Loopback0
>> tunnel mode gre multipoint
>>
>>
>> interface Tunnel1
>> bandwidth 10
>> ip address 201.0.0.7 255.255.255.0
>> no ip redirects
>> no ip next-hop-self eigrp 101
>> ip nhrp map multicast dynamic
>> ip nhrp network-id 201
>> no ip split-horizon eigrp 101
>> no ip split-horizon
>> tunnel source Loopback1
>> tunnel mode gre multipoint
>>
>>
>> Spoke :
>>
>> interface Tunnel1 ip address 201.0.0.6 255.255.255.0 no ip redirects ip
>> nhrp
>> map multicast dynamic ip nhrp map 201.0.0.7 7.7.7.71 ip nhrp map multicast
>> 7.7.7.71 ip nhrp network-id 201 ip nhrp nhs 201.0.0.7 tunnel source
>> Loopback1 tunnel mode gre multipoint interface Tunnel0 ip address
>> 200.0.0.6
>> 255.255.255.0 no ip redirects ip nhrp map multicast dynamic ip nhrp map
>> 200.0.0.7 7.7.7.7 ip nhrp map multicast 7.7.7.7 ip nhrp network-id 127 ip
>> nhrp nhs 200.0.0.7 tunnel source Loopback0 tunnel mode gre multipoint
>>
>> routing table on spoke :
>>
>> Rack1R6#sh ip route ei 142.4.0.0/24 is subnetted, 1 subnets D EX
>> 142.4.64.0
>> [170/2585600256] via 201.0.0.7, 00:19:09, Tunnel1 [170/2585600256] via
>> 200.0.0.7, 00:19:09, Tunnel0 10.0.0.0/24 is subnetted, 3 subnets D EX
>> 10.0.23.0 [170/2585600256] via 201.0.0.7, 00:40:52, Tunnel1
>> [170/2585600256]
>> via 200.0.0.2, 00:40:52, Tunnel0 D EX 10.0.35.0 [170/2585600256] via
>> 201.0.0.7, 00:19:09, Tunnel1 [170/2585600256] via 200.0.0.7, 00:19:09,
>> Tunnel0
>>
>>
>> why changing bw didn't affect IGP metric ?
>>
>>
>> Regards,
>> Jeremy
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Fri Nov 27 2009 - 12:29:59 ART

This archive was generated by hypermail 2.2.0 : Tue Dec 01 2009 - 06:36:29 ART