static routes will put them in the routing table, but actually route traffic
is another story....without BGP and route-targets not sure about leaking
between the two vrfs with ospf:
ip route vrf red 144.1.12.0 255.255.255.0 FastEthernet0/1 144.1.21.1
ip route vrf green 1.1.1.2 255.255.255.255 Loopback1 1.1.1.2
Router#sh ip route vrf red
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.2 is directly connected, Loopback1
144.1.0.0/24 is subnetted, 1 subnets
S 144.1.12.0 [1/0] via 144.1.21.1, FastEthernet0/1
133.1.0.0/24 is subnetted, 1 subnets
C 133.1.12.0 is directly connected, FastEthernet0/0
Router#sh ip route vrf green
1.0.0.0/32 is subnetted, 1 subnets
S 1.1.1.2 [1/0] via 1.1.1.2, Loopback1
144.1.0.0/24 is subnetted, 1 subnets
C 144.1.12.0 is directly connected, FastEthernet0/1
On Thu, Nov 26, 2009 at 9:23 PM, Bradford Hung <bradford.hung_at_gmail.com>wrote:
> Hi,
>
> Here is the configure:
>
> interface Loopback0
> ip address 1.1.1.1 255.255.255.255
> !
> interface Loopback1
> ip vrf forwarding red
> ip address 1.1.1.2 255.255.255.255
> !
> interface FastEthernet0/0
> ip vrf forwarding red
> ip address 133.1.12.1 255.255.255.0
> duplex auto
> speed auto
> mpls label protocol both
> !
> interface FastEthernet0/1
> ip vrf forwarding green
> ip address 144.1.12.1 255.255.255.0
> duplex auto
> speed auto
> !
> router ospf 100 vrf red
> log-adjacency-changes
> network 1.1.1.2 0.0.0.0 area 0
> network 133.1.12.0 0.0.0.255 area 0
> !
> router ospf 200 vrf green
> log-adjacency-changes
> network 144.1.12.0 0.0.0.255 area 0
>
> The question is how can I put the route "144.1.12.0/24" from vrf green to
> vrf red without bgp configuration?
>
> Thanks
>
> Regards,
> Hung
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
>
-- Garry L. Baker "There is no 'patch' for stupidity." - www.sqlsecurity.com Blogs and organic groups at http://www.ccie.netReceived on Thu Nov 26 2009 - 21:53:07 ART
This archive was generated by hypermail 2.2.0 : Tue Dec 01 2009 - 06:36:29 ART