Re: MPLS Traffic-Engineering Dynamic Tunnel

From: <armylegionmedic_at_aol.com>
Date: Fri, 30 Oct 2009 21:05:42 -0400

Hello Bryan,

   Thanks for your response, here is the info pulled from the config

R9

mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp router-id Loopback0
mpls label range 9000 9999
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
interface Tunnel98
 ip unnumbered Loopback0
 tunnel source Loopback0
 tunnel destination 32.32.0.8
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng autoroute metric relative -1
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth 500
 tunnel mpls traffic-eng path-option 10 dynamic
 no clns route-cache
!
interface Loopback0
 ip address 32.32.0.9 255.255.255.255
 ip router isis
 isis circuit-type level-1
!
!
interface FastEthernet0/0.29
 encapsulation dot1Q 29
 ip address 39.39.29.9 255.255.255.0
 ip router isis
 mpls ip
 isis network point-to-point
 isis csnp-interval 10
!
interface FastEthernet0/0.79
 encapsulation dot1Q 79
 ip address 39.39.79.9 255.255.255.0
 ip router isis
 mpls traffic-eng tunnels
 mpls ip
 isis network point-to-point
 isis csnp-interval 10
 ip rsvp bandwidth 2000

!
router isis
 net 52.0009.0000.0000.0009.00
 is-type level-1
 metric-style wide
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1

R8

mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp router-id Loopback0
mpls label range 8000 8999
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
interface Tunnel89
 ip unnumbered Loopback0
 tunnel source Loopback0
 tunnel destination 32.32.0.9
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth 500
 tunnel mpls traffic-eng path-option 10 dynamic
 no clns route-cache
!
interface Loopback0
 ip address 32.32.0.8 255.255.255.255
 ip router isis
!
!
interface FastEthernet1/0
 no ip address
 duplex full
 speed auto
!
interface FastEthernet1/0.28
 encapsulation dot1Q 28
 ip address 39.39.28.8 255.255.255.0
 ip router isis
 mpls traffic-eng tunnels
 mpls ip
 isis circuit-type level-1
 isis network point-to-point
 isis csnp-interval 10
 ip rsvp bandwidth 1000
!
!
interface FastEthernet1/0.78
 encapsulation dot1Q 78
 ip address 39.39.78.8 255.255.255.0
 ip router isis
 mpls ip
 isis circuit-type level-1
 isis hello-interval minimal
 isis network point-to-point
 no isis hello padding
 isis csnp-interval 10

!
router isis
 net 52.0009.0000.0000.0008.00
 is-type level-1
 metric-style wide

R2 and R7

both have

!
router isis
 net 52.0009.0000.0000.000X.00 --- X is based on their local Router number
 is-type level-1
 metric-style wide
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1

On the subinterfaces

R2 - .28 and .27 has the ip rsvp band 1000
R7 - .27 and .79 has the ip rsvp band 1000

I started with 5000 and 2000 on the tunnel but after the recommendation to
lower it, I tried lowering it but didnt help.

Here is the sh mpls traff topo

Rack1R8#
Rack1R8#show mpls traffic-eng topology
My_System_id: 0000.0000.0008.00 (isis level-1)

Signalling error holddown: 10 sec Global Link Generation 15

IGP Id: 0000.0000.0002.00, MPLS TE Id:32.32.0.2 Router Node (isis level-1)
      link[0]: Point-to-Point, Nbr IGP Id: 0000.0000.0008.00, nbr_node_id:1,
gen:5
          frag_id 0, Intf Address:39.39.28.2, Nbr Intf Address:39.39.28.8
          TE metric:10, IGP metric:10, attribute flags:0x0
          physical_bw: 10000 (kbps), max_reservable_bw_global: 2000 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool Sub Pool
               Total Allocated Reservable Reservable
               BW (kbps) BW (kbps) BW (kbps)
               --------------- ----------- ----------
        bw[0]: 0 2000 0
        bw[1]: 0 2000 0
        bw[2]: 0 2000 0
        bw[3]: 0 2000 0
        bw[4]: 0 2000 0
        bw[5]: 0 2000 0
        bw[6]: 0 2000 0
        bw[7]: 0 2000 0

      link[1]: Point-to-Point, Nbr IGP Id: 0000.0000.0007.00, nbr_node_id:2,
gen:5
          frag_id 0, Intf Address:39.39.27.2, Nbr Intf Address:39.39.27.7
          TE metric:10, IGP metric:10, attribute flags:0x0
          physical_bw: 10000 (kbps), max_reservable_bw_global: 2000 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool Sub Pool
               Total Allocated Reservable Reservable
               BW (kbps) BW (kbps) BW (kbps)
               --------------- ----------- ----------
        bw[0]: 0 2000 0
        bw[1]: 0 2000 0
        bw[2]: 0 2000 0
        bw[3]: 0 2000 0
        bw[4]: 0 2000 0
        bw[5]: 0 2000 0
        bw[6]: 0 2000 0
        bw[7]: 0 2000 0

IGP Id: 0000.0000.0007.00, MPLS TE Id:32.32.0.7 Router Node (isis level-1)

IGP Id: 0000.0000.0008.00, MPLS TE Id:32.32.0.8 Router Node (isis level-1)
      link[0]: Point-to-Point, Nbr IGP Id: 0000.0000.0002.00, nbr_node_id:3,
gen:15
          frag_id 0, Intf Address:39.39.28.8, Nbr Intf Address:39.39.28.2
          TE metric:10, IGP metric:10, attribute flags:0x0
          physical_bw: 100000 (kbps), max_reservable_bw_global: 1000 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool Sub Pool
               Total Allocated Reservable Reservable
               BW (kbps) BW (kbps) BW (kbps)
               --------------- ----------- ----------
        bw[0]: 0 1000 0
        bw[1]: 0 1000 0
        bw[2]: 0 1000 0
        bw[3]: 0 1000 0
        bw[4]: 0 1000 0
        bw[5]: 0 1000 0
        bw[6]: 0 1000 0
        bw[7]: 0 1000 0

IGP Id: 0000.0000.0009.00, MPLS TE Id:32.32.0.9 Router Node (isis level-1)
      link[0]: Point-to-Point, Nbr IGP Id: 0000.0000.0007.00, nbr_node_id:2,
gen:4
          frag_id 0, Intf Address:39.39.79.9, Nbr Intf Address:39.39.79.7
          TE metric:10, IGP metric:10, attribute flags:0x0
          physical_bw: 100000 (kbps), max_reservable_bw_global: 2000 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool Sub Pool
               Total Allocated Reservable Reservable
               BW (kbps) BW (kbps) BW (kbps)
               --------------- ----------- ----------
        bw[0]: 0 2000 0
        bw[1]: 0 2000 0
        bw[2]: 0 2000 0
        bw[3]: 0 2000 0
        bw[4]: 0 2000 0
        bw[5]: 0 2000 0
        bw[6]: 0 2000 0
        bw[7]: 0 2000 0

Rack1R9#sh mpls traffic-eng ?
  autoroute Autorouted tunnel destination information
  forwarding-adjacency forwarding-adjacency tunnel destination information
  link-management Link Management information
  topology Show topology Commands
  tunnels MPLS traffic-eng tunnel status

Rack1R9#sh mpls traffic-eng topo
My_System_id: 0000.0000.0009.00 (isis level-1)

Signalling error holddown: 10 sec Global Link Generation 12

IGP Id: 0000.0000.0002.00, MPLS TE Id:32.32.0.2 Router Node (isis level-1)
      link[0]: Point-to-Point, Nbr IGP Id: 0000.0000.0008.00, nbr_node_id:4,
gen:6
          frag_id 0, Intf Address:39.39.28.2, Nbr Intf Address:39.39.28.8
          TE metric:10, IGP metric:10, attribute flags:0x0
          physical_bw: 10000 (kbps), max_reservable_bw_global: 2000 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool Sub Pool
               Total Allocated Reservable Reservable
               BW (kbps) BW (kbps) BW (kbps)
               --------------- ----------- ----------
        bw[0]: 0 2000 0
        bw[1]: 0 2000 0
        bw[2]: 0 2000 0
        bw[3]: 0 2000 0
        bw[4]: 0 2000 0
        bw[5]: 0 2000 0
        bw[6]: 0 2000 0
        bw[7]: 0 2000 0

      link[1]: Point-to-Point, Nbr IGP Id: 0000.0000.0007.00, nbr_node_id:3,
gen:6
          frag_id 0, Intf Address:39.39.27.2, Nbr Intf Address:39.39.27.7
          TE metric:10, IGP metric:10, attribute flags:0x0
          physical_bw: 10000 (kbps), max_reservable_bw_global: 2000 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool Sub Pool
               Total Allocated Reservable Reservable
               BW (kbps) BW (kbps) BW (kbps)
               --------------- ----------- ----------
        bw[0]: 0 2000 0
        bw[1]: 0 2000 0
        bw[2]: 0 2000 0
        bw[3]: 0 2000 0
        bw[4]: 0 2000 0
        bw[5]: 0 2000 0
        bw[6]: 0 2000 0
        bw[7]: 0 2000 0

IGP Id: 0000.0000.0007.00, MPLS TE Id:32.32.0.7 Router Node (isis level-1)

IGP Id: 0000.0000.0008.00, MPLS TE Id:32.32.0.8 Router Node (isis level-1)
      link[0]: Point-to-Point, Nbr IGP Id: 0000.0000.0002.00, nbr_node_id:2,
gen:12
          frag_id 0, Intf Address:39.39.28.8, Nbr Intf Address:39.39.28.2
          TE metric:10, IGP metric:10, attribute flags:0x0
          physical_bw: 100000 (kbps), max_reservable_bw_global: 1000 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool Sub Pool
               Total Allocated Reservable Reservable
               BW (kbps) BW (kbps) BW (kbps)
               --------------- ----------- ----------
        bw[0]: 0 1000 0
        bw[1]: 0 1000 0
        bw[2]: 0 1000 0
        bw[3]: 0 1000 0
        bw[4]: 0 1000 0
        bw[5]: 0 1000 0
        bw[6]: 0 1000 0
        bw[7]: 0 1000 0

IGP Id: 0000.0000.0009.00, MPLS TE Id:32.32.0.9 Router Node (isis level-1)
      link[0]: Point-to-Point, Nbr IGP Id: 0000.0000.0007.00, nbr_node_id:-1,
gen:1
          frag_id 0, Intf Address:39.39.79.9, Nbr Intf Address:39.39.79.7
          TE metric:10, IGP metric:10, attribute flags:0x0
          physical_bw: 100000 (kbps), max_reservable_bw_global: 2000 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool Sub Pool
               Total Allocated Reservable Reservable
               BW (kbps) BW (kbps) BW (kbps)
               --------------- ----------- ----------
        bw[0]: 0 2000 0
        bw[1]: 0 2000 0
        bw[2]: 0 2000 0
        bw[3]: 0 2000 0
        bw[4]: 0 2000 0
        bw[5]: 0 2000 0
        bw[6]: 0 2000 0
        bw[7]: 0 2000 0

Thanks again for all your help and responses I do very much so appreciate it.

Regards,

James

-----Original Message-----
From: Bryan Bartik <bbartik_at_ipexpert.com>
To: Shawn Zandi <szmetal_at_gmail.com>
Cc: armylegionmedic_at_aol.com; nilsi2002_at_gmail.com; divinjohn_at_gmail.com;
vsrinivas.paturi_at_gmail.com; ccielab_at_groupstudy.com
Sent: Fri, Oct 30, 2009 10:43 am
Subject: Re: MPLS Traffic-Engineering Dynamic Tunnel

"No path to destination" can be misleading because it does not really mean
there is no route. It just means it cannot calculate a path that meets the
requirements of the tunnel. I am curious to see the full configs as well as
"show mpls traffic-eng topology."

On Fri, Oct 30, 2009 at 9:29 AM, Shawn Zandi <szmetal_at_gmail.com> wrote:

Army,

Last Error: PCALC:: No path to destination, 0000.0000.0008.00

Last Error: PCALC:: No path to destination, 0000.0000.0009.00

R8 does not have route to loopback of R9, and R9 does not have route to

loopback of R8. Enable ISIS on loopbacks by "ip router isis" or change your

TE router-ID to reachable ones.

--
Sincerely,
Shawn Zandi
Network Architect and Consultant
Cisco Certified CCIE x2 (R&S, Security)
Juniper, Foundry, Brocade and Procurve Certified
http://blog.shafagh.com
On Fri, Oct 30, 2009 at 6:45 PM, <armylegionmedic_at_aol.com> wrote:
> Hello Rich,
>
>
>    Thank you very much for the response. The command metric-style wide is
> in
> all the routers. When I type the command mpls traffic-eng level-* it will
> always tell me if there is no metric-style wide initiated. I have also gone
> through and checked all the routers.
>
>
> Regards,
>
>
> James
>
>
> -----Original Message-----
> From: Rich Collins <nilsi2002_at_gmail.com>
> To: Divin Mathew John <divinjohn_at_gmail.com>
> Cc: srinivas pv <vsrinivas.paturi_at_gmail.com>; armylegionmedic_at_aol.com;
> ccielab_at_groupstudy.com
> Sent: Fri, Oct 30, 2009 7:07 am
> Subject: Re: MPLS Traffic-Engineering Dynamic Tunnel
>
>
>
>
>
>
>
>
> Hi,
>
> Your problem is that all isis router instances should be metric-style
> wide for traffic engineering.
>
> If you do a show ip route isis you are probably missing some
> destinations (for the same above reason).
>
> -Rich
>
>
>
>
> > On Fri, Oct 30, 2009 at 9:00 AM, srinivas pv
> <vsrinivas.paturi_at_gmail.com>wrote:
> >
> >> Hi,
> >>
> >> You are getting following error:
> >>    Path Option 10:
> >>     Last Error: PCALC:: No path to destination, 0000.0000.0008.00
> >>
> >> You can check why you are getting this.
> >> Can you give following show outputs from both R8 and R9
> >>
> >> show mpls traffic-eng topology brief
> >> show mpls traffic-eng tunnels topology path destination <tunnel dest
> addr>
> >> show mpls traffic-eng tunnels topology path destination <tunnel dest
> addr>
> >> bandwidth
> >> show mpls traffic-eng tunnels topology path destination <tunnel dest
> addr>
> >> priority
> >> show mpls traffic-eng tunnels topology path tunnel89
> >> show mpls traffic-eng tunnels topology path tunnel89 bandwidth
> >> show mpls traffic-eng tunnels topology path tunnel89 priority
> >>
> >>
> >> Thanks,
> >> Srinivas
> >>
> >>
> >> On Fri, Oct 30, 2009 at 6:12 AM, <armylegionmedic_at_aol.com> wrote:
> >>
> >> > Hello Experts,
> >> >
> >> >   I have been troubleshooting this for like 2 hours now and just
> cannot
> >> see
> >> > what is wrong. I have read through the IPExpert article and tried the
> >> auto
> >> > bw
> >> > commands and it made no difference. Also, I am able to ping perfectly
> >> fine.
> >> > I
> >> > am trying to go R8-R2-R7-R9 and reverse path back, but my tunnel on R8
> >> and
> >> > R9
> >> > will not come online. I have also lowered the bandwidth on the RSVP as
> >> well
> >> > as
> >> > on the tunnel and this didnt help.
> >> >
> >> > Here is the config:
> >> >
> >> > R2
> >> > mpls traffic-eng tunn
> >> > router isis
> >> > mpls traffic-eng level-1
> >> > mpls traffic-eng rou lo0
> >> > int e0/0.28
> >> > mpls traffic-eng tunn
> >> > ip rsvp band 5000
> >> > int e0/0.27
> >> > mpls traffic-eng tunn
> >> > ip rsvp band 5000
> >> > r7
> >> > mpls traffic-eng tunn
> >> > router isis
> >> > mpls traffic-eng rout lo0
> >> > mpls traffic-eng level-1
> >> > int f1/0.27
> >> > mpls traffic-eng tunn
> >> > ip rsvp band 5000
> >> > int f1/0.79
> >> > mpls traffic-eng tunn
> >> > ip rsvp band 5000
> >> > r8
> >> > mpls traffic-eng tunn
> >> > router isis
> >> > mpls traffic-eng rou lo0
> >> > mpls traffic-eng level-1
> >> > int f1/0.28
> >> > mpls traffic-eng tunn
> >> > ip rsvp band 5000
> >> > int tunn 89
> >> > ip unn lo0
> >> > tunn so lo0
> >> > tunn dest 32.32.0.9
> >> > tunn mode mpls traffic-eng
> >> > tunn mpls traffic-eng prio 7 7
> >> > tunn mpls traffic-eng band 2000
> >> > tunn mpls traffic-eng path-opt 10 dynamic
> >> > tunn mpls traffic-eng autoroute announce
> >> > r9
> >> > mpls traffic-eng tunn
> >> > router isis
> >> > metric-sty wide
> >> > mpls traffic-eng rou lo0
> >> > mpls traffic-eng level-1
> >> > int f1/0.79
> >> > mpls traffic-eng tunn
> >> > ip rsvp band 5000
> >> > int tunn 98
> >> > ip unn lo0
> >> > tunn so lo0
> >> > tunn dest 32.32.0.8
> >> > tunn mode mpls traffic-eng
> >> > tunn mpls traffic-eng prio 7 7
> >> > tunn mpls traffic-eng band 2000
> >> > tunn mpls traffic-eng path-opt 10 dynamic
> >> > tunn mpls traffic-eng autoroute announce
> >> >
> >> > If I do a sh mpls traff tunn I get
> >> >
> >> > R9
> >> >
> >> > Rack1R9(config-if)#do sh mpls traffi tunn
> >> > Name: Rack1R9_t98                         (Tunnel98) Destination:
> >> 32.32.0.8
> >> >  Status:
> >> >    Admin: up         Oper: down   Path: not valid   Signalling: Down
> >> >    path option 10, type dynamic
> >> >  Config Parameters:
> >> >    Bandwidth: 2000      kbps (Global)  Priority: 7  7   Affinity:
> >> > 0x0/0xFFFF
> >> >    Metric Type: TE (default)
> >> >    AutoRoute:  enabled   LockDown: disabled  Loadshare: 500
> bw-based
> >> >    auto-bw: disabled
> >> >  History:
> >> >    Tunnel:
> >> >      Time since created: 32 minutes, 28 seconds
> >> >    Path Option 10:
> >> >      Last Error: PCALC:: No path to destination, 0000.0000.0008.00
> >> >
> >> > R8
> >> > Rack1R8(config-if)#do sh mpls traffi tunn
> >> > Name: Rack1R8_t89                         (Tunnel89) Destination:
> >> 32.32.0.9
> >> >  Status:
> >> >    Admin: up         Oper: down   Path: not valid   Signalling: Down
> >> >    path option 10, type dynamic
> >> >  Config Parameters:
> >> >    Bandwidth: 500      kbps (Global)  Priority: 7  7   Affinity:
> >> 0x0/0xFFFF
> >> >    Metric Type: TE (default)
> >> >    AutoRoute:  enabled   LockDown: disabled  Loadshare: 500
> bw-based
> >> >    auto-bw: disabled
> >> >  History:
> >> >    Tunnel:
> >> >      Time since created: 33 minutes, 15 seconds
> >> >    Path Option 10:
> >> >      Last Error: PCALC:: No path to destination, 0000.0000.0009.00
> >> > Rack1R8(config-if)#
> >> >
> >> > TIA for any help.
> >> >
> >> > Regards,
> >> >
> >> > James
> >> >
> >> >
> >> > Blogs and organic groups at http://www.ccie.net
> >> >
> >> >
> _______________________________________________________________________
> >> > Subscription information may be found at:
> >> > http://www.groupstudy.com/list/CCIELab.html
> >>
> >>
> >> Blogs and organic groups at http://www.ccie.net
> >>
> >> _______________________________________________________________________
> >> Subscription information may be found at:
> >> http://www.groupstudy.com/list/CCIELab.html
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >
> >
> > --
> >
> > Sent from Karnataka, India
> > Jean Cocteau <http://www.quotationspage.com/quote/1031.html>  - "We must
> > believe in luck. For how else can we explain the success of those we
> don't
> > like?"
> >
> >
> > Blogs and organic groups at http://www.ccie.net
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Fri Oct 30 2009 - 21:05:42 ART

This archive was generated by hypermail 2.2.0 : Sun Nov 01 2009 - 07:51:01 ART