Re: OSPF --) prefix-suppression

From: garry baker <baker.garry_at_gmail.com>
Date: Wed, 28 Oct 2009 08:33:11 +0300

ALL, i think you could play around with this thing, like you are saying if
you needed it to do what it does, but the basic idea i think is good to go
for now that it just suppresses local route from being advertised...

so more tests with another router R3, and in another area....

hope this helps you out...

<loop0 area1> R3 <-area0-> R1 <-area0-> R2

added R3:
interface Loopback0
 ip address 129.53.3.3 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 1
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 2.2.2.3 255.255.255.0
 ip ospf 1 area 0
 duplex auto
 speed auto
!
router ospf 1
 router-id 2.2.2.3
 log-adjacency-changes

R2:

R2#sh ip route
     1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
O 2.2.2.0 [110/20] via 1.1.1.1, 09:58:19, FastEthernet0/0
     100.0.0.0/32 is subnetted, 1 subnets
O 100.100.100.1 [110/11] via 1.1.1.1, 09:58:44, FastEthernet0/0
     3.0.0.0/24 is subnetted, 1 subnets
O 3.3.3.0 [110/20] via 1.1.1.1, 09:58:44, FastEthernet0/0
     129.53.0.0/24 is subnetted, 1 subnets
O IA 129.53.3.0 [110/21] via 1.1.1.1, 00:01:54, FastEthernet0/0
     9.0.0.0/24 is subnetted, 1 subnets
O 9.9.9.0 [110/11] via 1.1.1.1, 00:03:59, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
O 10.10.10.0 [110/11] via 1.1.1.1, 00:04:00, FastEthernet0/0

ON R1 global prefix-supression:
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router ospf 1
R1(config-router)#prefix-suppression

R2: the 9.0.0.0/24 is gone which is the primary IP from f1/0 on R1, but the
129.53.0.0/24 still goes through from R3...

R2#sh ip route

     1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, FastEthernet0/0
     100.0.0.0/32 is subnetted, 1 subnets
O 100.100.100.1 [110/11] via 1.1.1.1, 10:00:00, FastEthernet0/0
     3.0.0.0/24 is subnetted, 1 subnets
O 3.3.3.0 [110/20] via 1.1.1.1, 10:00:00, FastEthernet0/0
     129.53.0.0/24 is subnetted, 1 subnets
O IA 129.53.3.0 [110/21] via 1.1.1.1, 00:03:10, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
O 10.10.10.0 [110/11] via 1.1.1.1, 00:05:15, FastEthernet0/0

R1#sh run int f1/0
Building configuration...

Current configuration : 158 bytes
!
interface FastEthernet1/0
 ip address 10.10.10.10 255.255.255.0 secondary
 ip address 9.9.9.9 255.255.255.0
 ip ospf 1 area 0
 duplex auto
 speed auto
end

also added secondary ip address 7.7.7.3 on R3, and that route is making it
to R2 as well through R1, so the suppression is just on the local router,
which makes sense, i guess?? in the overall idea of what this command is for

R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#int f0/1
R3(config-if)#ip address 7.7.7.3 255.255.255.0 secondary
R3(config-if)#do sh run int f0/1
Building configuration...

Current configuration : 154 bytes
!
interface FastEthernet0/1
 ip address 7.7.7.3 255.255.255.0 secondary
 ip address 2.2.2.3 255.255.255.0
 ip ospf 1 area 0
 duplex auto
 speed auto
end

R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, FastEthernet0/0
     100.0.0.0/32 is subnetted, 1 subnets
O 100.100.100.1 [110/11] via 1.1.1.1, 10:03:44, FastEthernet0/0
     3.0.0.0/24 is subnetted, 1 subnets
O 3.3.3.0 [110/20] via 1.1.1.1, 10:03:44, FastEthernet0/0
     7.0.0.0/24 is subnetted, 1 subnets
O 7.7.7.0 [110/30] via 1.1.1.1, 00:00:02, FastEthernet0/0
     129.53.0.0/24 is subnetted, 1 subnets
O IA 129.53.3.0 [110/21] via 1.1.1.1, 00:06:54, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
O 10.10.10.0 [110/11] via 1.1.1.1, 00:09:00, FastEthernet0/0

On Wed, Oct 28, 2009 at 1:47 AM, ALL From_NJ <all.from.nj_at_gmail.com> wrote:

> Many thanks Garry for the follow up and testing.
>
> My comments were a bit vague there ... I was referring to this feature
> itself being a little odd to me. Not advertising all routes can be good, if
> this is now you have engineered your network. Perhaps the edge loopbacks
> only need to be learned for reachability ...
>
> In your testing, did R1 learn any routes from another router, and did it
> pass them on to R2 after this feature was configured? My intitial thought,
> was that this feature would cause R1 to not be a transit router because it
> would not forward other prefixes. It would only forward LSAs for loops, and
> secondaries ...
>
> Perhaps I am not understanding this feature. Were you able to test this?
>
> Many, many thanks Garry!
>
> Andrew Lee Lissitz
>
>
>
> On Tue, Oct 27, 2009 at 3:37 PM, garry baker <baker.garry_at_gmail.com>wrote:
>
>> not sure what you were looking for with this "I suppose those prefixes
>> would be advertised, not as connected, but as external. Seems a bit odd ...
>> unfortunately, I do not have a way to test. Any one ever lab this up?"
>>
>> some other way to test this feature that you are thinking?
>>
>> But i got the 12.4(15)T7 and was able to see this command in action, good
>> to see that i got the right code and the command is there:
>>
>> R1 <-> R2
>>
>>
>> R1#sh ip int brief
>> Interface IP-Address OK? Method
>> Status Protocol
>> FastEthernet0/0 1.1.1.1 YES manual
>> up up
>> FastEthernet0/1 2.2.2.2 YES manual
>> up up
>> Loopback0 100.100.100.1 YES manual
>> up up
>>
>> R1#sh run int f0/1
>> interface FastEthernet0/1
>> ip address 3.3.3.3 255.255.255.0 secondary
>> ip address 2.2.2.2 255.255.255.0
>>
>> ip ospf 1 area 0
>>
>>
>> R2#sh ip route
>>
>> 1.0.0.0/24 is subnetted, 1 subnets
>> C 1.1.1.0 is directly connected, FastEthernet0/0
>> 2.0.0.0/24 is subnetted, 1 subnets
>> O 2.2.2.0 [110/20] via 1.1.1.1, 00:00:02, FastEthernet0/0
>> 100.0.0.0/32 is subnetted, 1 subnets
>> O 100.100.100.1 [110/11] via 1.1.1.1, 00:00:02, FastEthernet0/0
>>
>> 3.0.0.0/24 is subnetted, 1 subnets
>> O 3.3.3.0 [110/20] via 1.1.1.1, 00:00:02, FastEthernet0/0
>>
>>
>> R1#conf t
>>
>> Enter configuration commands, one per line. End with CNTL/Z.
>> R1(config)#router ospf 1
>> R1(config-router)#prefix-suppression ?
>> <cr>
>>
>> R1(config-router)#prefix-suppression
>>
>>
>> R2#sh ip route
>>
>> 1.0.0.0/24 is subnetted, 1 subnets
>> C 1.1.1.0 is directly connected, FastEthernet0/0
>> 100.0.0.0/32 is subnetted, 1 subnets
>> O 100.100.100.1 [110/11] via 1.1.1.1, 00:02:14, FastEthernet0/0
>>
>> 3.0.0.0/24 is subnetted, 1 subnets
>> O 3.3.3.0 [110/20] via 1.1.1.1, 00:02:14, FastEthernet0/0
>>
>>
>> THEN TRY IT AT THE INTERFACE LEVEL:
>> R1#sh run interface f0/1
>>
>> interface FastEthernet0/1
>> ip address 3.3.3.3 255.255.255.0 secondary
>> ip address 2.2.2.2 255.255.255.0
>>
>> ip ospf 1 area 0
>>
>> interface FastEthernet1/0
>> ip address 10.10.10.10 255.255.255.0 secondary
>> ip address 9.9.9.9 255.255.255.0
>>
>> ip ospf 1 area 0
>>
>> R2#sh ip route
>>
>> 1.0.0.0/24 is subnetted, 1 subnets
>> C 1.1.1.0 is directly connected, FastEthernet0/0
>> 2.0.0.0/24 is subnetted, 1 subnets
>> O 2.2.2.0 [110/20] via 1.1.1.1, 00:00:01, FastEthernet0/0
>> 100.0.0.0/32 is subnetted, 1 subnets
>> O 100.100.100.1 [110/11] via 1.1.1.1, 00:00:25, FastEthernet0/0
>>
>> 3.0.0.0/24 is subnetted, 1 subnets
>> O 3.3.3.0 [110/20] via 1.1.1.1, 00:00:25, FastEthernet0/0
>>
>> 9.0.0.0/24 is subnetted, 1 subnets
>> O 9.9.9.0 [110/11] via 1.1.1.1, 00:00:01, FastEthernet0/0
>> 10.0.0.0/24 is subnetted, 1 subnets
>> O 10.10.10.0 [110/11] via 1.1.1.1, 00:00:25, FastEthernet0/0
>>
>>
>> R1(config)#int f1/0
>> R1(config-if)#ip ospf prefix-suppression ?
>> disable Disable prefix suppression
>> <cr>
>>
>> R1(config-if)#ip ospf prefix-suppression
>>
>>
>> R2#sh ip route
>>
>> 1.0.0.0/24 is subnetted, 1 subnets
>> C 1.1.1.0 is directly connected, FastEthernet0/0
>> 2.0.0.0/24 is subnetted, 1 subnets
>> O 2.2.2.0 [110/20] via 1.1.1.1, 00:02:29, FastEthernet0/0
>> 100.0.0.0/32 is subnetted, 1 subnets
>> O 100.100.100.1 [110/11] via 1.1.1.1, 00:02:54, FastEthernet0/0
>>
>> 3.0.0.0/24 is subnetted, 1 subnets
>> O 3.3.3.0 [110/20] via 1.1.1.1, 00:02:54, FastEthernet0/0
>> 10.0.0.0/24 is subnetted, 1 subnets
>> O 10.10.10.0 [110/11] via 1.1.1.1, 00:02:54, FastEthernet0/0
>>
>>
>>
>> R1#sh ip ospf interface
>> FastEthernet1/0 is up, line protocol is up
>> Internet Address 9.9.9.9/24, Area 0
>> Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
>> Enabled by interface config, including secondary ip addresses
>> Prefix-suppression is enabled
>> Transmit Delay is 1 sec, State DR, Priority 1
>> Designated Router (ID) 1.1.1.1, Interface address 9.9.9.9
>> No backup designated router on this network
>> Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>> oob-resync timeout 40
>> Hello due in 00:00:00
>> Supports Link-local Signaling (LLS)
>> Cisco NSF helper support enabled
>> IETF NSF helper support enabled
>> Index 4/4, flood queue length 0
>> Next 0x0(0)/0x0(0)
>> Last flood scan length is 0, maximum is 0
>> Last flood scan time is 0 msec, maximum is 0 msec
>> Neighbor Count is 0, Adjacent neighbor count is 0
>> Suppress hello for 0 neighbor(s)
>> FastEthernet0/1 is up, line protocol is up
>> Internet Address 2.2.2.2/24, Area 0
>> Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 10
>> Enabled by interface config, including secondary ip addresses
>> Transmit Delay is 1 sec, State DR, Priority 1
>> Designated Router (ID) 1.1.1.1, Interface address 2.2.2.2
>> No backup designated router on this network
>> Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>> oob-resync timeout 40
>> Hello due in 00:00:05
>> Supports Link-local Signaling (LLS)
>> Cisco NSF helper support enabled
>> IETF NSF helper support enabled
>> Index 3/3, flood queue length 0
>> Next 0x0(0)/0x0(0)
>> Last flood scan length is 0, maximum is 0
>> Last flood scan time is 0 msec, maximum is 0 msec
>> Neighbor Count is 0, Adjacent neighbor count is 0
>> Suppress hello for 0 neighbor(s)
>> FastEthernet0/0 is up, line protocol is up
>> Internet Address 1.1.1.1/24, Area 0
>> Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 10
>> Enabled by interface config, including secondary ip addresses
>> Transmit Delay is 1 sec, State BDR, Priority 1
>> Designated Router (ID) 1.1.1.2, Interface address 1.1.1.2
>> Backup Designated router (ID) 1.1.1.1, Interface address 1.1.1.1
>> Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>> oob-resync timeout 40
>> Hello due in 00:00:01
>> Supports Link-local Signaling (LLS)
>> Cisco NSF helper support enabled
>> IETF NSF helper support enabled
>> Index 2/2, flood queue length 0
>> Next 0x0(0)/0x0(0)
>> Last flood scan length is 1, maximum is 1
>> Last flood scan time is 0 msec, maximum is 0 msec
>> Neighbor Count is 1, Adjacent neighbor count is 1
>> Adjacent with neighbor 1.1.1.2 (Designated Router)
>> Suppress hello for 0 neighbor(s)
>> Loopback0 is up, line protocol is up
>> Internet Address 100.100.100.1/24, Area 0
>> Process ID 1, Router ID 1.1.1.1, Network Type LOOPBACK, Cost: 1
>> Enabled by interface config, including secondary ip addresses
>> Loopback interface is treated as a stub Host
>>
>>
>>
>>
>>
>>
>> On Tue, Oct 27, 2009 at 9:23 PM, ALL From_NJ <all.from.nj_at_gmail.com>wrote:
>>
>>> Hey guys,
>>>
>>> Thanks for the responses.
>>>
>>> Team - this command will advertise loops, secondary addresses, and
>>> passive interfaces. huh? Not advertising directly connected interfaces ,,,
>>> rules out the possibility of redistribution on the same router? Just
>>> thinking of the type 4 LSA that would normally be sent ...
>>>
>>> I suppose those prefixes would be advertised, not as connected, but as
>>> external. Seems a bit odd ... unfortunately, I do not have a way to test.
>>> Any one ever lab this up?
>>>
>>> Many thanks Garry for the response and lab test!
>>>
>>> Andrew
>>>
>>>
>>>
>>> On Tue, Oct 27, 2009 at 12:06 PM, garry baker <baker.garry_at_gmail.com>wrote:
>>>
>>>> guess i need to load the T version (12.4(15)T) cause i didnt have this
>>>> command on my 12.4(21a) routers...
>>>>
>>>> but in my attempt to test i found this interface command:
>>>>
>>>> ip ospf 1 area 0 secondaries none
>>>>
>>>> similar but not the same? not sure, but i dig this two router testing
>>>> idea...
>>>>
>>>> R4 <-> R3
>>>>
>>>> R4:
>>>> interface Loopback0
>>>> ip address 200.4.4.4 255.255.255.0
>>>> ip ospf 1 area 0
>>>> !
>>>> interface FastEthernet0/0
>>>> ip address 1.1.1.4 255.255.255.0
>>>> ip ospf 1 area 0
>>>> duplex auto
>>>> speed auto
>>>> !
>>>> interface FastEthernet0/1
>>>> ip address 3.3.3.4 255.255.255.0 secondary
>>>> ip address 2.2.2.4 255.255.255.0
>>>> ip ospf 1 area 0
>>>>
>>>>
>>>> R3#sh ip route
>>>> 200.4.4.0/32 is subnetted, 1 subnets
>>>> O 200.4.4.4 [110/11] via 1.1.1.4, 00:02:41, FastEthernet0/0
>>>> 1.0.0.0/24 is subnetted, 1 subnets
>>>> C 1.1.1.0 is directly connected, FastEthernet0/0
>>>> 2.0.0.0/24 is subnetted, 1 subnets
>>>> O 2.2.2.0 [110/20] via 1.1.1.4, 00:02:41, FastEthernet0/0
>>>> 100.0.0.0/24 is subnetted, 1 subnets
>>>> C 100.3.3.0 is directly connected, Loopback0
>>>> 3.0.0.0/24 is subnetted, 1 subnets
>>>> O 3.3.3.0 [110/20] via 1.1.1.4, 00:02:41, FastEthernet0/0
>>>>
>>>> R4:
>>>> R4#conf t
>>>> Enter configuration commands, one per line. End with CNTL/Z.
>>>> R4(config)#int f0/1
>>>> R4(config-if)#ip ospf 1 area 0 secondaries none
>>>> R4(config-if)#
>>>>
>>>> THE secondary from int f0/1 on R4 disappears on R3:
>>>> R3:
>>>> R3#sh ip route
>>>> 200.4.4.0/32 is subnetted, 1 subnets
>>>> O 200.4.4.4 [110/11] via 1.1.1.4, 00:00:09, FastEthernet0/0
>>>> 1.0.0.0/24 is subnetted, 1 subnets
>>>> C 1.1.1.0 is directly connected, FastEthernet0/0
>>>> 2.0.0.0/24 is subnetted, 1 subnets
>>>> O 2.2.2.0 [110/20] via 1.1.1.4, 00:00:09, FastEthernet0/0
>>>> 100.0.0.0/24 is subnetted, 1 subnets
>>>> C 100.3.3.0 is directly connected, Loopback0
>>>>
>>>>
>>>> On Tue, Oct 27, 2009 at 6:32 PM, ALL From_NJ <all.from.nj_at_gmail.com>wrote:
>>>>
>>>>> Similar as the default EIGRP stub feature? Seems this way ... Only
>>>>> not as
>>>>> versatile with it's options ...
>>>>>
>>>>> Any thoughts?
>>>>>
>>>>> Thoughts on how a question would be worded? "keep router 4 from being
>>>>> a
>>>>> transit router and ensure that none of the routers will choose R4 ...,
>>>>> maintain all ospf blah blah blah. you cannot use the max- metric
>>>>> command
>>>>> and must enable this with one global command"
>>>>>
>>>>> Also team, if any of you all have done this, perhaps on the spoke
>>>>> routers,
>>>>> please respond as well.
>>>>>
>>>>> Command reference:
>>>>>
>>>>> http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_osp2.html#wp1014135
>>>>>
>>>>> Feature overview:
>>>>>
>>>>> http://www.cisco.com/en/US/docs/ios/iproute/configuration/guide/irp_ospf_ex_lsa_ps6441_TSD_Products_Configuration_Guide_Chapter.html
>>>>>
>>>>> --
>>>>> Andrew Lee Lissitz
>>>>> all.from.nj_at_gmail.com
>>>>>
>>>>>
>>>>> Blogs and organic groups at http://www.ccie.net
>>>>>
>>>>> _______________________________________________________________________
>>>>> Subscription information may be found at:
>>>>> http://www.groupstudy.com/list/CCIELab.html
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> Garry L. Baker
>>>>
>>>> "There is no 'patch' for stupidity." - www.sqlsecurity.com
>>>>
>>>
>>>
>>>
>>> --
>>> Andrew Lee Lissitz
>>> all.from.nj_at_gmail.com
>>>
>>
>>
>>
>> --
>> Garry L. Baker
>>
>> "There is no 'patch' for stupidity." - www.sqlsecurity.com
>>
>
>
>
> --
> Andrew Lee Lissitz
> all.from.nj_at_gmail.com
>

-- 
Garry L. Baker
"There is no 'patch' for stupidity." - www.sqlsecurity.com
Blogs and organic groups at http://www.ccie.net
Received on Wed Oct 28 2009 - 08:33:11 ART

This archive was generated by hypermail 2.2.0 : Sun Nov 01 2009 - 07:51:01 ART