Hi League
FRF16 is a different beast, with encap frame mfr under the serial.
There is no ppp encapsulation.
Hence you can't use FRF.16 if asked for ppp.
Just out of interest, have you tested whether FRF.16 works with self ping?
2009/8/25 CCIE League <ccieleague_at_ymail.com>
> I guess this only solution other than ip unnum lo0 is MLPPP ... MLPPP is
> not Multilink Frame Relay - FRF.16... if Q say use PPP than can't use
> FRF.16?
>
>
>
> ------------------------------------------------------------
> R1
> interface Multilink1
> ip address 1.1.1.1 255.255.255.0
> ppp multilink
> ppp multilink group 1
> !
> interface Serial0/1
> no ip address
> encapsulation frame-relay
> no frame-relay inverse-arp
> !
> interface Serial0/1.1 point-to-point
> frame-relay interface-dlci 103 ppp Virtual-Template1
> !
> interface Virtual-Template1
> no ip address
> ppp multilink group 1
>
>
> -----------------------------------------------------------
> R2
> interface Multilink1
> ip address 1.1.1.2 255.255.255.0
> ppp multilink
> ppp multilink group 1
> !
> interface Serial0/1
> no ip address
> encapsulation frame-relay
> no frame-relay inverse-arp
> !
> interface Serial0/1.1 point-to-point
> frame-relay interface-dlci 301 ppp Virtual-Template1
> !
> interface Virtual-Template1
> no ip address
> ppp multilink group 1
>
> -----------------------------------------------------------------------------------
>
>
> R2#ping 1.1.1.1
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 60/61/68 ms
> R2#
>
> R2#ping 1.1.1.2
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 116/117/124 ms
> R2#
>
>
>
> R1#ping 1.1.1.2
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/61 ms
> R1#
>
>
> R1#ping 1.1.1.1
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 116/117/124 ms
> R1#
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> -----Original Message-----
> From: nobody_at_groupstudy.com [mailto:nobody_at_groupstudy.com] On Behalf Of
> Divin Mathew John
> Sent: 24 August 2009 11:13 AM
> To: Roy Waterman
> Cc: ccielab_at_groupstudy.com
> Subject: Re: Frame-Relay self ping on PPP
>
> Hey..
>
> I just labbed it up.. and there's a /32 route automatically ijected by PPP
>
> this is my running config
>
> R3
>
> interface Loopback0
> ip address 3.3.3.3 255.255.255.0
> !
> interface Serial0/0
> no ip address
> encapsulation frame-relay
> serial restart-delay 0
> frame-relay lmi-type ansi
> !
> interface Serial0/0.34 point-to-point
> frame-relay interface-dlci 203 ppp Virtual-Template1
> !
> interface Serial0/1
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial0/2
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial0/3
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Virtual-Template1
> ip unnumbered Loopback0
> !
> ip http server
> no ip http secure-server
> !
> R3#sh ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
> ia - IS-IS inter area, * - candidate default, U - per-user static
> route
> o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 3.0.0.0/24 is subnetted, 1 subnets
> C 3.3.3.0 is directly connected, Loopback0
> 4.0.0.0/32 is subnetted, 1 subnets
> C 4.4.4.4 is directly connected, Virtual-Access3
>
> R4
> interface Loopback0
> ip address 4.4.4.4 255.255.255.0
> !
> interface Serial0/0
> no ip address
> encapsulation frame-relay
> serial restart-delay 0
> frame-relay lmi-type ansi
> !
> interface Serial0/0.34 point-to-point
> frame-relay interface-dlci 302 ppp Virtual-Template1
> !
> interface Serial0/1
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial0/2
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial0/3
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Virtual-Template1
> ip unnumbered Loopback0
> !
> ip http server
>
> R4#sh ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
> ia - IS-IS inter area, * - candidate default, U - per-user static
> route
> o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 3.0.0.0/32 is subnetted, 1 subnets
> C 3.3.3.3 is directly connected, Virtual-Access3
> 4.0.0.0/24 is subnetted, 1 subnets
> C 4.4.4.0 is directly connected, Loopback0
> R4#
>
> R4#p 3.3.3.3
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 4/20/56 ms
> R4#
>
> Sent from Cochin, KL, India
>
> On Mon, Aug 24, 2009 at 3:08 PM, Roy Waterman <roy.waterman_at_gmail.com
> >wrote:
>
> > Doh!.
> > Cheers Divin :)
> >
>
> > It has to be a static route that is more specific than the directly
> > connected lo0.
> > I guess I frown upon using static routes for solutions :)
> >
>
> > Is there another way of getting this work without statics?
> >
>
> > 2009/8/24 Divin Mathew John <divinjohn_at_gmail.com>
> >
>
> > use a sttatic route out the interface for R4's Loopback>!
> >>
>
> >> On Mon, Aug 24, 2009 at 2:56 PM, Roy Waterman <roy.waterman_at_gmail.com
> >wrote:
> >>
>
> >>> Hey Joe
> >>> This is great.
> >>> Could you explain why self ping works using mlpppofr as opposed to
> >>> pppofr?
> >>> Is there some logical reason for it?
> >>> Also, could you also explain the ip numbered lo0 serial solution?
> Pinging
> >>> your own ip is no problem with this, but pinging the other end of the
> >>> link
> >>> results in...issues.
> >>>
>
> >>> In my scenario:
> >>>
>
> >>> lo0 --- R3 s0/0.34 ---------------s0/0.43 R4 --- lo0
> >>>
>
> >>> R3
> >>> int s0/0.34 p
> >>> ip unnumbered lo0
> >>> frame int 304
> >>> int lo0
> >>> ip add 10.1.34.3 255.255.255.0
> >>>
>
> >>> R4
> >>> int s0/0.43 p
> >>> ip unnumbered lo0
> >>> frame int 403
> >>> int lo0
> >>> ip add 10.1.34.4 255.255.255.0
> >>>
>
> >>> R3 can self ping but cannot ping R4, as 10.1.34.4 points to lo0...
> >>>
>
> >>> R3#ping 10.1.34.3
> >>>
>
> >>> Type escape sequence to abort.
> >>> Sending 5, 100-byte ICMP Echos to 10.1.34.3, timeout is 2 seconds:
> >>> !!!!!
> >>> Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
> >>> R3#ping 10.1.34.4
> >>>
>
> >>> Type escape sequence to abort.
> >>> Sending 5, 100-byte ICMP Echos to 10.1.34.4, timeout is 2 seconds:
> >>> .....
> >>> Success rate is 0 percent (0/5)
> >>>
>
> >>> R3#sh ip ro 10.1.34.4
> >>> Routing entry for 10.1.34.0/24
> >>> Known via "connected", distance 0, metric 0 (connected, via interface)
> >>> Routing Descriptor Blocks:
> >>> * directly connected, via Loopback0
> >>> Route metric is 0, traffic share count is 1
> >>>
>
> >>>
>
> >>> Could you show how you managed to get around this?
> >>>
>
> >>> Cheers man.
> >>>
>
> >>>
>
> >>>
>
> >>> 2009/8/24 Joe Astorino <jastorino_at_ipexpert.com>
> >>>
>
> >>> > You need either ppp multilink over frame or setup ip unnumbered and
> >>> point
> >>> > it to a loopback
> >>> >
> >>> >
> >>> > ------Original Message------
> >>> > From: Sameer Khurana
> >>> > Sender: nobody_at_groupstudy.com
> >>> > To: CCIE Groupstudy
> >>> > ReplyTo: Sameer Khurana
> >>> > Subject: Frame-Relay self ping on PPP
> >>> > Sent: Aug 23, 2009 10:55 PM
> >>> >
> >>> > Hi Group,
> >>> >
> >>> > If there is a P2P serial connections, for example:
> >>> >
> >>> > R1:
> >>> > ===
> >>> > S1:
> >>> > en fr
> >>> > no fram inv
> >>> > !
> >>> > int S1.1 po
> >>> > fram interface-dlci 102 ppp virtual-tem 1
> >>> > !
> >>> > int virtual-tem 1
> >>> > ip add 1.1.1.1 255.255.255.0
> >>> >
> >>> >
> >>> > R2:
> >>> > ===
> >>> > S1:
> >>> > en fr
> >>> > no fram inv
> >>> > !
> >>> > int S1.1 po
> >>> > fram interface-dlci 201 ppp virtual-tem 1
> >>> > !
> >>> > int virtual-tem 1
> >>> > ip add 1.1.1.2 255.255.255.0
> >>> >
> >>> > If we have to do self ping our own serial interfaces then what we
> need
> >>> to
> >>> > do? Means... R1 should ping its own 1.1.1.1 and R2 should ping
> 1.1.1.2.
> >>> >
> >>> > Thanks,
> >>> > Sameer
> >>> >
> >>> >
> >>> > Blogs and organic groups at http://www.ccie.net
> >>> >
> >>> >
> _______________________________________________________________________
> >>> > Subscription information may be found at:
> >>> > http://www.groupstudy.com/list/CCIELab.html
> >>> >
> >>> >
> >>> >
> >>> >
> >>> >
> >>> >
> >>> >
> >>> >
> >>> >
> >>> > Regards,
> >>> >
> >>> > Joe Astorino - CCIE #24347 R&S
> >>> > Technical Instructor - IPexpert, Inc.
> >>> > Cell: +1.586.212.6107
> >>> > Fax: +1.810.454.0130
> >>> > Mailto: jastorino_at_ipexpert.com
> >>> >
> >>> >
> >>> > Blogs and organic groups at http://www.ccie.net
> >>> >
> >>> >
> _______________________________________________________________________
> >>> > Subscription information may be found at:
> >>> > http://www.groupstudy.com/list/CCIELab.html
> >>> >
> >>> >
> >>> >
> >>> >
> >>> >
> >>> >
> >>> >
> >>> >
> >>>
>
> >>>
>
> >>> --
> >>> Regards
> >>> Roy
> >>>
>
> >>>
>
> >>> Blogs and organic groups at http://www.ccie.net
> >>>
>
> >>> _______________________________________________________________________
> >>> Subscription information may be found at:
> >>> http://www.groupstudy.com/list/CCIELab.html
> >>>
>
> >>>
>
> >>>
>
> >>>
>
> >>>
>
> >>>
>
> >>>
>
> >>>
>
> >>
>
> >
>
> >
>
> > --
> > Regards
> > Roy
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
>
-- Regards Roy Blogs and organic groups at http://www.ccie.netReceived on Tue Aug 25 2009 - 05:24:31 ART
This archive was generated by hypermail 2.2.0 : Tue Sep 01 2009 - 05:43:57 ART