From: Joseph L. Brunner (joe@affirmedsystems.com)
Date: Thu Mar 19 2009 - 12:14:27 ART
Your forgetting the resolution will fail because of the medium- Ethernet...
Solve this with "pumpkin loopbacks" or whatever the hell its called...
Simply run a gre tunnel between two tunnel interfaces in the same router, each sourced from different loopback. Both loopbacks part of global routing table; on tunnel interface part of VRF routing table.
Works every time!
-Joe
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of Antonio Soares
Sent: Thursday, March 19, 2009 12:10 PM
To: ccielab@groupstudy.com; comserv@groupstudy.com
Subject: IPv6 route leaking
Hello group,
Suppose these interfaces:
!
interface FastEthernet0/0
ip address 123.123.123.3 255.255.255.0
ipv6 address 2001:13::3/64
!
interface FastEthernet0/1.1
vrf forwarding vrf1
encapsulation dot1Q 1 native
ip address 100.100.100.1 255.255.255.0
ipv6 address 2001:3::1/64
!
For IPv4, we have these options to do route leaking:
1) Global RT to VRF:
ip route 100.100.100.0 255.255.255.0 FastEthernet0/1.1
2) VRF to Global RT:
ip route vrf vrf1 0.0.0.0 0.0.0.0 123.123.123.1 global
I was trying to accomplish the same with IPv6:
1) Global RT to VRF:
ipv6 route 2001:3::/64 FastEthernet0/1.1 nexthop-vrf vrf1
2) VRF to Global RT:
ipv6 route vrf vrf1 ::/0 2001:13::1 nexthop-vrf Default
But here Global RT to VRF does not work.
Local router:
ping vrf vrf1 2001:1::1
ICMPv6: Sent echo request, Src=2001:3::1, Dst=2001:1::1
ICMPv6: Sent Unreachable code 3, Src=2001:13::3, Dst=2001:1::1
Remote router:
ICMPv6: Received echo request, Src=2001:3::1, Dst=2001:1::1
ICMPv6: Sent echo reply, Src=2001:1::1, Dst=2001:3::1
ICMPv6: Received Unreachable code 3, Src=2001:13::3, Dst=2001:1::1
Ant hints ? Is this supported ?
Thanks.
Regards,
Antonio Soares, CCIE #18473 (R&S)
amsoares@netcabo.pt
Blogs and organic groups at http://www.ccie.net
This archive was generated by hypermail 2.1.4 : Mon Apr 06 2009 - 06:44:06 ART