From: Antonio Soares (amsoares@netcabo.pt)
Date: Thu Mar 19 2009 - 17:14:18 ART
The configuration i have works perfectly for IPv4. But the same type of config does not work for IPv6.
And the problem is this static route:
ipv6 route 2001:3::/64 FastEthernet0/1.1 nexthop-vrf vrf1
The router installs it but for some reason it does not work.
I have these configurations if someone wants to give it a try:
++++++++++++++++++++
R1:
++++++++++++++++++++
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
ipv6 address 2001:12::1/64
!
interface FastEthernet0/1
ip address 10.10.10.1 255.255.255.0
ipv6 address 2001:1::1/64
!
ip route 0.0.0.0 0.0.0.0 12.12.12.2
!
ipv6 route ::/0 2001:12::2
!
++++++++++++++++++++
R2
++++++++++++++++++++
!
vrf definition vrf1
rd 1:1
!
address-family ipv4
route-target export 1:1
route-target import 1:1
exit-address-family
!
address-family ipv6
route-target export 1:1
route-target import 1:1
exit-address-family
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
ipv6 address 2001:12::2/64
!
interface FastEthernet0/1
vrf forwarding vrf1
ip address 20.20.20.1 255.255.255.0
ipv6 address 2001:2::1/64
!
ip route 20.20.20.0 255.255.255.0 FastEthernet0/1
ip route vrf vrf1 0.0.0.0 0.0.0.0 12.12.12.1 global
!
ipv6 route 2001:2::/64 FastEthernet0/1 nexthop-vrf vrf1
ipv6 route vrf vrf1 ::/0 2001:12::1 nexthop-vrf default
!
++++++++++++++++++++
You will need 12.4(20)T or higher in order to have support for IPv6 VRFs.
Regards,
Antonio Soares, CCIE #18473 (R&S)
amsoares@netcabo.pt
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of Joseph L. Brunner
Sent: quinta-feira, 19 de Margo de 2009 15:14
To: 'Antonio Soares'; ccielab@groupstudy.com; comserv@groupstudy.com
Subject: RE: IPv6 route leaking
Your forgetting the resolution will fail because of the medium- Ethernet...
Solve this with "pumpkin loopbacks" or whatever the hell its called...
Simply run a gre tunnel between two tunnel interfaces in the same router, each sourced from different loopback. Both loopbacks part
of global routing table; on tunnel interface part of VRF routing table.
Works every time!
-Joe
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of Antonio Soares
Sent: Thursday, March 19, 2009 12:10 PM
To: ccielab@groupstudy.com; comserv@groupstudy.com
Subject: IPv6 route leaking
Hello group,
Suppose these interfaces:
!
interface FastEthernet0/0
ip address 123.123.123.3 255.255.255.0
ipv6 address 2001:13::3/64
!
interface FastEthernet0/1.1
vrf forwarding vrf1
encapsulation dot1Q 1 native
ip address 100.100.100.1 255.255.255.0
ipv6 address 2001:3::1/64
!
For IPv4, we have these options to do route leaking:
1) Global RT to VRF:
ip route 100.100.100.0 255.255.255.0 FastEthernet0/1.1
2) VRF to Global RT:
ip route vrf vrf1 0.0.0.0 0.0.0.0 123.123.123.1 global
I was trying to accomplish the same with IPv6:
1) Global RT to VRF:
ipv6 route 2001:3::/64 FastEthernet0/1.1 nexthop-vrf vrf1
2) VRF to Global RT:
ipv6 route vrf vrf1 ::/0 2001:13::1 nexthop-vrf Default
But here Global RT to VRF does not work.
Local router:
ping vrf vrf1 2001:1::1
ICMPv6: Sent echo request, Src=2001:3::1, Dst=2001:1::1
ICMPv6: Sent Unreachable code 3, Src=2001:13::3, Dst=2001:1::1
Remote router:
ICMPv6: Received echo request, Src=2001:3::1, Dst=2001:1::1
ICMPv6: Sent echo reply, Src=2001:1::1, Dst=2001:3::1
ICMPv6: Received Unreachable code 3, Src=2001:13::3, Dst=2001:1::1
Ant hints ? Is this supported ?
Thanks.
Regards,
Antonio Soares, CCIE #18473 (R&S)
amsoares@netcabo.pt
Blogs and organic groups at http://www.ccie.net
This archive was generated by hypermail 2.1.4 : Mon Apr 06 2009 - 06:44:06 ART