Re: IPV6: OSPF Routing over 6to4 Tunnel

From: Andy Hogard (andyhogard@gmail.com)
Date: Tue Feb 10 2009 - 16:52:48 ARST


*Ok,

As I said it work w/o any problems ..below are my configs. If you have any
other ipv6 doubts keep them coming. I am still on it for a few more days
..before I move on. :D

Configuration of R1 *

Current configuration : 2916 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
ipv6 unicast-routing
!
!
interface Tunnel12
 no ip address
 ipv6 address 12::12:1/64
 ipv6 rip ripr1r2r3r4 enable
 tunnel source Loopback101
 tunnel destination 172.16.102.1
 tunnel mode ipv6ip
!
interface Loopback101
 ip address 172.16.101.1 255.255.255.0
!
interface Serial1/0
 no ip address
 shutdown
 no dce-terminal-timing-enable
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/2
 description connection to R3
 ip address 172.16.13.1 255.255.255.0
 ipv6 address 13::13:1/64
 ipv6 address FE80::13:1 link-local
 ipv6 rip ripr1r2r3r4 enable
 no dce-terminal-timing-enable
!
interface Serial1/3
 description connection to R2
 ip address 172.16.12.1 255.255.255.0
 serial restart-delay 0
 no dce-terminal-timing-enable
!
router rip
 version 2
 passive-interface default
 no passive-interface Serial1/3
 network 172.16.0.0
 no auto-summary
!
ip http server
no ip http secure-server
!
!
!
ipv6 router rip ripr1r2r3r4
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 3
 login
line vty 4
 exec-timeout 0 0
 logging synchronous
 login
!
!
end

*
Configuration on R3*

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
ipv6 unicast-routing
!
!

interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 no dce-terminal-timing-enable
!
interface Serial1/1
 description connection to R1
 ip address 172.16.13.3 255.255.255.0
 ipv6 address 13::13:3/64
 ipv6 address FE80::13:3 link-local
 ipv6 rip ripr1r2r3r4 enable
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
ip http server
no ip http secure-server
!
!
!
ipv6 router rip ripr1r2r3r4
!
!
!
control-plane
!
!
!
end

*Configuration on R2*

Current configuration : 2782 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
ipv6 unicast-routing
!
!
!
interface Tunnel12
 no ip address
 ipv6 address 12::12:2/64
 ipv6 rip ripr1r2r3r4 enable
 tunnel source Loopback102
 tunnel destination 172.16.101.1
 tunnel mode ipv6ip
!
interface Loopback102
 ip address 172.16.102.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 172.16.24.2 255.255.255.0
 encapsulation frame-relay
 ipv6 address 24::24:2/64
 ipv6 address FE80::24:2 link-local
 ipv6 rip ripr1r2r3r4 enable
 no dce-terminal-timing-enable
 frame-relay map ipv6 24::24:4 204
 frame-relay map ipv6 FE80::24:4 204 broadcast
 frame-relay interface-dlci 204
!
interface Serial1/1
 description connection to R1
 ip address 172.16.12.2 255.255.255.0
 serial restart-delay 0
 no dce-terminal-timing-enable
!
!
router rip
 version 2
 passive-interface default
 no passive-interface Serial1/1
 network 172.16.0.0
 no auto-summary
!
ip http server
no ip http secure-server
!
!
!
ipv6 router rip ripr1r2r3r4
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 3
 login
line vty 4
 exec-timeout 0 0
 logging synchronous
 login
!
!
end

*Configuration on R4*

Current configuration : 2303 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
ipv6 unicast-routing
!
!
!
interface Serial1/0
 description connection to NMC R2
 ip address 172.16.24.4 255.255.255.0
 encapsulation frame-relay
 ipv6 address 24::24:4/64
 ipv6 address FE80::24:4 link-local
 ipv6 rip r1r2r3r4 enable
 no dce-terminal-timing-enable
 frame-relay map ipv6 24::24:2 402
 frame-relay map ipv6 FE80::24:2 402 broadcast
 frame-relay interface-dlci 402
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
!
ip http server
no ip http secure-server
!
!
!
ipv6 router rip r1r2r3r4
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 3
 login
line vty 4
 exec-timeout 0 0
 logging synchronous
 login
!
!
end

*Final verification from R4 to R3, through the tunnel between R1 & R2*

R4#ping 13::13:3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13::13:3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/71/200 ms
R4#
R4#
R4#trace 13::13:3

Type escape sequence to abort.
Tracing the route to 13::13:3

  1 24::24:2 40 msec 56 msec 20 msec
  2 12::12:1 88 msec 20 msec 20 msec
  3 13::13:3 48 msec 16 msec 28 msec
R4#

*Routes, on R2 learnt through the tunnel:*

R2#
R2#sh ipv route rip
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
R 13::/64 [120/2]
     via FE80::AC10:6501, Tunnel12
R2#
R2#

*Debug o/p, on R1 ..we can see here updates going through the tunnel:*

R1#
*Mar 1 01:30:24.471: RIPng: Sending multicast update on Tunnel12 for
ripr1r2r3r4
*Mar 1 01:30:24.475: src=FE80::AC10:6501
*Mar 1 01:30:24.475: dst=FF02::9 (Tunnel12)
*Mar 1 01:30:24.479: sport=521, dport=521, length=52
*Mar 1 01:30:24.479: command=2, version=1, mbz=0, #rte=2
*Mar 1 01:30:24.483: tag=0, metric=1, prefix=13::/64
*Mar 1 01:30:24.483: tag=0, metric=1, prefix=12::/64
*Mar 1 01:30:24.487: RIPng: Sending multicast update on Serial1/2 for
ripr1r2r3r4
*Mar 1 01:30:24.491: src=FE80::13:1
*Mar 1 01:30:24.491: dst=FF02::9 (Serial1/2)
*Mar 1 01:30:24.495: sport=521, dport=521, length=72
R1#
*Mar 1 01:34:37.895: RIPng: response received from FE80::AC10:6601 on
Tunnel12 for ripr1r2r3r4
*Mar 1 01:34:37.899: src=FE80::AC10:6601 (Tunnel12)
*Mar 1 01:34:37.899: dst=FF02::9
*Mar 1 01:34:37.899: sport=521, dport=521, length=52
*Mar 1 01:34:37.903: command=2, version=1, mbz=0, #rte=2
*Mar 1 01:34:37.903: tag=0, metric=1, prefix=24::/64
*Mar 1 01:34:37.907: tag=0, metric=1, prefix=12::/64

*Conclusion RIPng works well on manual v6 tunnels.*

*HTH,
Andy.

Next up is OSPFv3 on this same topology!! :D *

On Tue, Feb 10, 2009 at 9:09 PM, Roger RPF <rpf@bluemail.ch> wrote:

> I just tried it yesterday, could not bring it up and running...but maybe I
> missed something...smile...
>
> regards
>
> Roger
>
> -----Urspr|ngliche Nachricht-----
> Von: nobody@groupstudy.com [mailto:nobody@groupstudy.com] Im Auftrag von
> Alexei Monastyrnyi
> Gesendet: Dienstag, 10. Februar 2009 15:32
> An: S Malik
> Cc: Cisco certification
> Betreff: Re: IPV6: OSPF Routing over 6to4 Tunnel
>
> To my experience OSPF won't work over 6to4 tunnels. This is due to
> hellos and updates exchange between link-local addresses which one
> cannot properly map within 6to4 scheme.(true for RIPng and EIGRP as
> well). BGP seems to work though due to TCP nature, but I haven't tried
> myself. :-)
>
> Simple static route
> ipv6 route 2002::/16 Tunnel NNN
> would be a remedy but one has to follow 6to4 rules strictly for IPv^
> address assignments. It was a good post about it way back in Dec 08 or
> Jan 09.
>
> HTH,
> A.
>
> S Malik wrote:
> > Can we do ospfv3 routing over 6to4 tunnel?
> >
> > I would appreciate if some one can forward working configuration please.
> >
> >
> > Blogs and organic groups at http://www.ccie.net
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
>

-- 
My Blog URL: http://ccieno.blogspot.com/

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Sun Mar 01 2009 - 09:44:10 ARST