AW: Layer 2 qos

From: Roger RPF (rpf@bluemail.ch)
Date: Sat Oct 25 2008 - 05:11:29 ARST


Hi Mark,

Well, if you configure a switchport voice vlan, the port will still be an
access port.

Have a look at the config guide which has some great explanation regarding
this issue:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/1
2.2_44_se/configuration/guide/swvoip.html

There it says:

"switchport voice vlan dot1p: Instruct the switch port to use IEEE 802.1p
priority tagging for voice traffic and to use the default native VLAN (VLAN
0) to carry all traffic. By default, the Cisco IP phone forwards the voice
traffic with an IEEE 802.1p priority of 5."

An alternative is also to use the "embeded" macro for configuring a voice
port: With sh parser macro you can see all available macros. There is one
called cisco-phone. I'll post it below and I'll apply it also to a
switchport, you can see what it does with the port:

Here the macro:
---------------------

Macro name : cisco-phone
Macro type : default interface
# Cisco IP phone + desktop template

# macro keywords $access_vlan $voice_vlan
          

# VoIP enabled interface - Enable data VLAN
# and voice VLAN
# Recommended value for access vlan should not be 1
switchport access vlan $access_vlan
switchport mode access

# Update the Voice VLAN value which should be
# different from data VLAN
# Recommended value for voice vlan should not be 1
switchport voice vlan $voice_vlan

# Enable port security limiting port to a 2 MAC
# addressess -- One for desktop on data vlan and
# one for phone on voice vlan
switchport port-security
switchport port-security maximum 2

# Ensure port-security age is greater than one minute
# and use inactivity timer
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
          
# Enable auto-qos to extend trust to attached Cisco phone
auto qos voip cisco-phone
          
# Configure port as an edge network port
spanning-tree portfast
spanning-tree bpduguard enable

And below what happens if you apply it to an interface:
-----------------------------------------------------------------

Cat3550-2(config-if)#macro apply cisco-phone $access_vlan 88 $voice_vlan 89
Cat3550-2(config-if)#do sh run int fa0/14
Building configuration...

Current configuration : 747 bytes
!
interface FastEthernet0/14
 switchport access vlan 88
 switchport mode access
 switchport voice vlan 89
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 wrr-queue bandwidth 10 20 70 1
 wrr-queue min-reserve 1 5
 wrr-queue min-reserve 2 6
 wrr-queue min-reserve 3 7
 wrr-queue min-reserve 4 8
 wrr-queue cos-map 1 0 1
 wrr-queue cos-map 2 2 4
 wrr-queue cos-map 3 3 6 7
 wrr-queue cos-map 4 5
 priority-queue out
 spanning-tree portfast
 spanning-tree bpduguard enable
end

regards

Roger

-----Urspr|ngliche Nachricht-----
Von: nobody@groupstudy.com [mailto:nobody@groupstudy.com] Im Auftrag von
Mark Stephanus Chandra
Gesendet: Samstag, 25. Oktober 2008 08:22
An: 'Anthony J Sequeira'; ccielab@groupstudy.com
Betreff: RE: Layer 2 qos

hi Anthony,

Thanks a lot for the explanation. That's mean, if we configure the
switchport with switchport mode access vlan instead of trunk. Than The COS
will have no effect right ?

So do we have to configure a trunk mode port or we just use switchport voice
vlan which is automatically turn the port to trunk ?

Is that correct ?

Thanks

Regards

Mark Stephanus Chandra
IT Consultant
-----Original Message-----
From: Anthony J Sequeira [mailto:asequeira@internetworkexpert.com]
Sent: 25 Oktober 2008 11:57
To: mark.chandra@gmail.com; ccielab@groupstudy.com
Subject: Re: Layer 2 qos

The Layer 2 QoS markings may be generically termed Class of Service (CoS)
markings. In both ISL and 802.1Q frames across the trunk, there are three
bits reserved for the CoS marking.

The Cisco IP Phone is acting like a Layer 2 switch. Taking traffic from the
PC and the phone itself and trunking this traffic to the Catalyst switch
with CoS markings. By default the phone marks the VoIP traffic with a CoS of
5. This is the highest value Cisco recommends for marking traffic. Values 6
and 7 are reserved for network device usage.

Warmest regards,

Anthony J. Sequeira, CCIE #15626, CCSI #23251
Senior CCIE Instructor

asequeira@internetworkexpert.com

Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987
Outside US: 775-826-4344

On 10/24/08 11:38 PM, "mark.chandra@gmail.com" <mark.chandra@gmail.com>
wrote:

> Hi guys,
>
> Just want to make sure my understanding about layer 2 qos.
>
> Layer 2 packet that we should call it frame, don't have tos bit in their
> frame. So Qos that Ieee called it 802.1p qos bit only can be carried by
isl
> and dot1.q frame, is that correct?
>
> So, when I have a switchport connected to cisco ip phone that in default
will
> forwarding frame with cos of 5. The switch port have to be a trunk, cause
if
> not, isl or dot1q cannot carried the tos. Is that right?
>
>
> Can anybody correct me if I'm wrong.
>
> Thanks a lot guys
> Sent from my BlackBerry. wireless device from XL GPRS/EDGE/3G network
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Sat Nov 01 2008 - 15:35:22 ARST