RE: Ip PIM Auto-rp Listener

From: Chuck Ryan (chryan) (chryan@cisco.com)
Date: Wed Oct 08 2008 - 19:25:50 ART


and here are the configs that I promised.....

Here are the configs for each:

BB1#sh config
Using 1346 out of 8192 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BB1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
!
!
ip cef
ip multicast-routing
no ipv6 cef
!
!
!
interface Loopback0
 ip address 11.11.11.11 255.255.255.255
 ip pim sparse-mode
!
interface Ethernet0/0
 ip address 10.1.37.7 255.255.255.0
 ip pim sparse-mode
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 11.11.11.11
 log-adjacency-changes
 network 10.1.37.7 0.0.0.0 area 0
 network 11.11.11.11 0.0.0.0 area 0
!
ip forward-protocol nd
!
!
no ip http server
ip pim send-rp-announce Loopback0 scope 16
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

BB1#
----------------------------------------------------

R3#show config
Using 1341 out of 8192 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
ip multicast-routing
no ipv6 cef
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip pim sparse-mode
!
interface Ethernet0/0
 ip address 10.1.37.3 255.255.255.0
 ip pim sparse-mode
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 ip address 150.1.13.3 255.255.255.0
 ip pim sparse-mode
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 10.1.37.3 0.0.0.0 area 0
 network 150.1.13.3 0.0.0.0 area 0
!
ip forward-protocol nd
!
!
no ip http server
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

R3#
-----------------------------------------------------

R1#sh config
Using 1601 out of 8192 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
ip multicast-routing
no ipv6 cef
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip pim sparse-mode
!
interface Ethernet0/0
 ip address 150.1.15.1 255.255.255.0
 ip pim sparse-mode
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no frame-relay inverse-arp
!
interface Serial1/0.1 point-to-point
 ip address 150.1.12.1 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 102
!
interface Serial1/1
 ip address 150.1.13.1 255.255.255.0
 ip pim sparse-mode
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 150.1.12.1 0.0.0.0 area 0
 network 150.1.13.1 0.0.0.0 area 0
 network 150.1.15.1 0.0.0.0 area 0
!
ip forward-protocol nd
!
!
no ip http server
ip pim send-rp-discovery Loopback0 scope 16
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

R1#

Thanks,

Chuck

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Sat Nov 01 2008 - 15:35:20 ARST