RE: QoS for mVPN

From: Roman Rodichev (roman@iementor.com)
Date: Wed Aug 06 2008 - 11:45:19 ART


How do you know that multicast traffic is not getting matched?

TOS field is copied automatically from customer's multicast packet into mVPN
GRE multicast packet. QoS pre-classify serves a different purpose and is
needed only if you are trying to match multicast traffic based on ACL (other
IP header fields). Therefore, all your customer multicast traffic should be
marked with appropriate DSCP.

As everyone mentioned, mVPN mGRE packets are not tagged with MPLS label,
because the destination IP address of those packets is multicast.

Roman Rodichev
5xCCIE #7927 (R&S, Security, Voice, Storage, Service Provider)
Instructor, Content Developer. ieMentor Corporation
http://www.iementor.com
Y!M: roman7927

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Harindha Fernando
Sent: Wednesday, August 06, 2008 5:38 PM
To: Robert McCallum
Cc: comserv@groupstudy.com; ccielab@groupstudy.com
Subject: Re: QoS for mVPN

Hi,

we are using the following output policy-map in MPLS interface,

class-map match-any E-RT-VIDEO
  match ip dscp cs4
  match ip dscp af41
  match ip dscp af42
  match ip dscp af43
  match mpls experimental topmost 4
class-map match-any E-RT-VOICE
  match ip dscp ef
  match mpls experimental topmost 5
class-map match-all I-CCTV-SCAVENGER
  match access-group name TRAFFIC-MULTICAST
class-map match-any E-SCAVENGER
  match ip dscp cs1
  match mpls experimental topmost 1
class-map match-all I-CCTV-LLMULTIMEDIA
  match access-group name TRAFFIC-UNICAST
class-map match-any E-LL-MULTIMEDIA
  match ip dscp cs3
  match ip dscp af31
  match ip dscp af32
  match ip dscp af33
  match mpls experimental topmost 3
class-map match-any E-LL-DATA
  match ip dscp cs2
  match ip dscp af21
  match ip dscp af22
  match ip dscp af23
  match mpls experimental topmost 2
!
policy-map E-POL-FLEX-CHILD
  class E-RT-VOICE
    priority 2800
   set mpls exp topmost 5
  class E-RT-VIDEO
    bandwidth percent 10
    random-detect dscp-based
   set mpls exp topmost 4
  class E-LL-MULTIMEDIA
    bandwidth percent 25
    random-detect dscp-based
   set mpls exp topmost 3
   set ip dscp cs3
  class E-LL-DATA
    bandwidth percent 15
    random-detect dscp-based
   set mpls exp topmost 2
  class E-SCAVENGER
    bandwidth percent 1
    random-detect dscp-based
   set mpls exp topmost 1
  class class-default
   set mpls exp topmost 0
    random-detect
policy-map E-POL-FLEX
  class class-default
    shape average 20000000
   service-policy E-POL-FLEX-CHILD

interface GigabitEthernet1/0/0
 description *** Connected to PE7 -Gi1/0/0 *
 dampening
 mtu 1536
 bandwidth 20000
 ip address 172.20.6.1 255.255.255.252
 no ip redirects
 ip router isis
 ip pim sparse-mode
 load-interval 30
 carrier-delay msec 0
 speed 100
 no negotiation auto
 mpls ip
 bfd interval 100 min_rx 100 multiplier 3
 cdp enable
 isis circuit-type level-2-only
 isis network point-to-point
 isis authentication mode md5
 isis authentication key-chain MOI
 isis bfd
 service-policy output E-POL-FLEX

class-map match-all TEST
  match access-group 15

policy-map I-POL-CCTV
  class TEST
   set ip dscp cs3

interface Vlan10
 description ### Multicast-server ###
 ip vrf forwarding CCTV
 ip address 192.168.6.1 255.255.255.0
 no ip redirects
 ip pim sparse-mode
 service-policy input I-POL-CCTV

Rgds,
Harin

On Wed, Aug 6, 2008 at 5:24 PM, Robert McCallum
<rmccallum@thrupoint.net>wrote:

> Your multicast traffic is IP based on not MPLS based. So where normally
an
> outbound policy would look like ...
>
> Match mpls exp 5
>
> You also need to match your ip equivalent e.g. match ip dscp ef
>
> Common mistake when it comes to multicast in MVPN. Just remember that you
> can tear down an mpls neighbour which you know multicast traffic runs
> across
> and it still works, whereas all ip non multicast traffic is blackholed.
>
> Watchout on the GSR's and on some linecards as multicast is only ever put
> into the default queue.
>
> HTH
>
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On
> > Behalf Of Harindha Fernando
> > Sent: 06 August 2008 14:14
> > To: comserv@groupstudy.com; ccielab@groupstudy.com
> > Subject: QoS for mVPN
> >
> > Hi,
> >
> > I have been trying to set QoS for mVPN in MPLS QoS but I am
> > still unable to achieve it. below is the scenario...
> >
> > Reciever1 -->PE1-->P1-->P2-->PE2--->Source
> > |
> > |
> > P3--->PE3--->Receiver2
> >
> > Core - PIM SSM
> > Customer mVPN - PIM-SSM with static SSM mapping
> >
> > mVPN is working fine, but I need to offer some QoS in the core.
> >
> > at PE2 customer interface I have a input policy-map setting
> > all muliticast traffic on that interface, set to DSCP AF41.
> > the MPLS interface towards core I have an output policy
> > allocating BW based on dscp or exp marking and also I do set
> > exp values. DSCP AF41 = Exp 4
> >
> > when I put a output policy in the PE1 and PE3 customer
> > interfaces to match DSCP AF41 I do not see any matching packets.
> >
> > since mVPN traffic is going through GRE tunnels I don't see
> > any possibility of setting the DSCP values in the GRE header
> > as this Tunnel interfaces are not configurable.
> >
> > can any body tell how can we achieve the QoS for mVPN ?
> >
> > I am using 7600s with RSP720 and 12.2(33)SRC1.
> >
> >
> > Rgds,
> > Harin
> >
> > _____________________________________________________________________
> > Subscription information: http://www.groupstudy.com/list/comserv.html
> >
>
>
>
> Note:The information contained in this message may be privileged and
> confidential and protected from disclosure . If the reader of this message
> is not the
> intended recipient, or an employee or agent responsible for delivering
this
> message to the intended recipient, you are hereby notified that any
> dissemination, distribution or copying of this communication is strictly
> prohibited. If you have received this communication in error, please
notify
> us
> immediately by replying to the message and deleting it from your computer.
> Thankyou. ThruPoint Ltd.

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Mon Sep 01 2008 - 08:15:29 ART