Re: RIP routing table EIGRP won't take it

From: Jack Tsai (jacknew2005@gmail.com)
Date: Sun Jul 06 2008 - 17:54:00 ART


R4# sh run
...
interface Loopback0
 ip address 172.16.26.20 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 10.201.28.176 255.255.255.128
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.14.26.20 255.255.0.0
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 10.4.10.1 255.255.255.0
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 10.4.20.1 255.255.255.0
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 10.4.30.1 255.255.255.0
!
interface FastEthernet0/0.40
 encapsulation dot1Q 40
 ip address 10.4.40.1 255.255.255.0
!
interface FastEthernet0/0.50
 encapsulation dot1Q 50
 ip address 10.4.50.1 255.255.255.0
!
router eigrp 100
 redistribute connected metric 1000 1 255 1 1500
 network 10.0.0.0
 no auto-summary
!
ip classless
...

R1#sh run
...
interface Loopback0
 ip address 172.16.56.1 255.255.255.255
...
interface FastEthernet0/6
 no switchport
 ip address 10.14.35.60 255.255.0.0
!
interface FastEthernet0/7
 no switchport
 ip address 192.168.13.1 255.255.255.0
!
...
router eigrp 100
 redistribute connected
 default-metric 1000 1 255 1 1500
 no auto-summary
 network 10.0.0.0
 network 192.168.12.0
 network 192.168.13.0
!
router rip
 version 2
 redistribute connected metric 1
 network 192.168.12.0
 network 192.168.13.0
 no auto-summary
!
...

R3# sh run
...
interface Loopback0
 ip address 172.16.56.3 255.255.255.255
...
interface FastEthernet0/7
 no switchport
 ip address 192.168.23.3 255.255.255.0
!
interface FastEthernet0/8
 no switchport
 ip address 192.168.13.3 255.255.255.0
...
router eigrp 100
 redistribute connected
 default-metric 1000 1 255 1 1500
 no auto-summary
 network 10.0.0.0
 network 192.168.13.0
 network 192.168.23.0
!
router rip
 version 2
 redistribute connected metric 1
 network 10.0.0.0
 network 192.168.13.0
 network 192.168.23.0
 no auto-summary
...
ip route 0.0.0.0 0.0.0.0 192.168.13.1

R1# sh ip ro
...
Gateway of last resort is not set

C 192.168.12.0/24 is directly connected, FastEthernet0/8
C 192.168.13.0/24 is directly connected, FastEthernet0/7
     172.16.0.0/32 is subnetted, 6 subnets
C 172.16.56.1 is directly connected, Loopback0
D 172.16.56.2 [90/156160] via 192.168.12.2, 6d11h, FastEthernet0/8
*R 172.16.56.3 [120/1] via 192.168.13.3, 00:00:29, FastEthernet0/7*
D 172.16.37.50 [90/158720] via 192.168.12.2, 6d12h, FastEthernet0/8
R 172.16.28.11 [120/2] via 192.168.13.3, 00:00:29, FastEthernet0/7
D EX 172.16.26.20 [170/2562816] via 10.14.26.20, 6d12h, FastEthernet0/6
D 192.168.26.0/24 [90/30720] via 192.168.12.2, 6d12h, FastEthernet0/8
D 192.168.56.0/24 [90/30976] via 192.168.13.3, 6d12h, FastEthernet0/7
     10.0.0.0/8 is variably subnetted, 11 subnets, 3 masks
C 10.14.0.0/16 is directly connected, FastEthernet0/6
...

R4# sh ip route
...
Gateway of last resort is not set

D 192.168.12.0/24 [90/30720] via 10.14.35.60, 6d12h, FastEthernet0/0.2
D 192.168.13.0/24 [90/30720] via 10.14.35.60, 6d12h, FastEthernet0/0.2
     172.16.0.0/32 is subnetted, 4 subnets
*D EX 172.16.56.1 [170/156160] via 10.14.35.60, 6d12h, FastEthernet0/0.2
D 172.16.56.2 [90/158720] via 10.14.35.60, 6d11h, FastEthernet0/0.2*
D 172.16.37.50 [90/161280] via 10.14.35.60, 6d12h, FastEthernet0/0.2
C 172.16.26.20 is directly connected, Loopback0
D 192.168.26.0/24 [90/33280] via 10.14.35.60, 6d12h, FastEthernet0/0.2
D 192.168.56.0/24 [90/33536] via 10.14.35.60, 6d12h, FastEthernet0/0.2
     10.0.0.0/8 is variably subnetted, 11 subnets, 3 masks
C 10.4.10.0/24 is directly connected, FastEthernet0/0.10
C 10.14.0.0/16 is directly connected, FastEthernet0/0.2
D 10.5.10.0/24 [90/33536] via 10.14.35.60, 6d12h, FastEthernet0/0.2
C 10.4.30.0/24 is directly connected, FastEthernet0/0.30
D 10.5.30.0/24 [90/33536] via 10.14.35.60, 6d12h, FastEthernet0/0.2
C 10.4.20.0/24 is directly connected, FastEthernet0/0.20
D 10.5.20.0/24 [90/33536] via 10.14.35.60, 6d12h, FastEthernet0/0.2
C 10.4.40.0/24 is directly connected, FastEthernet0/0.40
D 10.35.0.0/16 [90/30976] via 10.14.35.60, 6d12h, FastEthernet0/0.2
C 10.4.50.0/24 is directly connected, FastEthernet0/0.50
C 10.201.28.128/25 is directly connected, FastEthernet0/0.1
D 192.168.23.0/24 [90/33280] via 10.14.35.60, 6d12h, FastEthernet0/0.2

*D EX 172.16.56.3 [170/158720] via 10.14.35.60, 6d12h,
FastEthernet0/0.2 is missing?

Jack

*Luan Nguyen wrote:
> very cool paper here that could help you:
> http://reports-archive.adm.cs.cmu.edu/anon/2008/CMU-CS-08-123.pdf
>
> -Luan
>
>
> On Sat, Jul 5, 2008 at 11:47 PM, Jack Tsai <jacknew2005@gmail.com
> <mailto:jacknew2005@gmail.com>> wrote:
>
> Jack Tsai wrote:
>
> topology: R3--R1--R4
>
> -- Background --
> R3 loopback0: 172.16.56.3/32 <http://172.16.56.3/32>
> All three routers are running EIGRP no auto-summary.
> R3 Lo0 is not introduced to the EIGRP by network; it is
> injected by Redistribute Connected
> sh ip route on R4 shows that 172.16.56.3/32
> <http://172.16.56.3/32> is EX with distance 170.
> All interfaces of the three routers are reachable by all routers.
>
> -- New add-in and observation --
> add router RIP version 2 on R3 and R1 with no auto-summary
> R3 Lo0 is not introduced to the RIP by network; it is injected
> by Redistribute Connected metric 1
> sh ip route on R1 shows R 172.16.56.3
> <http://172.16.56.3> [120/1] via 192.168.13.3
> <http://192.168.13.3>
> sh ip route on R4 DOES NOT show this route on its routing table!
> sh ip eigrp top on R4 DOES NOT show this route (172.16.56.3
> <http://172.16.56.3>) on its EIGRP topology table!!
>
> -- Remedy --
> add the command distance 180 172.16.56.3 <http://172.16.56.3>
> 0.0.0.0 <http://0.0.0.0> on R4 router RIP will solve the problem.
>
> --Question --
> (1) Is there a way we can do on R1 to change the distance of
> the learned route (172.16.56.3/32 <http://172.16.56.3/32>)?
> (2) Why 172.16.56.3/32 <http://172.16.56.3/32> is not on the
> R4 EIGRP topology table while it is on the R1 EIGRP table?
> (3) Any comments?
>
> Thanks,
> Jack Tsai
> CCIE R&S candidate
>
>
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Mon Aug 04 2008 - 06:11:53 ART