Route Leaking Challenge

From: Antonio Soares (amsoares@netcabo.pt)
Date: Wed Jul 02 2008 - 15:58:55 ART


Hello group,

I have here a task that i found interesting. Given the configs bellow where
R1 and R3 are connected to R2, and only using static routing, configure R2
in order to have full reachability between R1 and R3:

+++++++++++++++++++++++++++++++++++
R1:
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
 ip address 12.12.12.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 12.12.12.2
!
+++++++++++++++++++++++++++++++++++
R2:
!
ip vrf R1
 rd 100:100
 route-target export 100:100
 route-target import 100:100
!
interface FastEthernet1/0
 ip vrf forwarding R1
 ip address 12.12.12.2 255.255.255.0
!
interface FastEthernet2/0
 ip address 23.23.23.2 255.255.255.0
!
+++++++++++++++++++++++++++++++++++
R3:
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet2/0
 ip address 23.23.23.3 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 23.23.23.2
!
+++++++++++++++++++++++++++++++++++

Regards,

Antonio Soares, CCIE #18473 (R&S)



This archive was generated by hypermail 2.1.4 : Mon Aug 04 2008 - 06:11:53 ART