From: ccietester55 ccietester55 (ccietester55@gmail.com)
Date: Wed May 28 2008 - 02:57:47 ART
I need some help with establishing a GRE tunnel between a router and a
switch. The topology is SW1 ----trunk---- SW2 ---- R6. SW1 and SW2
have a working trunk between them. SW1 and R6 are communicating over
vlan 120. There's an SVI for this vlan on SW1.
On SW1
interface Vlan120
ip address 10.1.1.1 255.255.255.0
On R6
interface Ethernet0/0
ip address 10.1.1.6 255.255.255.0
SW1 can ping R6 and vice versa. All looks good. Now I create a GRE
tunnel between SW1 and R6:
On SW1
interface Tunnel0
ip address 192.168.0.1 255.255.255.0
keep 10 3
tunnel source Vlan120
tunnel destination 10.1.1.6
On R6
interface Tunnel0
ip address 192.168.0.6 255.255.255.0
keep 10 3
tunnel source Ethernet0/0
tunnel destination 10.1.1.1
...and here's where I hit the problem. The tunnel does not come up.
When I do a "debug tunnel keep" on both devices I see SW1 sending and
receiving keepalives but R6 only sends them. It appears that SW1 is
dropping the keepalives from R6. When I turn off keepalives at both
ends the tunnel comes up and I can ping 192.168.0.6 from SW1 and
192.168.0.1 from R6.
I'm completely at a loss to explain this behavior. Vlan 120 on SW1 and
e0/0 on R6 can ping each other and yet they can't exchange keepalives?
And yet once keepalives are turned off the two devices can happily
exchange packets over the tunnel? Please help with this. I've been
looking at it for 5 hours and can't work it out!
Thanks,
Ash
This archive was generated by hypermail 2.1.4 : Mon Jun 02 2008 - 06:59:18 ART