From: Michael Whittle (mgwhittle@gmail.com)
Date: Fri Apr 11 2008 - 03:43:42 ART
Hi all,
I'm just practicing testing different multicast scenarios and something is
happening which I can't work out. I have been up since 5:30am so I'm
probably just tired and missing something.
I have configured 4 routers with this setup:
R5 (fa0/1-192.168.1.5) <--> (fa0/0-192.168.1.1) R1 (s0/0-10.0.0.1)
<--OSPF+FR--> (s0/0-10.0.0.3) R3 (fa0/0-192.168.3.3) <-->
(fa0/1-192.168.1.4) R4
I have connectivity end-to-end and I have configured PIM DM on all
interfaces. R3 and R5 are my test hosts. I setup IP SLA to send a UDP
broadcast with destination port of 5555 on R4. I've configured a multicast
helper on R3 and R1. For some reason my IP SLA probes aren't even leaving
R4. Can someone spot what's wrong?
R4#
interface FastEthernet0/1
ip address 192.168.3.4 255.255.255.0
!
R3#
interface FastEthernet0/0
ip address 192.168.3.3 255.255.255.0
ip directed-broadcast
ip pim dense-mode
ip multicast helper-map broadcast 239.3.3.3 100
!
interface Serial1/0
ip address 10.0.0.3 255.255.255.0
ip pim dense-mode
!
access-list 100 permit udp any any eq 5555
!
R1#
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip directed-broadcast
ip pim dense-mode
!
interface Serial1/0
ip address 10.0.0.3 255.255.255.0
ip multicast helper-map 239.3.3.3 192.168.1.255 100
ip pim dense-mode
!
access-list 100 permit udp any any eq 5555
!
R5#
interface FastEthernet0/1
ip address 192.168.1.5 255.255.255.0
!
I can ping end-to-end and multicast is working.
R4#ping 192.168.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms
I've set this up on R4:
ip sla monitor 1
type udpEcho dest-ipaddr 192.168.3.255 dest-port 5555 control disable
timeout 1
frequency 1
ip sla monitor schedule 1 start-time now
R4#ping 192.168.3.255
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.255, timeout is 2 seconds:
Reply to request 0 from 192.168.3.3, 1 ms
Reply to request 1 from 192.168.3.3, 1 ms
Reply to request 2 from 192.168.3.3, 1 ms
Reply to request 3 from 192.168.3.3, 1 ms
Reply to request 4 from 192.168.3.3, 1 ms
R4#debug ip packet
IP packet debugging is on
R4#
*Mar 2 01:21:17.741: IP: tableid=0, s=192.168.3.4 (local),
d=192.168.3.255(FastEthernet0/1), routed via RIB
*Mar 2 01:21:17.741: IP: s=192.168.3.4 (local),
d=192.168.3.255(FastEthernet0/1), len 44, sending
*Mar 2 01:21:17.741: IP: s=192.168.3.4 (local),
d=192.168.3.255(FastEthernet0/1), len 44, encapsulation failed
*Mar 2 01:21:18.741: IP: tableid=0, s=192.168.3.4 (local),
d=192.168.3.255(FastEthernet0/1), routed via RIB
*Mar 2 01:21:18.741: IP: s=192.168.3.4 (local),
d=192.168.3.255(FastEthernet0/1), len 44, sending
*Mar 2 01:21:18.741: IP: s=192.168.3.4 (local),
d=192.168.3.255(FastEthernet0/1), len 44, encapsulation failed
*Mar 2 01:21:19.741: IP: tableid=0, s=192.168.3.4 (local),
d=192.168.3.255(FastEthernet0/1), routed via RIB
*Mar 2 01:21:19.741: IP: s=192.168.3.4 (local),
d=192.168.3.255(FastEthernet0/1), len 44, sending
*Mar 2 01:21:19.741: IP: s=192.168.3.4 (local),
d=192.168.3.255(FastEthernet0/1), len 44, encapsulation failed
*Mar 2 01:21:20.741: IP: tableid=0, s=192.168.3.4 (local),
d=192.168.3.255(FastEthernet0/1), routed via RIB
*Mar 2 01:21:20.741: IP: s=192.168.3.4 (local),
d=192.168.3.255(FastEthernet0/1), len 44, sending
*Mar 2 01:21:20.741: IP: s=192.168.3.4 (local),
d=192.168.3.255(FastEthernet0/1), len 44, encapsulation failed
Does anyone know why I'm getting "encapsulation failed"?
Thanks in advance.
Regards,
Mike
Pass the CCIE in six weeks, Guaranteed!
http://www.certscience.com/CCIE
This archive was generated by hypermail 2.1.4 : Thu May 01 2008 - 08:25:50 ART