Re: OSPF point-to-multipoint

From: Olugbenga Adanlawo (gbengaadan@hotmail.com)
Date: Tue Mar 25 2008 - 21:45:39 ART


I just lab it up with PPPoFR on dynamips and i can ping spoke to spoke

!
============R1 (spoke)======================
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay interface-dlci 102 ppp Virtual-Template12
!
!
interface Virtual-Template12
 ip address 10.10.10.1 255.255.255.0
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.10.10.1 0.0.0.0 area 0
!
=============R2 (Hub)==================
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay interface-dlci 201 ppp Virtual-Template21
 frame-relay interface-dlci 203 ppp Virtual-Template23
!
!
interface Virtual-Template21
 ip address 10.10.10.2 255.255.255.0
!
interface Virtual-Template23
 ip address 10.10.10.2 255.255.255.0
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 10.10.10.2 0.0.0.0 area 0
!
=================R3 (Spoke)===================
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay interface-dlci 302 ppp Virtual-Template32
!
interface Virtual-Template32
 ip address 10.10.10.3 255.255.255.0
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 10.10.10.3 0.0.0.0 area 0
!

!

Regards

--------------------------------------------------
From: "Olugbenga Adanlawo" <gbengaadan@hotmail.com>
Sent: Wednesday, March 26, 2008 1:15 AM
To: <steveaggie@gmail.com>; "'Sadiq Yakasai'" <sadiqtanko@gmail.com>; "Bob
Sinclair" <bob@bobsinclair.net>
Cc: "Cisco certification" <ccielab@groupstudy.com>
Subject: Re: OSPF point-to-multipoint

> Hi Steve,
>
> Do you have the constrains of the hub network type to be p2p and no mapping
> between hubs? If not change the network type on the hub to p2mp or create a
> FR mapping.
>
> With the two above constrains, what i can think of is to use PPPoFR and run
> OSPF on the virtual template.
>
> Regards
>
> Gbenga
>
> --------------------------------------------------
> From: <steveaggie@gmail.com>
> Sent: Wednesday, March 26, 2008 12:34 AM
> To: "'Sadiq Yakasai'" <sadiqtanko@gmail.com>; "Bob Sinclair"
> <bob@bobsinclair.net>
> Cc: "Cisco certification" <ccielab@groupstudy.com>
> Subject: RE: OSPF point-to-multipoint
>
>> Ok here are the configs, but this time R2 and R4 are spokes and R5 is the
>> hub.
>>
>> ===========R2======================
>> interface Serial1/0
>> ip address 140.1.245.2 255.255.255.0
>> encapsulation frame-relay
>> ip ospf network point-to-point
>> serial restart-delay 0
>> frame-relay map ip 140.1.245.5 205 broadcast
>> no frame-relay inverse-arp
>>
>> show ip route:
>> C 140.1.245.0/24 is directly connected, Serial1/0
>> O 140.1.245.5/32 [110/64] via 140.1.245.5, 01:32:08, Serial1/0
>>
>> Rack1R2#ping 140.1.245.5
>>
>> Type escape sequence to abort.
>> Sending 5, 100-byte ICMP Echos to 140.1.245.5, timeout is 2 seconds:
>> !!!!!
>> Success rate is 100 percent (5/5), round-trip min/avg/max = 8/52/96 ms
>> Rack1R2#ping 140.1.245.4
>>
>> Type escape sequence to abort.
>> Sending 5, 100-byte ICMP Echos to 140.1.245.4, timeout is 2 seconds:
>> .....
>> Success rate is 0 percent (0/5)
>>
>> ==========R5====================
>> interface Serial1/0
>> ip address 140.1.245.5 255.255.255.0
>> encapsulation frame-relay
>> ip ospf network point-to-multipoint
>> ip ospf hello-interval 10
>> serial restart-delay 0
>> frame-relay map ip 140.1.245.2 502 broadcast
>> frame-relay map ip 140.1.245.4 504 broadcast
>> no frame-relay inverse-arp
>>
>> show ip route (omitted extra junk):
>> C 140.1.245.0/24 is directly connected, Serial1/0
>>
>> Rack1R5#ping 140.1.245.2
>>
>> Type escape sequence to abort.
>> Sending 5, 100-byte ICMP Echos to 140.1.245.2, timeout is 2 seconds:
>> !!!!!
>> Success rate is 100 percent (5/5), round-trip min/avg/max = 12/42/84 ms
>> Rack1R5#ping 140.1.245.4
>>
>> Type escape sequence to abort.
>> Sending 5, 100-byte ICMP Echos to 140.1.245.4, timeout is 2 seconds:
>> !!!!!
>> Success rate is 100 percent (5/5), round-trip min/avg/max = 8/113/324 ms
>>
>> =============R4================
>> interface Serial1/0
>> ip address 140.1.245.4 255.255.255.0
>> encapsulation frame-relay
>> ip ospf network point-to-point
>> serial restart-delay 0
>> frame-relay map ip 140.1.245.5 405 broadcast
>> no frame-relay inverse-arp
>>
>> show ip route (omitted extra junk):
>> C 140.1.245.0/24 is directly connected, Serial1/0
>> O 140.1.245.5/32 [110/64] via 140.1.245.5, 01:36:05, Serial1/0
>>
>> Type escape sequence to abort.
>> Sending 5, 100-byte ICMP Echos to 140.1.245.5, timeout is 2 seconds:
>> !!!!!
>> Success rate is 100 percent (5/5), round-trip min/avg/max = 80/199/296 ms
>> Rack1R4#ping 140.1.245.2
>>
>> Type escape sequence to abort.
>> Sending 5, 100-byte ICMP Echos to 140.1.245.2, timeout is 2 seconds:
>> .....
>> Success rate is 0 percent (0/5)
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Tue Apr 01 2008 - 07:53:54 ART