From: keith tokash (ktokash@hotmail.com)
Date: Sat Feb 23 2008 - 18:01:58 ARST
There's a very simple way to see DEFINITIVELY if you're working with the
reserved-bandwidth, or the total interface bandwidth.
-----------------------------------------------------------------------------
--------
class-map match-all TEST
match ip precedence 5
!
!
policy-map TEST_POL
class TEST
priority percent 76
Rack1R1(config-pmap)#int s1/0
Rack1R1(config-if)#service-policy output TEST_POL
I/f Serial1/0 class TEST requested bandwidth 76%, available only 75%
-----------------------------------------------------------------------------
--------
Boom. If you were working within the sub-percentage of the max-reserve, you
would be able to allocate 100%.
Now, leaving the interface bandwidth alone (default at 128k), I use FRTS to
set the CIR to 256k, then use MQC to try and prioritize 128k. 50% will work
fine if CIR is the baseline used by IOS.
-----------------------------------------------------------------------------
--------
class-map match-all TEST
match ip precedence 5
policy-map TEST_POL
class TEST
priority 128000
map-class frame-relay TEST_MC
frame-relay cir 256000
service-policy output TEST_POL
Rack1R1#sh int s1/0 | i BW
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
Rack1R1(config-if)#frame traffic-shaping
I/f Serial1/0 DLCI 102 class TEST requested bandwidth 128000 (kbps), available
only 128 (kbps)
Traffic shaping not enabled due to invalid policy in map-class TEST_MC
-----------------------------------------------------------------------------
--------
It looks pretty clear that IOS is taking its queue (pun!) from the actual
bandwidth of the physical interface as set by the "bandwidth" command, which
makes sense if you think in terms of serialization rates on the interface.
With a few exceptions, secrecy is deeply incompatible with democracy and with
science.
--Carl Sagan
> Subject: RE: Frame-relay trafic shaping
> Date: Thu, 21 Feb 2008 12:56:29 -0500
> From: DTODD@PARTNERS.ORG
> To: pbhatkoti@gmail.com; cisco@groupstudy.com
> CC: ccielab@groupstudy.com
>
> Hmm -- some light heading your way I hope and not a dark spot...
>
>
> Some correct me if I'm incorrect:
>
> When you apply QoS to a circuit it takes 75% of the bandwidth, 25% is set
for
> control and IGP (etc). If you need to reserve %20 percent, I would assume
that
> it's 20% of the interface bandwidth, thus a max-bandwidth statement must be
> applied. Then you are taking %20 of the interface bandwidth and not %20 of
%75
> of the interface bandwidth.
>
> Thus you are working with 75% of the interface bandwidth (sh int | i BW)
(no
> max-bandwidth statement).
>
> Q2: If you are not using max-bandwidth then its %20 of the %75 interface BW.
CIR
> is just the threshold of where you want the DE bit to be set. But obviously
it's
> part of the Bc/Be formulas.
>
> Douglas
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Radioactive Frog
> Sent: Wednesday, February 20, 2008 7:13 PM
> To: Cisco certification
> Cc: ccie forum
> Subject: Frame-relay trafic shaping
>
> FRTS question folks,
>
> Q1. in QoS class-map statement, if we have to reserve 20% bandwidth - will
that
> be calculated from Frame-relay CIR???? (CIR=95% of BW). I am not sure....
>
> Q2. Also if we have to allocate 20% bandwidth for signaling traffic - will
that
> be calculated from CIR? or Total Bandwidth?
>
> can someone shed some light on this please....
>
>
> Frog
>
>
> interface Serial6/0
> description Parent FR Link for BRANCH#60 no ip address encapsulation
frame-relay
> frame-relay traffic-shaping !
>
>
> interface Serial6/0.60 point-to-point
> description FR Sub-Interface for BRANCH#60 bandwidth 256
>
> frame-relay interface-dlci 60 ppp Virtual-Template60 ! Enables MLPoFR
class
> FRTS-256kbps ! Binds the map-class to the FR DLCI
>
>
>
> !
> interface Virtual-Template60
> bandwidth 256
> ip address 10.200.60.2 255.255.255.252
> service-policy output WAN-EDGE ! Attaches MQC policy to map-class ppp
multilink
> ppp multilink fragment-delay 10 ! Enables MLP fragmentation ppp multilink
> interleave ! Enables MLP interleaving !
>
> !
> map-class frame-relay FRTS-256kbps
> frame-relay cir 243200 ! CIR is set to 95% of FR DLCI rate frame-relay bc
2432 !
> Bc is set to CIR/100 frame-relay be 0 ! Be is set to 0 frame-relay mincir
243200
> ! MinCIR is set to CIR
>
>
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.5.516 / Virus Database: 269.20.8/1289 - Release Date: 2/20/2008
10:26
> AM
>
>
> No virus found in this outgoing message.
> Checked by AVG Free Edition.
> Version: 7.5.516 / Virus Database: 269.20.8/1289 - Release Date: 2/20/2008
10:26
> AM
>
>
> The information transmitted in this electronic communication is intended
only
> for the person or entity to whom it is addressed and may contain
confidential
> and/or privileged material. Any review, retransmission, dissemination or
other
> use of or taking of any action in reliance upon this information by persons
or
> entities other than the intended recipient is prohibited. If you received
this
> information in error, please contact the Compliance HelpLine at 800-856-1983
and
> properly dispose of this information.
>
This archive was generated by hypermail 2.1.4 : Sat Mar 01 2008 - 16:54:49 ARST