From: YourPal (dearprudence28@gmail.com)
Date: Sun Feb 17 2008 - 22:51:32 ARST
Hi Group,
I'm facing an issue with DHCP proxy-client feature. Below is my setup:
R4 (s0/1) -----PPP----- (s0/1/0) R5 (s0/0/0.501 p2p) -----FR----- (s0/0/0)
R1
R5 is configured with DHCP proxy-client feature. R4 negotiates an IP address
dynamically. R1 is the DHCP server and should supply R4's serial interface
with the IP address 139.1.45.4.
R4 config
---------
!
interface Serial0/1
ip address negotiated
encapsulation ppp
!
R5 config
---------
!
interface Serial0/1/0
ip address 139.1.45.5 255.255.255.0
encapsulation ppp
peer default ip address dhcp
clockrate 2000000
!
interface Serial0/0/0.501 point-to-point
ip address 139.1.15.5 255.255.255.0
frame-relay interface-dlci 501
!
ip dhcp-server 139.1.15.1
!
R1 config
---------
!
interface Serial0/0/0
ip address 139.1.15.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 139.1.15.5 105 broadcast
no frame-relay inverse-arp
!
ip dhcp excluded-address 139.1.45.1 139.1.45.3
ip dhcp excluded-address 139.1.45.5 139.1.45.254
ip dhcp pool TEMP_R4
network 139.1.45.0 255.255.255.0
!
R4 fails to negotiate an IP address despite R1 having a DHCP binding:
R1#sh ip dh binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
139.1.45.4 0063.6973.636f.2d31. Feb 18 2008 02:30 PM
Automatic
3339.2e31.2e34.352e.
352d.5365.7269.616c.
302f.312f.30
Shut R4's s0/1 interface, do "cle ip dhc bind *" on R1, then no shut R4's
s0/1 interface. R4 still fails to obtain an IP address.
Part of the outputs of "deb ppp nego" on R4:
Se0/1 IPCP: I CONFREQ [ACKsent] id 10 len 10
Se0/1 IPCP: Address 139.1.45.5 (0x03068B012D05)
Se0/1 IPCP: O CONFACK [ACKsent] id 10 len 10
Se0/1 IPCP: Address 139.1.45.5 (0x03068B012D05)
Se0/1 IPCP: TIMEout: State ACKsent
Se0/1 IPCP: O CONFREQ [ACKsent] id 10 len 10
Se0/1 IPCP: Address 0.0.0.0 (0x030600000000)
Se0/1 IPCP: I CONFREJ [ACKsent] id 8 len 10
Se0/1 IPCP: Address 0.0.0.0 (0x030600000000)
Se0/1 IPCP: ID 8 didn't match 10, discarding packet
Can anyone advise what am I missing?
Thank you.
BR,
Emil
This archive was generated by hypermail 2.1.4 : Sat Mar 01 2008 - 16:54:49 ARST