Re: EIGRP redistribution between 2 VRFs

From: Rich Collins (nilsi2002@gmail.com)
Date: Sun Feb 17 2008 - 19:02:20 ARST


I found this link in my notes:
http://www.gossamer-threads.com/lists/cisco/nsp/80981

It looks like you need additionally a standalone bgp instance (no neighbor
necessary). Something along the lines of:

You will have to check who much of the "redistribute connected" you will
need.

router bgp 99999
!
address-family ipv4
redistribute connected
exit-address-family
!
address-family ipv4 *vrf* JP
redistribute connected
redistribute *eigrp* IPEXPERT
exit-address-family
!
address-family ipv4 *vrf* IPEXPERT
redistribute connected
redistribute *eigrp* JP
exit-address-family

-Rich

On 2/14/08, Luan Nguyen <luan.m.nguyen@gmail.com> wrote:
>
> Hi guys,
> Say i have VRF JP one one of the interface, and VRF IPEXPERT on another
> interface. And i need to run EIGRP on both of them. They have their own
> ASN and don't want to change them. How do i send routes learned from JP
> into IPEXPERT and vice versa? From the command line, EIGRP doesn't allow
> redistribution of EIGRP from VRF.
>
> Sample config is something like this:
> router eigrp 1
> passive-interface default
> no passive-interface Tunnel0
> no auto-summary
> !
> address-family ipv4 vrf IPEXPERT
> network 10.0.0.0 0.0.1.255
> no auto-summary
> autonomous-system 1
> exit-address-family
> !
> router eigrp 2
> passive-interface default
> no passive-interface tunnel1
> no auto-summary
> !
> address-family ipv4 vrf JP
> network 10.1.1.1 0.0.0.0
> no auto-summary
> autonomous-system 1
> exit-address-family
>
>
> DMVPNSite1R1(config-router-af)#redistribute eigrp 1 ?
> metric Metric for redistributed routes
> route-map Route map reference
> <cr>
>
> No VRF option there, unlike say OSPF
>
> DMVPNSite1R1(config-router-af)#redistribute ospf 1 ?
> match Redistribution of OSPF routes
> metric Metric for redistributed routes
> route-map Route map reference
> vrf VPN Routing/Forwarding Instance
> <cr>
>
> Is there a way to advertise routes between them?
>
> TIA
>
> -lmn
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sat Mar 01 2008 - 16:54:48 ARST