RE: OSPF adjacency problem (may be dynamips related)

From: steveaggie@gmail.com
Date: Thu Dec 27 2007 - 22:57:48 ART


Thanks for taking a look. One thing I just noticed as I was doing this was
that R3 seems to have a limit on the number of OSPF adjacencies. It has
adjacencies with 2 other routers out that interface. (This is IEWB-DYN Lab
5). When I killed one of the other routers, suddenly the R2-R3 adjacency
came up. Then after a few minutes R3-R5 finally comes up. I don't know
what's going on now.

-------------R2--------------
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 162.1.27.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/0.1 point-to-point
 ip address 162.1.0.2 255.255.255.0
 ip ospf network non-broadcast
 frame-relay interface-dlci 203
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 150.1.2.2
 log-adjacency-changes
 area 27 stub no-summary
 network 150.1.2.2 0.0.0.0 area 0
 network 162.1.0.2 0.0.0.0 area 0
 network 162.1.27.2 0.0.0.0 area 27
 neighbor 162.1.0.3
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 neighbor 162.1.0.3 remote-as 300
 neighbor 162.1.27.7 remote-as 65001
 no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
!
end

Rack1R2#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
150.1.3.3 10 FULL/DR 00:01:42 162.1.0.3
Serial1/0.1
150.1.7.7 1 FULL/DR 00:00:39 162.1.27.7
FastEthernet0/0
Rack1R2#sh frame map
Serial1/0.1 (up): point-to-point dlci, dlci 203(0xCB,0x30B0), broadcast
          status defined, active

------------------R3-----------------------
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R3
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
!
interface Ethernet0/0
 ip address 162.1.38.3 255.255.255.0
 full-duplex
!
interface Ethernet0/1
 ip address 162.1.3.3 255.255.255.0
 full-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 ip address 162.1.0.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network non-broadcast
 ip ospf priority 10
 serial restart-delay 0
 frame-relay map ip 162.1.0.2 302 broadcast
 frame-relay map ip 162.1.0.4 304 broadcast
 frame-relay map ip 162.1.0.5 305 broadcast
 frame-relay interface-dlci 302
 no frame-relay inverse-arp
!
interface Serial1/1
 ip address 162.1.13.3 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 162.1.13.1 311 broadcast
 no frame-relay inverse-arp
!
interface Serial1/2
 no ip address
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 serial restart-delay 0
!
router eigrp 200
 redistribute ospf 1 metric 10000 100 255 1 1500
 network 162.1.3.3 0.0.0.0
 network 162.1.13.3 0.0.0.0
 network 162.1.38.3 0.0.0.0
 metric weights 0 3 1 0 1 0
 no auto-summary
!
router ospf 1
 router-id 150.1.3.3
 log-adjacency-changes
 network 150.1.3.3 0.0.0.0 area 0
 network 162.1.0.3 0.0.0.0 area 0
 neighbor 162.1.0.2
 neighbor 162.1.0.4
 neighbor 162.1.0.5
 default-information originate always
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 neighbor 162.1.0.2 remote-as 300
 neighbor 162.1.0.4 remote-as 100
 neighbor 162.1.13.1 remote-as 200
 neighbor 162.1.38.8 remote-as 65002
 no auto-summary
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
!
end

Rack1R3#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
150.1.2.2 1 FULL/DROTHER 00:01:53 162.1.0.2 Serial1/0
150.1.4.4 1 FULL/DR 00:01:57 162.1.0.4 Serial1/0
150.1.5.5 1 FULL/DROTHER 00:01:48 162.1.0.5 Serial1/0
Rack1R3#sh frame map
Serial1/0 (up): ip 162.1.0.2 dlci 302(0x12E,0x48E0), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 162.1.0.4 dlci 304(0x130,0x4C00), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 162.1.0.5 dlci 305(0x131,0x4C10), static,
              broadcast,
              CISCO, status defined, active
Serial1/1 (up): ip 162.1.13.1 dlci 311(0x137,0x4C70), static,
              broadcast,
              CISCO, status defined, active

-----Original Message-----
From: Brian Dennis [mailto:bdennis@internetworkexpert.com]
Sent: Thursday, December 27, 2007 7:40 PM
To: steveaggie@gmail.com; ccielab@groupstudy.com
Subject: Re: OSPF adjacency problem (may be dynamips related)

Can you post your configurations for these two routers along with the
output of the show ip ospf neighbor and show frame-relay map commands from
each router?

Brian Dennis, CCIE4 #2210 (R&S/ISP-Dial/Security/SP)
bdennis@internetworkexpert.com

Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)

>----- Original Message -----
Subject: OSPF adjacency problem (may be dynamips related)
Date: Thu, December 27, 2007 16:38
From: steveaggie@gmail.com

> Has anyone had trouble with OSPF routes not being added to your routing
> table even though they're unique routes? I've been having a heck of a
time
> with 2 routers forming an adjacency. My topology looks like this:
>
>
>
> R2---frame-------R3
>
>
>
> R2 is a p2p sub interface. R3 is a physical interface. Both are
configured
> as non-broadcast and the other neighbor is specified.
>
>
>
> They don't seem to send hellos every 30 seconds, but once in a blue moon.
> They will get up to EXSTART on R2 and 2WAY on R3 but eventually the dead
> timer goes off and they start over. If I change the network type on
both to
> broadcast they will get to FULL pretty quickly, but then R2 never puts the
> routes in the routing table even though they show up in the OSPF database.
>
>
>
> One time I rebooted the whole network and everything worked fine (in
> non-broadcast mode). I'm using dynamips so I'm wondering if it's somehow
> related. I can run a continuous ping between the routers and not drop a
> packet.
>
>
>
> Please help before I pull my hair out.
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Tue Jan 01 2008 - 12:04:32 ARST