RE: DMVPN Multihomed(Hus & Spokes)with Loopback interfaces Help

From: SAMARTH (samarth_04@hotmail.com)
Date: Sun Dec 16 2007 - 16:31:46 ART


If R2 is the spoke, I would do this

interface Tunnel0
 ip address 10.10.1.2 255.255.255.0
 no ip redirects
 ip mtu 1440
 ip nhrp authentication cisco123
 ip nhrp map 10.10.1.1 1.1.1.1
 ip nhrp map multicast 1.1.1.1
 ip nhrp network-id 1
 ip nhrp nhs 10.10.1.1
 ip ospf network broadcast
 tunnel source Loopback1
 tunnel key 0
 tunnel protection ipsec profile cisco
 tunnel mode gre multipoint

Best Wishes,
C SAMARTH
CCIE #18535
CCSP CCNP CCNA
MCSE MCSD SCSA1

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of atif
raees
Sent: Sunday, December 16, 2007 6:35 PM
To: ccielab@groupstudy.com
Subject: DMVPN Multihomed(Hus & Spokes)with Loopback interfaces Help
Required

Dear All

I am testing DMVPN with Hub & spoke connectivity.
hub connects to the SP using redundant link for fail over so as the Spoke
redundant link to SP.
I have used Loopbacks on both sites.

Problem is i need to add two static route pointing remote loop back with
each
next hop physical interface so that my tunnels can go up & failover.
i there any way to eliminate the static routes b/c at HUB site then i will
need to use static route for each spoke sites.

Below is the config (R1 Hub connects to R2 spoke)

R1:

crypto isakmp policy 10
 hash md5
 authentication pre-share
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set strong esp-3des esp-md5-hmac
!
crypto ipsec profile cisco
 set security-association lifetime seconds 120
 set transform-set strong
!
!
!
!
!
!
interface Tunnel0
 ip address 10.10.1.1 255.255.255.0
 no ip redirects
 ip mtu 1440
 ip nhrp authentication cisco123
 ip nhrp map multicast dynamic
 ip nhrp network-id 1
 ip ospf network broadcast
 tunnel source Loopback1
 tunnel mode gre multipoint
 tunnel key 0
 tunnel protection ipsec profile cisco
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.2.1 255.255.255.252
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 172.16.10.1 255.255.255.252
 encapsulation ppp
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/1
 ip address 172.16.11.1 255.255.255.252
 encapsulation ppp
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
router ospf 1
 log-adjacency-changes
 network 10.1.1.0 0.0.0.255 area 0
 network 10.10.1.0 0.0.0.255 area 0
!
ip http server
no ip http secure-server
!
ip route 2.2.2.2 255.255.255.255 192.168.1.2
ip route 2.2.2.2 255.255.255.255 172.16.10.2 254



This archive was generated by hypermail 2.1.4 : Tue Jan 01 2008 - 12:04:31 ARST