Re: RIP conditional route advertisement

From: shiran guez (shiranp3@gmail.com)
Date: Sun Nov 11 2007 - 05:49:48 ART


i think there is some confusion here on what you want to achieve, and what
are you getting wrong.

can you organize it again?

On Nov 11, 2007 10:15 AM, Joseph Brunner <joe@affirmedsystems.com> wrote:

> >but the route map is only indicating that if they are there then send a
> default route not if they are not there
>
>
>
> (check the task again)
>
>
>
> Task:
>
>
>
> Router6 should advertise a rip default route ONLY to Switch1 and ONLY if
> either 150.1.1.0/24 or 150.1.3.0/24 exist in the routing table.
>
>
> ------------------------------
>
> *From:* shiran guez [mailto:shiranp3@gmail.com]
> *Sent:* Sunday, November 11, 2007 3:07 AM
>
> *To:* Joseph Brunner
> *Cc:* groupstudy
> *Subject:* Re: RIP conditional route advertisement
>
>
>
> but the route map is only indicating that if they are there then send a
> default route not if they are not there. you are matching with a permit 2
> route map with 2 permit access list
>
>
>
> if you wanted to distribute a default route in case that one of this
> prefix is not on the routing table then this should be
>
>
>
>
>
> route-map condition deny 10
>
> match ip address 10
>
> set interface xxxx
>
> route-map condition deny 20
>
> match ip address 20
>
> set interface yyyy
>
> route-map condition permit 30
>
>
>
> or
>
>
>
> route-map condition per 10
>
> match ip address 10
>
> set interface xxxx
>
> route-map condition per 20
>
> match ip address 20
>
> set interface yyyy
>
>
>
> access-list 10 deny 150.1.1.0 0.0.0.255
>
> access-list 10 per any
>
> access-list 20 deny 150.1.3.0 0.0.0.255
>
> access-list 20 per any
>
>
>
> in that way if you do not see one of the routes then you will advertise a
> default route.
>
>
>
>
>
> On Nov 11, 2007 9:45 AM, Joseph Brunner <joe@affirmedsystems.com> wrote:
>
> I didn't overlook anything ;)
>
>
>
> My verification was to show the routes leaving the routing table one by
> one,
>
> the first one leaving from R6' s connected 150.1.1.0/24 (f0/1) being
>
> shutdown, the second from a s0/0 to r5 (where 150.1.3.0/24 is connected to
> bb3.
>
>
>
> Either route is enough to make the rip conditional default succeed,
>
> Lack of BOTH routes in R6's routing table is enough to make rip stop
> default
> originating to Sw1 via R6's f0/0
>
>
>
> -Joe
>
> _____
>
> From: shiran guez [mailto: shiranp3@gmail.com]
> Sent: Sunday, November 11, 2007 1:31 AM
> To: Joseph Brunner
> Cc: groupstudy
> Subject: Re: RIP conditional route advertisement
>
>
> your condition was only if one of the network is showing on the Routing
> Table but you probebly overlooked that both networks are not in your
> routing
> table from your verification
>
>
>
> Verification
>
> rack1r6(config)#int f0/1
>
> rack1r6(config-if)#shut
>
> rack1r6#sh ip route 150.1.1.0 <http://150.1.1.0/ >
>
>
> % Subnet not in table
>
> rack1r6(config)#int s0/0
>
> rack1r6(config-if)#shut
>
> rack1r6(config-if)#^Z
>
> rack1r6#sh ip route 150.1.3.0 <http://150.1.3.0/>
>
>
> % Network not in table
>
>
>
> can you show that the routes do apear on your routing table and you still
> do
> not advertise the 0.0.0.0/0?
>
>
> 1) Make sure first the routes (150.1.3.0 <http://150.1.3.0/> or 150.1.1.0
> <http://150.1.1.0/> ) are showing on your RIB
>
>
> 2) do clear ip route * on SW1 to reinitialize the build of the RIB
>
> 3) If you still do not see the default route on SW1 then do debug ip rip
> on
> R6 to make sure it is sending i, after you verified step 1.
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> On Nov 11, 2007 6:38 AM, Joseph Brunner <joe@affirmedsystems.com> wrote:
>
> From my own personal lab testing of the doc cd;
>
>
>
> Task:
>
>
>
> Router6 should advertise a rip default route ONLY to Switch1 and ONLY if
> either 150.1.1.0/24 or 150.1.3.0/24 exist in the routing table.
>
>
>
>
>
> rack1r6#sh run | b router rip
>
> router rip
>
> version 2
>
> network 1.0.0.0 < http://1.0.0.0/>
>
> network 150.1.0.0 <http://150.1.0.0/>
>
>
> default-information originate route-map BBNETSCHECK
>
> no auto-summary
>
>
>
> route-map BBNETSCHECK permit 10
>
> match ip address 10
>
> set interface FastEthernet0/0
>
> !
>
> route-map BBNETSCHECK permit 20
>
> match ip address 20
>
> set interface FastEthernet0/0
>
>
> access-list 10 permit 150.1.1.0 < http://150.1.1.0/> 0.0.0.255
> <http://0.0.0.255/>
>
> access-list 20 permit 150.1.3.0 <http://150.1.3.0/> 0.0.0.255
> <http://0.0.0.255/>
>
>
>
>
> Verification;
>
>
>
> (see if the route is now on sw1)
>
>
> rack1sw1#sh ip route 0.0.0.0 < http://0.0.0.0/>
>
>
> Routing entry for 0.0.0.0/0, supernet
>
> Known via "rip", distance 120, metric 1, candidate default path
>
> Redistributing via ospf 1, rip
>
> Last update from 1.1.16.6 <http://1.1.16.6/> on GigabitEthernet0/6,
>
> 00:00:02 ago
>
> Routing Descriptor Blocks:
>
> * 1.1.16.6 <http://1.1.16.6/> , from 1.1.16.6 <http://1.1.16.6/> ,
> 00:00:02
>
> ago, via GigabitEthernet0/6
>
> Route metric is 1, traffic share count is 1
>
>
>
> Verification
>
> rack1r6(config)#int f0/1
>
> rack1r6(config-if)#shut
>
> rack1r6#sh ip route 150.1.1.0 <http://150.1.1.0/>
>
>
> % Subnet not in table
>
>
>
> (back on sw1, wait more than 30 seconds to be safe)
>
>
> rack1sw1#sh ip route 0.0.0.0 < http://0.0.0.0/>
>
>
> Routing entry for 0.0.0.0/0, supernet
>
> Known via "rip", distance 120, metric 1, candidate default path
>
> Redistributing via ospf 1, rip
>
> Last update from 1.1.16.6 <http://1.1.16.6/> on GigabitEthernet0/6,
>
> 00:00:18 ago
>
> Routing Descriptor Blocks:
>
> * 1.1.16.6 <http://1.1.16.6/> , from 1.1.16.6 <http://1.1.16.6/> ,
> 00:00:18
>
> ago, via GigabitEthernet0/6
>
> Route metric is 1, traffic share count is 1
>
>
>
> (now shutdown the last interface towards BB3, 150.1.3.0/24 on router 6)
>
> rack1r6(config)#int s0/0
>
> rack1r6(config-if)#shut
>
> rack1r6(config-if)#^Z
>
> rack1r6#sh ip route 150.1.3.0 < http://150.1.3.0/>
>
>
> % Network not in table
>
>
>
> (Check on switch1; wait a while, past invalid then flush timer)
>
>
> rack1sw1#sh ip route 0.0.0.0 <http://0.0.0.0/>
>
>
> Routing entry for 0.0.0.0/0, supernet
>
> Known via "rip", distance 120, metric 1, candidate default path
>
> Redistributing via ospf 1, rip
>
> Last update from 1.1.16.6 <http://1.1.16.6/> on GigabitEthernet0/6,
>
> 00:02:58 ago
>
> Routing Descriptor Blocks:
>
> * 1.1.16.6 <http://1.1.16.6/> , from 1.1.16.6 <http://1.1.16.6/> ,
> 00:02:58
>
> ago, via GigabitEthernet0/6
>
> Route metric is 1, traffic share count is 1
>
>
> rack1sw1#sh ip route 0.0.0.0 < http://0.0.0.0/>
>
> Routing entry for 0.0.0.0/0 <http://0.0.0.0/0> , supernet
>
>
> Known via "rip", distance 120, metric 4294967295 (inaccessible),
> candidate
> default path
>
> Redistributing via ospf 1, rip
>
> Last update from 1.1.16.6 <http://1.1.16.6/> on GigabitEthernet0/6,
>
> 00:03:02 ago
>
> Hold down timer expires in 0 secs
>
>
>
> (Gone)
>
>
>
>
> rack1sw1#sh ip route 0.0.0.0 < http://0.0.0.0/>
>
>
> % Network not in table
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
> --
> Shiran Guez
> MCSE CCNP NCE1
> http://cciep3.blogspot.com
>
> http://www.linkedin.com/in/cciep3 <http://www.linkedin.com/in/cciep3>
>
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
> --
> Shiran Guez
> MCSE CCNP NCE1
> http://cciep3.blogspot.com
> http://www.linkedin.com/in/cciep3
>

-- 
Shiran Guez
MCSE CCNP NCE1
http://cciep3.blogspot.com
http://www.linkedin.com/in/cciep3


This archive was generated by hypermail 2.1.4 : Sat Dec 01 2007 - 06:37:29 ART