From: Benedict Munyao (bmunyao@gmail.com)
Date: Tue Oct 23 2007 - 03:30:22 ART
Aminul,
The best way to verify this is by labbing it up. Here's my lab with
different eigrp ASes on R2:
eigrp10 eigrp100
R1--------------------------------------R2---------------------------------------------R3
155.2.123.0/24 155.2.23.0/24
R1
-----------------------------------------------------------------------
Rack1R1(config-router)#do sh ip int bri | e unass
Interface IP-Address OK? Method Status
Protocol
FastEthernet0/0 155.2.123.1 YES manual up
up
Loopback0 150.2.1.1 YES manual up
up
Loopback1 10.1.1.1 YES manual up
up
Rack1R1(config-router)#do sh run | s eigrp
router eigrp 10
network 10.1.1.1 0.0.0.0
network 150.2.1.1 0.0.0.0
network 155.2.123.1 0.0.0.0
no auto-summary
Rack1R1(config-router)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
155.2.0.0/24 is subnetted, 2 subnets
D EX 155.2.23.0 [170/2172416] via 155.2.123.2, 00:09:14, FastEthernet0/0
C 155.2.123.0 is directly connected, FastEthernet0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback1
150.2.0.0/24 is subnetted, 3 subnets
C 150.2.1.0 is directly connected, Loopback0
D EX 150.2.2.0 [170/156160] via 155.2.123.2, 00:09:14, FastEthernet0/0
D EX 150.2.3.0 [170/2300416] via 155.2.123.2, 00:09:14, FastEthernet0/0
Rack1R1(config-router)#
R2
--------------------------------------------------------------------------------------------
Rack1R2(config-router)#do sh ip int bri | e unass
Interface IP-Address OK? Method Status
Protocol
FastEthernet0/0 155.2.123.2 YES manual up
up
Serial1/1 155.2.23.2 YES manual up
up
Loopback0 150.2.2.2 YES manual up
up
Rack1R2(config-router)#do sh run | s eigrp
router eigrp 100
redistribute eigrp 10
network 150.2.2.2 0.0.0.0
network 155.2.23.2 0.0.0.0
no auto-summary
router eigrp 10
redistribute eigrp 100
network 155.2.123.2 0.0.0.0
no auto-summary
Rack1R2(config-router)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
155.2.0.0/24 is subnetted, 2 subnets
C 155.2.23.0 is directly connected, Serial1/1
C 155.2.123.0 is directly connected, FastEthernet0/0
10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/156160] via 155.2.123.1, 00:06:28, FastEthernet0/0
150.2.0.0/24 is subnetted, 3 subnets
D 150.2.1.0 [90/156160] via 155.2.123.1, 00:06:28, FastEthernet0/0
C 150.2.2.0 is directly connected, Loopback0
D 150.2.3.0 [90/2297856] via 155.2.23.3, 00:14:22, Serial1/1
R3
---------------------------------------------------------------------------------------------------
Rack1R3(config-router)#do sh ip int bri | e unass
Interface IP-Address OK? Method Status
Protocol
Serial1/3 155.2.23.3 YES manual up
up
Loopback0 150.2.3.3 YES manual up
up
Rack1R3(config-router)#do sh run | s eigrp
router eigrp 100
network 150.2.3.3 0.0.0.0
network 155.2.23.3 0.0.0.0
no auto-summary
Rack1R3(config-router)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
155.2.0.0/24 is subnetted, 2 subnets
C 155.2.23.0 is directly connected, Serial1/3
D EX 155.2.123.0 [170/2172416] via 155.2.23.2, 00:12:16, Serial1/3
10.0.0.0/24 is subnetted, 1 subnets
D EX 10.1.1.0 [170/2300416] via 155.2.23.2, 00:09:15, Serial1/3
150.2.0.0/24 is subnetted, 3 subnets
D EX 150.2.1.0 [170/2300416] via 155.2.23.2, 00:08:58, Serial1/3
D 150.2.2.0 [90/2297856] via 155.2.23.2, 00:08:58, Serial1/3
C 150.2.3.0 is directly connected, Loopback0
Rack1R3(config-router)#
Note that I did not specify metric, or default-metric for redistribution
between eigrp10 and eigrp100 on R2. As Herbert stated, EIGRP will carry over
the metrics from one AS to the other.
HTH
Benedict Munyao
On 10/23/07, Aminul Siddiqui <aminul.siddiqui@gmail.com> wrote:
>
> Yes, you need to define the metric even for the different processes of
> eigrp, otherwise you won't get it.
>
> HTH,
> Aminul
>
> On 10/22/07, Cecil Wilson <Cecil.Wilson@flextronics.com> wrote:
> >
> > Donghai
> > I don't follow?
> >
> >
> > Cecil G. Wilson
> > IT Network Services
> > Office: (901) 215-2710
> > Cell: (901) 601-6201
> > VoIP 104-2710
> > FLEX Logistics
> > cecil.wilson@flextronics.com
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> > Donghai Zhang
> > Sent: Sunday, October 21, 2007 10:30 PM
> > To: ccielab@groupstudy.com
> > Subject: Re: Help with Eigrp redistribution
> >
> > Dear,
> > No redistribution occur if two different routing protocol processes are
> > run on the same router.So you have to activate eirgrp 10 on R2 or
> > activate eigrp 100 on R1, otherwide the redistribution would not work.
> >
> > 2007/10/22, raul raul <juvenn@hotmail.com>:
> > >
> > > you need to include metric for eigrp redistribution
> > >
> > > example
> > >
> > > eigrp 10
> > > redistribute eigrp 100 subnet metric 1000 100 255 1 1500
> > > > From: scott_ccie_list@it-ag.com> To: Cecil.Wilson@flextronics.com;
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Fri Nov 16 2007 - 13:11:17 ART