From: Bob Sinclair (bob@bobsinclair.net)
Date: Wed Oct 17 2007 - 18:42:00 ART
Saul Arjona wrote:
>> Bob,
>>
>
>
>
> I labbed it up and it is not working as a functional AND but as a functional
> OR as Koen mentioned. So as long as one of the routes is still in the
> routing table we will still advertise the default route, it will stop
> advertising it only if both routes are out of the routing table.
>
> regards,
> -Saul
>
> You might want to lab this up. When I do a conditional default using
>
>> RIP or BGP the router in fact implements the match as an AND function.
>> In other words, BOTH must be in the table. Here is an example with BGP:
>>
>> interface Loopback2
>> ip address 2.2.2.2 255.255.255.0
>> !
>> interface Loopback20
>> ip address 20.0.0.1 255.0.0.0
>> shutdown
>> router bgp 200
>> no synchronization
>> bgp log-neighbor-changes
>> neighbor 172.16.25.5 remote-as 500
>> neighbor 172.16.25.5 default-originate route-map CONDITIONAL
>> no auto-summary
>> access-list 10 permit 2.0.0.0
>> access-list 20 permit 20.0.0.0
>> !
>> route-map CONDITIONAL permit 10
>> match ip address 10 20
>>
>>
Hi Saul,
It for this reason that I always tell students "believe none of what you
hear and only half of what you see". The result of any test will
depend on the complete context and exact procedures. Above, I have
shown you what I consider to be the relevant config on the sending
router. Below you will see the debug of what happens when ONLY ONE of
the loopbacks is shut:
R2#sh ip int brief | excl unass
Interface IP-Address OK? Method
Status Protocol
Serial0/0 172.16.123.2 YES NVRAM administratively
down down
Serial1/0 172.16.25.2 YES NVRAM
up up
Loopback2 2.2.2.2 YES manual
up up
Loopback20 20.0.0.1 YES manual
up up
R2(config)#int loop20
R2(config-if)#shut
R2(config-if)#
*Oct 16 04:21:10.321: BGP(0): 172.16.25.5 send unreachable 0.0.0.0/0
<<<<<<<NOTE
*Oct 16 04:21:10.321: BGP(0): 172.16.25.5 enqueued default-originate update
R2(config-if)#
*Oct 16 04:21:12.317: %LINK-5-CHANGED: Interface Loopback20, changed
state to administratively down
*Oct 16 04:21:13.317: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Loopback20, changed state to down
R2(config-if)#no shut
R2(config-if)#
*Oct 16 04:21:17.413: BGP(0): 172.16.25.5 enqueued default-originate
update <<<<< NOTE
R2(config-if)#
*Oct 16 04:21:19.405: %LINK-3-UPDOWN: Interface Loopback20, changed
state to up
*Oct 16 04:21:20.405: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Loopback20, changed state to up
R2(config-if)#
It sure looks to me like when I shut ONE of the loopbacks, withdrawing
ONLY ONE of the required routes, BGP withdraws the default. And when I
no-shut that interface it is re-advertised. To me, this pretty clearly
says that the router is implementing the route-map as an AND.
What am I missing??
Maybe you could share some of the context that led to your conclusion.
--Bob Sinclair CCIE 10427 CCSI 30427 www.netmasterclass.net
This archive was generated by hypermail 2.1.4 : Fri Nov 16 2007 - 13:11:15 ART