From: Saul Arjona (saul.arjona.bueno@gmail.com)
Date: Wed Oct 17 2007 - 19:00:03 ART
Sure Bob,
What I did is I am using three routers R4, R5 and R1 int a FR cloud with
R1 as the hub R4-----------R1----------R5
I created Loopback 10 and Loopback 11 with ip addresses 1.1.1.1/32 and
2.2.2.2/32 and I am advertising this routes via BGP to R1.
On R1 I am generating the default route to R5 with a Route-map as condition
matching to prefix lists that match 1.1.1.1/32 and 2.2.2.2/32
R4
interface Loopback10
ip address 1.1.1.1 255.255.255.255
!
interface Loopback11
ip address 2.2.2.2 255.255.255.255
interface Serial1/0
ip address 174.1.145.4 255.255.255.0
encapsulation frame-relay
delay 23423
serial restart-delay 0
frame-relay map ip 174.1.145.1 401 broadcast
frame-relay map ip 174.1.145.5 401
no frame-relay inverse-arp
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
network 2.2.2.2 mask 255.255.255.255
neighbor 174.1.145.1 remote-as 100
neighbor 174.1.145.1 send-community
neighbor 174.1.145.1 route-map NO_ADVERTISE out
no auto-summary
!
route-map NO_ADVERTISE permit 10
set community no-advertise
R1
interface Serial1/0
bandwidth 1544
ip address 174.1.145.1 255.255.255.0
encapsulation frame-relay
no ip split-horizon eigrp 1024
delay 1
serial restart-delay 0
frame-relay map ip 174.1.145.4 104 broadcast
frame-relay map ip 174.1.145.5 105 broadcast
no frame-relay inverse-arp
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 174.1.145.4 remote-as 100
neighbor 174.1.145.4 route-reflector-client
neighbor 174.1.145.5 remote-as 100
neighbor 174.1.145.5 route-reflector-client
neighbor 174.1.145.5 default-originate route-map CONDITIONAL
no auto-summary
ip prefix-list LOOP10 seq 5 permit 1.1.1.1/32
!
ip prefix-list LOOP11 seq 5 permit 2.2.2.2/32
route-map CONDITIONAL permit 10
match ip address prefix-list LOOP10 LOOP11
R5
interface Serial1/0
ip address 174.1.145.5 255.255.255.0
encapsulation frame-relay
delay 1
serial restart-delay 0
frame-relay map ip 174.1.145.1 501 broadcast
frame-relay map ip 174.1.145.4 501
no frame-relay inverse-arp
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 174.1.145.1 remote-as 100
no auto-summary
On R1 as long as one of the routes is in the routing table it will announce
the default route to R5
Rack1R1#show ip route | in 1.1.1.1|2.2.2.2
B 1.1.1.1 [200/0] via 174.1.145.4, 00:39:10
B 2.2.2.2 [200/0] via 174.1.145.4, 00:39:10
Rack1R1#
Rack1R1#show ip bgp neighbors 174.1.145.5 advertised-routes
BGP table version is 3, local router ID is 150.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Originating default network 0.0.0.0
Network Next Hop Metric LocPrf Weight Path
Rack1R1#
Here i shutdown loop10 on R4
Rack1R4(config)#int loop10
Rack1R4(config-if)#shut
Rack1R4(config-if)#
*Mar 1 01:42:03.983: %LINK-5-CHANGED: Interface Loopback10, changed state
to administratively down
*Mar 1 01:42:04.983: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Loopback10, changed state to down
Rack1R1#show ip route | in 1.1.1.1|2.2.2.2
B 2.2.2.2 [200/0] via 174.1.145.4, 00:40:16
Rack1R1#show ip bgp neighbors 174.1.145.5 advertised-routes
BGP table version is 4, local router ID is 150.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Originating default network 0.0.0.0
Network Next Hop Metric LocPrf Weight Path
Rack1R1#
You can see that I only have route 2.2.2.2 on the routing table, however R1
is still advertising the default to R5
Here I shutdown loop11 on R4
Rack1R4(config-if)#int loop11
Rack1R4(config-if)#shut
Rack1R4(config-if)#
*Mar 1 01:43:15.263: %LINK-5-CHANGED: Interface Loopback11, changed state
to administratively down
*Mar 1 01:43:16.263: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Loopback11, changed state to down
Rack1R1#show ip route | in 1.1.1.1|2.2.2.2
Rack1R1#show ip bgp neighbors 174.1.145.5 advertised-routes
Rack1R1#
When both routes are gone I do not advertise the default to R5 so both
routes need to be gone in order to not advertise the default to R5.
This archive was generated by hypermail 2.1.4 : Fri Nov 16 2007 - 13:11:15 ART