From: Gregory Gombas (ggombas@gmail.com)
Date: Mon Oct 08 2007 - 13:36:19 ART
Joe B,
I was giving this some thought...In this scenario R3 and R4 are the
spokes and only have mappings to R2 which is the hub correct?
If you do a show ip route on R3 what is the next hop for routes
learned from R4? Being they are in the same IP subnet I am assuming R2
will advertise R4 as the next hop in which case the Layer 2
encapsulation will fail because R3 doesn't have a mapping to R4.
Is that the case here? Can you do a show IP route on R3 for a route
learned from R4 i.e. R4's loopback?
Thanks,
Greg
On 10/7/07, Joseph Brunner <joe@affirmedsystems.com> wrote:
> rack1r2#sh run int s0/0
> Building configuration...
>
> Current configuration : 206 bytes
> !
> interface Serial0/0
> ip address 1.1.234.2 255.255.255.0
> encapsulation frame-relay
> ip ospf priority 0
> frame-relay map ip 1.1.234.3 203
> frame-relay map ip 1.1.234.4 204
> no frame-relay inverse-arp
> end
>
> rack1r3#sh run int s0/0
> Building configuration...
>
> Current configuration : 172 bytes
> !
> interface Serial0/0
> ip address 1.1.234.3 255.255.255.0
> encapsulation frame-relay
> ip ospf priority 0
> frame-relay map ip 1.1.234.2 302
> no frame-relay inverse-arp
> end
>
>
> rack1r4#sh run int s0/0
> Building configuration...
>
> Current configuration : 203 bytes
> !
> interface Serial0/0
> ip address 1.1.234.4 255.255.255.0
> encapsulation frame-relay
> ip ospf priority 0
> frame-relay map ip 1.1.234.2 402
> no frame-relay inverse-arp
> end
>
> and
>
> rack1r2#sh ip ospf nei
>
> Neighbor ID Pri State Dead Time Address Interface
> 160.1.4.4 0 FULL/ - 00:00:39 1.1.234.4 Tunnel24
> 160.1.3.3 0 FULL/ - 00:00:36 1.1.234.3 Tunnel23
> 160.1.8.8 1 FULL/DR 00:00:39 1.1.22.2
> FastEthernet0/0
>
> rack1r2#sho ip route ospf | inc Tunnel
> O IA 1.1.13.0/24 [110/11113] via 1.1.234.3, 00:06:55, Tunnel23
> O IA 1.1.33.0/24 [110/11112] via 1.1.234.3, 00:06:55, Tunnel23
> O E2 188.18.18.0/24 [110/20] via 1.1.234.3, 00:06:55, Tunnel23
> O E2 188.18.19.0/24 [110/20] via 1.1.234.3, 00:06:55, Tunnel23
> O E2 188.18.16.0/24 [110/20] via 1.1.234.3, 00:06:55, Tunnel23
> O E2 188.18.17.0/24 [110/20] via 1.1.234.3, 00:06:55, Tunnel23
> O E2 160.1.9.9 [110/20] via 1.1.234.3, 00:06:55, Tunnel23
> O E2 160.1.3.3 [110/20] via 1.1.234.3, 00:06:55, Tunnel23
>
> -Joe
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Joseph Saad
> Sent: Sunday, October 07, 2007 11:29 PM
> To: Joseph Brunner
> Cc: Gregory Gombas; ccielab@groupstudy.com
> Subject: Re: OSPF over Frame-relay Task
>
> You'll need "ip ospf priority 0" under physical interfaces to render the
> NBMA network useless and really verify how your routes are learnt.
> This will effectively disable NBMA network and verify that your solution
> really "works".
>
> Joseph.
>
> On 10/8/07, Joseph Brunner <joe@affirmedsystems.com> wrote:
> >
> > A tunnel defaults to ospf network type POINT_TO_POINT; my answer is in the
> > config here for R2. Ignore other parts which don't matter... But you see
> > where I'm going with this... Multicast & Ipv6 comes later...
> >
> > My wording was very very similar to how this task would be worded in the
> > lab. You are forced to consider
> > -the default OSPF network type with physical (main) interface frame-relay
> > (non-broadcast)
> > -That this has a DR
> > -But you can't use a DR!
> > -Oh, sh*t I can't change the network type...
> >
> > If faced with a scenario you can't overcome you have to look forward fast
> > to
> > see how many more points you risk by not SOLVING BY ANY MEANS POSSIBLE...
> > I.E there may be 3 QOS, 3 MULTICAST, and 3 BGP points at stake from this
> > OSPF configuration... So do you just do what you can (run neighbor
> > commands
> > with non_broadcast, and have a DR, but don't break the FRAME-RELAY task
> > requirements...) and make the 9 easy points later? Maybe come back to this
> > after lunch? Strategy, strategy, strategy...
> >
> > Check it...
> >
> > rack1r2#sh run
> > Building configuration...
> >
> > Current configuration : 2003 bytes
> > !
> > version 12.3
> > service timestamps debug datetime msec
> > service timestamps log datetime msec
> > service password-encryption
> > !
> > hostname rack1r2
> > !
> > boot-start-marker
> > boot-end-marker
> > !
> > no logging console
> > enable secret 5 $1$vY/X$.P5pA3AI0m7dMS8DOSmnK1
> > !
> > memory-size iomem 30
> > aaa new-model
> > !
> > !
> > aaa authentication login default line none
> > aaa session-id common
> > ip subnet-zero
> > ip cef
> > !
> > !
> > !
> > no ip domain lookup
> > ip audit po max-events 100
> > !
> > !
> > !
> > key chain EIGRP
> > key 1
> > key-string 7 01302F377824
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > interface Loopback0
> > ip address 160.1.2.2 255.255.255.255
> > !
> > interface Tunnel23
> > ip unnumbered Serial0/0
> > tunnel source 1.1.234.2
> > tunnel destination 1.1.234.3
> > !
> > interface Tunnel24
> > ip unnumbered Serial0/0
> > tunnel source 1.1.234.2
> > tunnel destination 1.1.234.4
> > !
> > interface FastEthernet0/0
> > ip address 1.1.22.12 255.255.255.0
> > ip ospf mtu-ignore
> > duplex auto
> > speed auto
> > !
> > interface Serial0/0
> > ip address 1.1.234.2 255.255.255.0
> > encapsulation frame-relay
> > frame-relay map ip 1.1.234.3 203
> > frame-relay map ip 1.1.234.4 204
> > no frame-relay inverse-arp
> > !
> > interface FastEthernet0/1
> > no ip address
> > duplex auto
> > speed auto
> > !
> > interface FastEthernet0/1.23
> > encapsulation dot1Q 23 native
> > ip address 1.1.23.2 255.255.255.0
> > !
> > interface FastEthernet0/1.103
> > encapsulation dot1Q 103
> > ip address 150.1.3.2 255.255.255.0
> > ip authentication mode eigrp 100 md5
> > ip authentication key-chain eigrp 100 EIGRP
> > !
> > router eigrp 100
> > network 1.1.23.2 0.0.0.0
> > network 150.1.3.2 0.0.0.0
> > no auto-summary
> > !
> > router ospf 1
> > router-id 160.1.2.2
> > log-adjacency-changes
> > area 99 nssa no-summary
> > redistribute connected subnets route-map CONN->OSPF
> > redistribute eigrp 100 metric-type 1 subnets tag 2
> > network 1.1.22.12 0.0.0.0 area 99
> > network 1.1.234.2 0.0.0.0 area 0
> > !
> > ip classless
> > !
> > ip http server
> > no ip http secure-server
> > !
> > !
> > route-map CONN->OSPF permit 10
> > match interface Loopback0
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > !
> > line con 0
> > exec-timeout 0 0
> > password 7 13061E010803
> > line aux 0
> > line vty 0 4
> > password 7 030752180500
> > !
> > End
> >
> >
> > rack1r2# sh ip ospf int
> > Tunnel24 is up, line protocol is up
> > Internet Address 0.0.0.0/0, Area 0
> > Process ID 1, Router ID 160.1.2.2, Network Type POINT_TO_POINT, Cost:
> > 11111
> > Transmit Delay is 1 sec, State POINT_TO_POINT,
> > Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
> > oob-resync timeout 40
> > Hello due in 00:00:04
> > Index 3/3, flood queue length 0
> > Next 0x0(0)/0x0(0)
> > Last flood scan length is 1, maximum is 12
> > Last flood scan time is 0 msec, maximum is 4 msec
> > Neighbor Count is 1, Adjacent neighbor count is 1
> > Adjacent with neighbor 160.1.4.4
> > Suppress hello for 0 neighbor(s)
> > Tunnel23 is up, line protocol is up
> > Internet Address 0.0.0.0/0, Area 0
> > Process ID 1, Router ID 160.1.2.2, Network Type POINT_TO_POINT, Cost:
> > 11111
> > Transmit Delay is 1 sec, State POINT_TO_POINT,
> > Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
> > oob-resync timeout 40
> > Hello due in 00:00:04
> > Index 2/2, flood queue length 0
> > Next 0x0(0)/0x0(0)
> > Last flood scan length is 1, maximum is 12
> > Last flood scan time is 0 msec, maximum is 4 msec
> > Neighbor Count is 1, Adjacent neighbor count is 1
> > Adjacent with neighbor 160.1.3.3
> > Suppress hello for 0 neighbor(s)
> > Serial0/0 is up, line protocol is up
> > Internet Address 1.1.234.2/24, Area 0
> > Process ID 1, Router ID 160.1.2.2, Network Type NON_BROADCAST, Cost:
> > 1785
> > Transmit Delay is 1 sec, State DR, Priority 1
> > Designated Router (ID) 160.1.2.2, Interface address 1.1.234.2
> > No backup designated router on this network
> > Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
> > oob-resync timeout 120
> > Hello due in 00:00:23
> > Index 1/1, flood queue length 0
> > Next 0x0(0)/0x0(0)
> > Last flood scan length is 0, maximum is 0
> > Last flood scan time is 0 msec, maximum is 0 msec
> > Neighbor Count is 0, Adjacent neighbor count is 0
> > Suppress hello for 0 neighbor(s)
> > FastEthernet0/0 is up, line protocol is up
> > Internet Address 1.1.22.12/24, Area 99
> > Process ID 1, Router ID 160.1.2.2, Network Type BROADCAST, Cost: 1
> > Transmit Delay is 1 sec, State BDR, Priority 1
> > Designated Router (ID) 160.1.8.8, Interface address 1.1.22.2
> > Backup Designated router (ID) 160.1.2.2, Interface address 1.1.22.12
> > Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
> > oob-resync timeout 40
> > Hello due in 00:00:04
> > Index 1/4, flood queue length 0
> > Next 0x0(0)/0x0(0)
> > Last flood scan length is 2, maximum is 10
> > Last flood scan time is 0 msec, maximum is 4 msec
> > Neighbor Count is 1, Adjacent neighbor count is 1
> > Adjacent with neighbor 160.1.8.8 (Designated Router)
> > Suppress hello for 0 neighbor(s)
> > rack1r2#sh ip ospf nei
> >
> > Neighbor ID Pri State Dead Time Address
> > Interface
> > 160.1.4.4 0 FULL/ - 00:00:39 1.1.234.4 Tunnel24
> > 160.1.3.3 0 FULL/ - 00:00:38 1.1.234.3 Tunnel23
> > 160.1.8.8 1 FULL/DR 00:00:39 1.1.22.2
> > FastEthernet0/0
> >
> > -----Original Message-----
> > From: Gregory Gombas [mailto:ggombas@gmail.com]
> > Sent: Sunday, October 07, 2007 8:52 PM
> > To: Joseph Brunner
> > Cc: ccielab@groupstudy.com
> > Subject: Re: OSPF over Frame-relay Task
> >
> > Hmmm
> >
> > No DR means you can't use network types NBMA or Broadcast.
> > Can't use opsf network command means you can't change the network type
> > to multipoint which would have been my choice.
> >
> > Looks like PPP over Frame Relay is the only choice here.
> >
> > What other way is there?
> >
> >
> > On 10/7/07, Joseph Brunner <joe@affirmedsystems.com> wrote:
> > > Can anyone add something to this task (I made it up). (Slevin I made
> > this
> > > for you, so you won't have to ask us later ;)
> > >
> > >
> > >
> > > 2.1 Frame-relay Configuration
> > >
> > > - Configure frame-relay between R2, R3 and R4 per the diagram
> > >
> > > - Configure frame-relay using only these device's physical
> > interfaces.
> > >
> > > - Disable the use of inverse arp on these interfaces.
> > >
> > > - R3 & R4 will each only have 1 "frame-relay map" command
> > >
> > > - Do not use the "broadcast" keyword on any interface
> > >
> > > .
> > >
> > >
> > >
> > >
> > >
> > > 3.2 OSPF Configuration over Frame-relay
> > >
> > > - Configure OSPF area 0 between R2, R3 and R4
> > >
> > > - You are not allowed to use the command "ip ospf network" on any of
> > > these routers
> > >
> > > - You are not allowed to create any additional addressing for this
> > task
> > >
> > > - There will not be a DR in this area.
> > >
> > >
> > >
> > >
> > >
> > > There are several ways to solve this task; I think it's a pretty good
> > judge
> > > of whether or not you're ready for the CREATIVITY required to pass the
> > lab.
> > >
> > >
> > >
> > > -Joe
> > >
> > > _______________________________________________________________________
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Fri Nov 16 2007 - 13:11:12 ART