From: Ben (bmunyao@gmail.com)
Date: Fri Sep 28 2007 - 08:48:41 ART
Alex,
Here is what I did.
IPv6
IPv4
R1(s1/0.1)------------------------------(s1/0.1)R3(e0/1)-----------------------(e0/1)R4
2001:192:168:1::/64
192.168.2.0/24
interface Serial1/0.1 point-to-point
ipv6 address 2001:192:168:1::1/64
frame-relay interface-dlci 103
end
Rack1R1#sh run | i ipv6 route
ipv6 route 2001:192:168:2::/64 2001:192:168:1::3
Rack1R1#
Rack1R3(config)#do sh run int s1/0.1
Building configuration...
Current configuration : 124 bytes
!
interface Serial1/0.1 point-to-point
ipv6 address 2001:192:168:1::3/64
ipv6 nat
frame-relay interface-dlci 301
end
Rack1R3(config)#
Rack1R3(config)#do sh run int e0/1
Building configuration...
Current configuration : 90 bytes
!
interface Ethernet0/1
ip address 192.168.2.3 255.255.255.0
full-duplex
ipv6 nat
end
Rack1R3(config)#
Rack1R3(config)#do sh run | i nat
ipv6 nat
ipv6 nat
ipv6 nat v4v6 source 192.168.2.4 2001:192:168:2::4
ipv6 nat v6v4 source 2001:192:168:1::1 192.168.1.1
ipv6 nat prefix 2001:192:168:2::/96
Rack1R3(config)#
Rack1R4#sh run int e0/1
Building configuration...
Current configuration : 80 bytes
!
interface Ethernet0/1
ip address 192.168.2.4 255.255.255.0
full-duplex
end
Rack1R4#
Rack1R4#sh run | i ip route
ip route 192.168.1.0 255.255.255.0 192.168.2.3
Rack1R4#
Note that I had to configure static routes on R1 and R4 for the translated
addresses.Here is the verification.
Rack1R1#ping ipv 2001:192:168:2::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:192:168:2::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/224/464 ms
Rack1R1#
Rack1R4#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/134/208 ms
Rack1R4#
Here is nat debug on NAT-PT router
Rack1R3(config)#do sh deb
Generic IPv6:
IPv6 NAT-PT detailed debugging is on
Rack1R3(config)#
Rack1R3(config)#
*Mar 1 02:24:09.947: IPv6 NAT: icmp src (2001:192:168:1::1) -> (192.168.1.1),
dst (2001:192:168:2::4) -> (192.168.2.4)
*Mar 1 02:24:10.187: IPv6 NAT: icmp src (2001:192:168:1::1) -> (192.168.1.1),
dst (2001:192:168:2::4) -> (192.168.2.4)
*Mar 1 02:24:10.391: IPv6 NAT: icmp src (2001:192:168:1::1) -> (192.168.1.1),
dst (2001:192:168:2::4) -> (192.168.2.4)
*Mar 1 02:24:10.539: IPv6 NAT: icmp src (2001:192:168:1::1) -> (192.168.1.1),
dst (2001:192:168:2::4) -> (192.168.2.4)
*Mar 1 02:24:10.763: IPv6 NAT: icmp src (2001:192:168:1::1) -> (192.168.1.1),
dst (2001:192:168:2::4) -> (192.168.2.4)
Rack1R3(config)#
I also tried dynamic NAT-PT but could only get it to work in one direction,
i.e. dynamic for IPv6 -> IPv4, or dynamic for IPv4 -> IPv6. When I
tried to have dynamic in both directions, it did not work??? Not sure
whether that is supported.
HTH
Ben
On 9/28/07, Alex Steer <alex.steer@eison.co.uk> wrote:
>
> Because you haven't configured most of it.
> Check below:-
>
> 1. Firstly. As with any nat you need to enable it on the outside
> and inside interface(s) with the "ipv6 nat" command
>
> 2. Next you need a prefix that can be used by v4 hosts for
> reachablity (config)#ipv6 nat prefix X::X:X/96 (this can also be
> configured on a per interface basis)
>
> 3. You need a translation in each direction (remember the command
> here is SOURCE so it isn't the same command flipped on its head)
>
> Ipv6 nat v6v4 source ipv6hostsource ipv4somethingmadeup
> Ipv6 nat v4v6 source ipv4hostsource somethingintheprefixrange
>
> Don't forget the v6 host needs a route to the prefix range and the v4
> host needs a route to the ipv4somethingmadeup range
>
> Check to see if this works below:-
>
> R6
> Int lo1
> Ipv6 nat
> Int fastconnection r/9
> Ipv6 nat
>
> Ipv6 nat prefix 2001:6::/96
> ipv6 nat source v6v4 source 3333:6:6:6::6 104.69.69.16
> ipv6 nat source v4v6 104.69.69.16 2001:6::104:69:69:16
> ipv6 route 2001:9::/96 next-ipv6-hop-address
>
> -------------------------------------------------------
>
> R9
> Int lo1
> Ipv6 nat
> Int gigaconnection r/6
> Ipv6 nat
>
> Ipv6 nat prefix 2001:9::/96
> ipv6 nat v6v4 source 3333:9:9:9::9 104.69.69.19
> ipv6 nat v4v6 source 104.69.69.19 2001:9::104:69:69:16
> ipv6 route 2001:6::/96 next-ipv6-hop-address
>
>
>
> let me know how you get on (forgive if my syntax is wrong). Debug ipv6
> nat and debug ipv6 packet will show you if you have the correct routing
> and nat statements in both directions.
>
> Alex
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> ISolveSystems
> Sent: 28 September 2007 03:05
> To: groupstudy
> Subject: Simple IPv6 NAT config
>
> R6 connects to R9 via Serial using IPv4 address. R6(104.69.69.6); R9(
> 104.69.69.9)
>
> R6 Lo1 - 3333:6:6:6::6
>
> R9 Lo1 - 3333:9:9:9::9
>
> Task asks to configure IPv6 NAT over the serial link. Lo1 int should be
> able to ping each other using IPv4 address from the shared subnet. Do
> not
> use Overload.
>
> Below is the config. Any idea why it doesn't work?
>
> R6
> ipv6 nat v6v4 source 3333:6:6:6::6 104.69.69.16
>
> R9
> ipv6 nat v6v4 source 3333:9:9:9::9 104.69.69.19
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> ______________________________________________________________________
> This email has been scanned by the MessageLabs Email Security System.
> For more information please visit http://www.messagelabs.com/email
> ______________________________________________________________________
>
> ______________________________________________________________________
> This email has been scanned by the MessageLabs Email Security System.
> For more information please visit http://www.messagelabs.com/email
> ______________________________________________________________________
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sat Oct 06 2007 - 12:01:16 ART