RE: is IGP tag transitive

From: Bit Gossip (bit.gossip@chello.nl)
Date: Sun Sep 09 2007 - 04:41:23 ART


Now maybe I understand why certain redistribution I have done using tag
and filter were going belly up :-)

Anyway I think there is a workaround

router rip
redistribute ospf 1 route-map WORKAROUND

route-map WORKAROUND
match tag 1
set tag 1

Funny enough but this way the tag is carried over to RIP

Bit.

On Fri, 2007-09-07 at 22:59 +0100, Antonio Soares wrote:
> Got the same behaviour:
>
> ++++++++++++++++++++++
> R2#sh ip route 1.1.1.1
> Routing entry for 1.1.1.0/24
> Known via "ospf 1", distance 110, metric 20
> Tag 1, type extern 2, forward metric 10
> Redistributing via rip
> Advertised by rip metric 2
> Last update from 12.12.12.1 on Ethernet1/0, 00:02:04 ago
> Routing Descriptor Blocks:
> * 12.12.12.1, from 1.1.1.1, 00:02:04 ago, via Ethernet1/0
> Route metric is 20, traffic share count is 1
>
> R2#
> ++++++++++++++++++++++
> R2#
> *Mar 4 21:47:59.818: RIP: sending v2 update to 224.0.0.9 via Ethernet1/1
> (23.23.23.2)
> *Mar 4 21:47:59.818: RIP: build update entries
> *Mar 4 21:47:59.818: 1.1.1.0/24 via 0.0.0.0, metric 2, tag 0
> *Mar 4 21:47:59.818: 2.2.2.0/24 via 0.0.0.0, metric 2, tag 0
> *Mar 4 21:47:59.818: 12.12.12.0/24 via 0.0.0.0, metric 2, tag 0
> R2#
> ++++++++++++++++++++++
> R3#sh ip route 1.1.1.1
> Routing entry for 1.1.1.0/24
> Known via "rip", distance 120, metric 2
> Redistributing via rip
> Last update from 23.23.23.2 on Ethernet0/1, 00:00:18 ago
> Routing Descriptor Blocks:
> * 23.23.23.2, from 23.23.23.2, 00:00:18 ago, via Ethernet0/1
> Route metric is 2, traffic share count is 1
>
> R3#
> ++++++++++++++++++++++
>
> And as you saw, eigrp maintains the tag:
>
> ++++++++++++++++++++++
> R3#sh ip route 1.1.1.1
> Routing entry for 1.1.1.0/24
> Known via "eigrp 23", distance 170, metric 2560025856
> Tag 1, type external
> Redistributing via eigrp 23
> Last update from 23.23.23.2 on Ethernet0/1, 00:00:03 ago
> Routing Descriptor Blocks:
> * 23.23.23.2, from 23.23.23.2, 00:00:03 ago, via Ethernet0/1
> Route metric is 2560025856, traffic share count is 1
> Total delay is 1010 microseconds, minimum bandwidth is 1 Kbit
> Reliability 1/255, minimum MTU 1 bytes
> Loading 1/255, Hops 1
>
> R3#
> ++++++++++++++++++++++
>
>
> Regards,
>
> Antonio Soares
> CCIE #18473, CCNP, CCIP
>
> -----Original Message-----
> From: Bit Gossip [mailto:bit.gossip@chello.nl]
> Sent: sexta-feira, 7 de Setembro de 2007 21:52
> To: Antonio Soares; ccielab@groupstudy.com
> Subject: Re: is IGP tag transitive
>
> I have done further more tests on
> C3750 Software (C3750-ADVIPSERVICESK9-M), Version 12.2(25)SEE
> and
> (C2600-JK9S-M), Version 12.3(21)
> and
> 7200 Software (C7200-ADVIPSERVICESK9-M), Version 12.4(15)T1
> and
> C2600 Software (C2600-ADVIPSERVICESK9-M), Version 12.4(12)
>
> When redistributing from OSPF into RIP the tag is lost and reset to 0 !!!
>
> The simple test:
>
> R2(config-router)#do show run | b router
> router eigrp 100
> redistribute ospf 1 metric 1 1 1 1 1
> network 2.2.2.2 0.0.0.0
> no auto-summary
> router ospf 1
> log-adjacency-changes
> network 1.1.1.2 0.0.0.0 area 0
> router rip
> version 2
> redistribute ospf 1 metric 1
> network 2.0.0.0
>
> R2(config-router)#do show ip route 9.9.9.9
> Routing entry for 9.9.9.9/32
> Known via "ospf 1", distance 110, metric 20
> Tag 9, type extern 2, forward metric 64
> Redistributing via eigrp 100, rip
> Advertised by eigrp 100 metric 1 1 1 1 1
> rip metric 1
> Last update from 1.1.1.1 on Serial1/1, 00:03:57 ago
> Routing Descriptor Blocks:
> * 1.1.1.1, from 9.9.9.9, 00:03:57 ago, via Serial1/1
> Route metric is 20, traffic share count is 1
> Route tag 9
>
> R2(config-router)#
> *Sep 7 22:48:30.963: RIP: sending v2 update to 224.0.0.9 via Serial1/0
> (2.2.2.2)
> *Sep 7 22:48:30.963: RIP: build update entries
> *Sep 7 22:48:30.963: 1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Sep 7 22:48:30.963: 9.0.0.0/8 via 0.0.0.0, metric 1, tag 0
>
>
> Instead the same redistribution OSPF->EIGRP no problem.
> This can have quite an impact when relying on tagging in mutual
> redistribution scenarios
>
> Please confirm, or better tell me that I am wrong !!!
>
> Thanks,
> bit.
>
>
> ----- Original Message -----
> From: "Bit Gossip" <bit.gossip@chello.nl>
> To: "Antonio Soares" <amsoares@netcabo.pt>; <ccielab@groupstudy.com>
> Sent: Friday, September 07, 2007 9:50 PM
> Subject: Re: is IGP tag transitive
>
>
> >I am afraid there is a major problem with tag here:
> >
> >
> > interface Loopback1
> > ip address 9.9.9.9 255.255.255.255
> > !
> > interface Serial1/0
> > ip address 1.1.1.1 255.0.0.0
> > serial restart-delay 0
> > !
> > router rip
> > version 2
> > redistribute connected route-map R
> > network 1.0.0.0
> > !
> > route-map R permit 10
> > set tag 9
> > !
> > R1(config-router)#
> > *Sep 7 21:48:42.227: RIP: sending v2 update to 224.0.0.9 via Serial1/0
> > (1.1.1.1)
> > *Sep 7 21:48:42.227: RIP: build update entries
> > *Sep 7 21:48:42.227: 9.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> >
> >
> >
> >
> >
> >
> > ----- Original Message -----
> > From: "Antonio Soares" <amsoares@netcabo.pt>
> > To: "'Julio Carrasco'" <julio.carrasco@ya.com>; "'Bit Gossip'"
> > <bit.gossip@chello.nl>; <ccielab@groupstudy.com>
> > Sent: Friday, September 07, 2007 7:57 PM
> > Subject: RE: is IGP tag transitive
> >
> >
> >> It does support. Maybe you are hitting an IOS issue. Here my routers are
> >> running 12.3.20:
> >>
> >> +++++++++++++++++++++++++++++++++
> >> R2#sh ip route 1.1.1.1
> >> Routing entry for 1.1.1.1/32
> >> Known via "ospf 1", distance 110, metric 11, type intra area
> >> Redistributing via rip
> >> Advertised by rip metric 2 route-map ospf2rip
> >> Last update from 12.12.12.1 on Ethernet1/0, 00:01:56 ago
> >> Routing Descriptor Blocks:
> >> * 12.12.12.1, from 1.1.1.1, 00:01:56 ago, via Ethernet1/0
> >> Route metric is 11, traffic share count is 1
> >>
> >> R2#
> >> +++++++++++++++++++++++++++++++++
> >> R2#sh route-map
> >> route-map ospf2rip, permit, sequence 10
> >> Match clauses:
> >> Set clauses:
> >> tag 2
> >> Policy routing matches: 0 packets, 0 bytes
> >> R2#
> >> +++++++++++++++++++++++++++++++++
> >> R3#sh ip route 1.1.1.1
> >> Routing entry for 1.1.1.1/32
> >> Known via "rip", distance 120, metric 2
> >> Tag 2
> >> Redistributing via rip
> >> Last update from 23.23.23.2 on Ethernet0/1, 00:00:06 ago
> >> Routing Descriptor Blocks:
> >> * 23.23.23.2, from 23.23.23.2, 00:00:06 ago, via Ethernet0/1
> >> Route metric is 2, traffic share count is 1
> >>
> >> R3#
> >> +++++++++++++++++++++++++++++++++
> >>
> >>
> >> Regards,
> >>
> >> Antonio Soares
> >> CCIE #18473, CCNP, CCIP
> >>
> >> -----Original Message-----
> >> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> >> Julio Carrasco
> >> Sent: sexta-feira, 7 de Setembro de 2007 18:36
> >> To: Bit Gossip; ccielab@groupstudy.com
> >> Subject: Re: is IGP tag transitive
> >>
> >> Hi Bit,
> >>
> >> RIP do not support tags.
> >>
> >> ----- Original Message -----
> >> From: "Bit Gossip" <bit.gossip@chello.nl>
> >> To: <ccielab@groupstudy.com>
> >> Sent: Friday, September 07, 2007 6:39 PM
> >> Subject: is IGP tag transitive
> >>
> >>
> >>> Experts,
> >>> I was under the impression that if routing protocol A set a tag value on
>
> >>> a
> >>> certain prefix, when this prefix is redistributed into protocol B the
> >>> tag
> >>> value is preserved.
> >>> My lab is showing instead that this is not true at least from OSPF to
> >>> RIP.
> >>> What is the real truth here?
> >>> Thanks,
> >>> bit.
> >>>
> >>> Routing entry for 204.12.3.0/24
> >>> Known via "ospf 1", distance 110, metric 20
> >>> Tag 125, type extern 2, forward metric 128
> >>> Redistributing via rip
> >>> Advertised by rip metric 1 route-map OR
> >>> Last update from 145.3.23.2 on Serial4/0.23, 00:08:00 ago
> >>> Routing Descriptor Blocks:
> >>> * 145.3.23.2, from 150.3.5.5, 00:08:00 ago, via Serial4/0.23
> >>> Route metric is 20, traffic share count is 1
> >>> Route tag 125 <<<<<<<<<<<<<<<<<<
> >>>
> >>>
> >>> *Sep 7 16:44:46.833: RIP: sending v2 update to 224.0.0.9 via
> >>> FastEthernet1/0
> >>> (145.3.36.3)
> >>> *Sep 7 16:44:46.833: RIP: build update entries
> >>> <....>
> >>>
> >>> *Sep 7 16:44:46.837: 204.12.3.0/24 via 0.0.0.0, metric 1, tag 0
> >>> <<<<<<<<<
> >>>
> >>> Rack3R3#
> >>>
> >>> _______________________________________________________________________
> >>> Subscription information may be found at:
> >>> http://www.groupstudy.com/list/CCIELab.html
> >>
> >> _______________________________________________________________________
> >> Subscription information may be found at:
> >> http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sat Oct 06 2007 - 12:01:10 ART