RE: RIP Conditional advertisiment

From: Shine Joseph (shinepjoseph@iprimus.com.au)
Date: Thu Sep 06 2007 - 18:01:25 ART


Bit,

Your solution of applying the backup interface on the Ethernet interface
will not work.

If you need to apply the backup interface on a multipoint interface, you
must create a tunnel. So, in order to get your solution work, create a
tunnel between the Ethernet interfaces. Do not forget to add the keepalive
in the tunnel and apply the backup interface command to the tunnel.

interface Tunnel0
 backup interface Loopback1
 ip unnumbered Ethernet0/0
 keepalive 1 3
 tunnel source Ethernet0/0
 tunnel destination 190.1.17.7

interface Loopback1
 ip address 10.10.10.1 255.255.255.0

interface Ethernet0/0
 ip address 190.1.17.1 255.255.255.0
 shutdown
 half-duplex

router rip
 version 2
 network 190.1.0.0
 default-information originate route-map DEFAULT_CONDITION
 no auto-summary

Now, when the Ethernet interface goes down, the loopback interface gets
active and installs in the routing table and then rip creates the default
route.

My 2c

Shine

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of Bit
Gossip
Sent: Friday, 7 September 2007 5:36 AM
To: Cisco certification
Subject: Re: RIP Conditional advertisiment

Yemi,
I tested your proposal but I am not able to get it to work: in general it
doesn't seem to like a negative condition in the route-map.
I have the following proposal that seems to work instead: create a loopback
interface as a back-up interface of e0/0. The condition of the default is on

this new loopback so that when e0/0 goes down -> lo0 goes up and the default

is announced.

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 backup interface Loopback0
 ip address 157.1.36.3 255.255.255.0
 duplex full
!
router rip
 version 2
 network 12.0.0.0
 network 23.0.0.0
 default-information originate route-map CONDITION
!
access-list 1 permit 2.2.2.2
!
route-map CONDITION permit 10
 match ip address 1
!

----- Original Message -----
From: "Salau, Yemi" <yemi.salau@siemens.com>
To: "Sergey" <public@svlp.net>; "Cisco certification"
<ccielab@groupstudy.com>
Sent: Tuesday, September 04, 2007 11:09 AM
Subject: RE: RIP Conditional advertisiment

> To be honest, if there is any other thing in the RIB table, then your
> first option should work.
>
> I believe when you do route-map with default-information originate with
> RIP, you're actually looking for something in the RIB, init?
>
> So If I do
> route-map RG deny 5
> match ip address prefix-list E00
>
> That will not return any variable to the defualt-information originate
> line, but when you add:
> !
> route-map RG permit 10
>
> That should return all other routes in your RIB to your
> default-information originate line, hence RIP should then advertise the
> default-route.
>
> For the second Option:-
>
> route-map RG permit 10
> match ip address prefix-list E00
> !
> This line return a variable to the default-information originate line,
> and remember there is always implicit deny entry within route-maps, just
> like access-lists.
>
> So, the "invicible" deny entry wouldn't return any variable to the
> default-information line, as long as a variable gets returned to the
> default-information originate line, then RIP should advertise the
> default route.
>
> Many Thanks
>
> Yemi Salau
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Sergey
> Sent: Tuesday, September 04, 2007 9:12 AM
> To: 'Cisco certification'
> Subject: RIP Conditional advertisiment
>
> I want that router advertise default gateway via RIP only if interface
> E0/0 is down.
> my configuration is
>
>
> interface Ethernet0/0
> ip address 157.1.36.3 255.255.255.0
> shutdown
> half-duplex
>
> router rip
> default-information originate route-map RG
>
> ip prefix-list E00 seq 5 permit 157.1.36.0/24
>
> route-map RG deny 5
> match ip address prefix-list E00
> !
> route-map RG permit 10
>
> In my logic, if E0/0 is up than route 157.1.36.0/24 present in routing
> table, and default gateway advertising is suppressed by "route-map RG
> deny 5" but it seems "route-map RG deny
> 5" suppress route in spite of status of E0/0, with my config router
> never advertise default.
>
>
> but if i want opposite task (advertise default only if E0/0 is up) than
> conditional advertising works fine
>
> router rip
> default-information originate route-map RG
>
> ip prefix-list E00 seq 5 permit 157.1.36.0/24
>
> route-map RG permit 10
> match ip address prefix-list E00
> !
>
> if E0/0 is up router advertise default, if it down router not advertise
> default.
>
> Why if I use deny statement in route-map, conditional advertising
> failed?
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sat Oct 06 2007 - 12:01:09 ART