From: Ben (bmunyao@gmail.com)
Date: Fri Jul 20 2007 - 01:46:26 ART
Brandon
Bridging configuration on R1 looks ok. Is your underlying L2 configuration
correct? R1 needs to be on a dot1q trunk port on the switch. R2 and R3 need
to be on access ports in appropriate VLANs.
Ben
On 7/20/07, Brandon Smithson <thesmithsons@verizon.net> wrote:
>
> I set this up, yet am not seeing anything on R1. I just see connectivity
> between R2 and R3.
>
> R1:
> bridge irb
> !
> interface FastEthernet1/0
> no ip address
> !
> interface FastEthernet1/0.20
> encapsulation dot1Q 20
> no ip redirects
> bridge-group 1
> !
> interface FastEthernet1/0.30
> encapsulation dot1Q 30
> no ip redirects
> bridge-group 1
> !
> interface BVI1
> ip address 172.17.60.1 255.255.255.0
> ip ospf network broadcast
> ip ospf priority 100
> !
> router ospf 1
> network 172.17.60.0 0.0.0.255 area 1
> !
> bridge 1 protocol ieee
> bridge 1 route ip
>
> R2:
> interface Loopback102
> ip address 172.17.102.1 255.255.255.0
> ip ospf network point-to-point
> !
> interface FastEthernet1/0
> ip address 172.17.60.2 255.255.255.0
> !
> router ospf 1
> network 172.17.60.0 0.0.0.255 area 1
> network 172.17.102.0 0.0.0.255 area 1
>
> R3:
> interface Loopback102
> ip address 172.17.103.1 255.255.255.0
> ip ospf network point-to-point
> !
> interface FastEthernet3/0
> ip address 172.17.60.3 255.255.255.0
> !
> router ospf 1
> network 172.17.60.0 0.0.0.255 area 1
> network 172.17.103.0 0.0.0.255 area 1
>
> r1#show ip ospf neighbor
>
> r1#
>
> r1#show ip ospf data
>
> OSPF Router with ID (172.17.60.1) (Process ID 1)
>
> Router Link States (Area 1)
>
> Link ID ADV Router Age Seq# Checksum Link count
> 172.17.60.1 172.17.60.1 1200 0x80000001 0x00E160 1
> r1#
>
> r2#
> r2#show ip ospf neighbor
>
> Neighbor ID Pri State Dead Time Address
> Interface
> 172.17.103.1 1 FULL/DR 00:00:35 172.17.60.3
> FastEthernet1/0
> r2#show ip ospf data
>
> OSPF Router with ID (172.17.102.1) (Process ID 1)
>
> Router Link States (Area 1)
>
> Link ID ADV Router Age Seq# Checksum Link count
> 172.17.102.1 172.17.102.1 1241 0x80000006 0x005B5A 2
> 172.17.103.1 172.17.103.1 1020 0x80000006 0x006C45 2
>
> Net Link States (Area 1)
>
> Link ID ADV Router Age Seq# Checksum
> 172.17.60.3 172.17.103.1 1020 0x80000003 0x004881
> r2#
> r3#show ip ospf neighbor
>
> Neighbor ID Pri State Dead Time Address
> Interface
> 172.17.102.1 1 FULL/BDR 00:00:35 172.17.60.2
> FastEthernet3/0
> r3#show ip ospf data
>
> OSPF Router with ID (172.17.103.1) (Process ID 1)
>
> Router Link States (Area 1)
>
> Link ID ADV Router Age Seq# Checksum Link count
> 172.17.102.1 172.17.102.1 1288 0x80000006 0x005B5A 2
> 172.17.103.1 172.17.103.1 1065 0x80000006 0x006C45 2
>
> Net Link States (Area 1)
>
> Link ID ADV Router Age Seq# Checksum
> 172.17.60.3 172.17.103.1 1065 0x80000003 0x004881
> r3#
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Ash
> Sent: Thursday, July 19, 2007 12:40 PM
> To: Tony Schaffran
> Cc: Max Braun; ccielab@groupstudy.com
> Subject: Re: problem with ospf
>
> to add to that, please also post the OSPF database output for router lsa
> from r1...
>
> On 7/18/07, Tony Schaffran <groupstudy@cconlinelabs.com> wrote:
> >
> > After a quick glance, I do not see a problem with the config you have
> > provided.
> >
> > I would question if the config you have provided matches the actual
> > running
> > config. I assume the provided config is not the running config because
> > you
> > have misspelled broadcast on your bvi interface and abbreviated some
> > commands.
> >
> > Could you please provide the actual running config to see if we can spot
> > the
> > problem?
> >
> >
> > Tony Schaffran
> > Network Analyst
> > CCIE #11071
> > CCNP, CCNA, CCDA,
> > NNCDS, NNCSS, CNE, MCSE
> >
> > www.cconlinelabs.com
> > Your #1 choice for online Cisco rack rentals.
> >
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> > Max
> > Braun
> > Sent: Wednesday, July 18, 2007 5:34 AM
> > To: ccielab@groupstudy.com
> > Subject: problem with ospf
> >
> > Hi, Group!
> >
> > I have a problem with ospf. I have a simple scheme:
> >
> > ------vlan 30-------r3-loopback 103
> > |
> > r1- |
> > |
> > ------vlan 20-------r2-loopback 102
> >
> > On r1 I have 2 fastethernet subinterfaces and bvi interface (must be the
> > same address on both vlans) and I have the ospf here. There is the
> > configuration:
> >
> > r1:
> >
> > interface bvi 1
> > ip add 172.17.60.1 255.255.255.0
> > ip ospf network broudcast
> > ip ospf priority 100
> >
> > int fa 0/0.20
> > enc dot1q 20
> > bridge-group 1
> > no ip redirect
> >
> > int fa 0/0.30
> > enc dot1q 30
> > bridge-group 1
> > no ip redirect
> >
> > router ospf 1
> > network 172.17.60.0 0.0.0.255 area 1
> >
> >
> >
> > r2:
> > int fa 0/0
> > ip add 172.17.60.2 255.255.255.0
> >
> > int loo 102
> > ip add 172.17.102.1 255.255.255.0
> > ip ospf network point-to-point
> >
> > router ospf 1
> > net 172.17.60.0 0.0.0.255 area 1
> > net 172.17.102.0 0.0.0.255 area 1
> >
> >
> >
> > r3:
> > int fa 0/0
> > ip add 172.17.60.3 255.255.255.0
> >
> > int loo 102
> > ip add 172.17.103.1 255.255.255.0
> > ip ospf network point-to-point
> >
> > router ospf 1
> > net 172.17.60.0 0.0.0.255 area 1
> > net 172.17.103.0 0.0.0.255 area 1
> >
> >
> > I have all routes on r1 exclude the 172.17.102.0. I see it in ospf
> > database but not in routing table. There is the output of show ip ospf
> > neighbors:
> >
> > r1(config-if)#do sh ip os ne
> >
> > Neighbor ID Pri State Dead Time Address
> > Interface
> > 172.17.102.1 1 FULL/DROTHER 00:00:38 172.17.60.2 BVI1
> > 172.17.103.1 1 FULL/BDR 00:00:39 172.17.60.3
> > BVI1
> >
> > Thank you all.
> >
> > Best regards,
> > Max Braun
> >
> > --
> > We've Got Your Name at http://www.mail.com!
> > Get a FREE E-mail Account Today - Choose From 100+ Domains
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sat Aug 18 2007 - 08:17:41 ART