RE: problem with ospf

From: subodh.rawat@wipro.com
Date: Mon Jul 23 2007 - 00:47:35 ART


Problem is with L2 configuration of Switch.

You need to make Port which is connected to R1 as trunk with Dot1Q
Encapsulation (which is default in any way).

Port on switch connected to R2 and R3 should be access port with VLAN
association of 20 and 30 respectively.

I have configured similar setup and found no problem.

I am pasting my configuration and output here.

R1:
bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 no ip redirects
 bridge-group 1
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 no ip redirects
 bridge-group 1
!
interface BVI1
 ip address 172.17.60.1 255.255.255.0
 ip ospf network broadcast
 ip ospf priority 100
!
router ospf 1
 log-adjacency-changes
 network 172.17.60.0 0.0.0.255 area 1
---------------------------------------
R2:
interface Loopback102
 ip address 172.17.102.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 172.17.60.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 172.17.60.0 0.0.0.255 area 1
 network 172.17.102.0 0.0.0.255 area 1
---------------------------------------
R3:
interface Loopback102
 ip address 172.17.103.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 172.17.60.3 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 172.17.60.0 0.0.0.255 area 1
 network 172.17.103.0 0.0.0.255 area 1
----------------------------------------
SW:
interface FastEthernet1/1
 switchport mode trunk
!
interface FastEthernet1/2
 switchport access vlan 20
!
interface FastEthernet1/3
 switchport access vlan 30
----------------------------------------
Output (R1):

r1# sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address
Interface
172.17.102.1 1 FULL/DROTHER 00:00:39 172.17.60.2 BVI1
172.17.103.1 1 FULL/BDR 00:00:38 172.17.60.3 BVI1

r1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.17.0.0/24 is subnetted, 3 subnets
C 172.17.60.0 is directly connected, BVI1
O 172.17.103.0 [110/2] via 172.17.60.3, 00:05:20, BVI1
O 172.17.102.0 [110/2] via 172.17.60.2, 00:05:20, BVI1
------------------------------------------------------------------------
------------
Output (R2):
r2# sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address
Interface
172.17.60.1 100 FULL/DR 00:00:30 172.17.60.1
FastEthernet0/
0
172.17.103.1 1 FULL/BDR 00:00:39 172.17.60.3
FastEthernet0/
0

r2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.17.0.0/24 is subnetted, 3 subnets
C 172.17.60.0 is directly connected, FastEthernet0/0
O 172.17.103.0 [110/2] via 172.17.60.3, 00:05:20, FastEthernet0/0
C 172.17.102.0 is directly connected, Loopback102
------------------------------------------------------------------------
------------
Output (R3):
r3#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address
Interface
172.17.60.1 100 FULL/DR 00:00:30 172.17.60.1
FastEthernet0/
0
172.17.102.1 1 FULL/DROTHER 00:00:31 172.17.60.2
FastEthernet0/
0
 
r3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.17.0.0/24 is subnetted, 3 subnets
C 172.17.60.0 is directly connected, FastEthernet0/0
C 172.17.103.0 is directly connected, Loopback102
O 172.17.102.0 [110/2] via 172.17.60.2, 00:05:28, FastEthernet0/0



This archive was generated by hypermail 2.1.4 : Sat Aug 18 2007 - 08:17:41 ART