From: M S (michaelgstout@hotmail.com)
Date: Thu Jul 12 2007 - 02:16:45 ART
Here is the topo I'm using
BB-routers
|
R6
as100
|
R3
as300
|
R2--FR--\/--FR--R4
as200 as400
R5
as500
Multi-Access
R2
interface Serial0/0/0
ip address 136.1.245.2 255.255.255.0
encapsulation frame-relay
R5
interface Serial0/0/0
ip address 136.1.245.5 255.255.255.0
encapsulation frame-relay
R4
interface Serial0/0/0
ip address 136.1.245.4 255.255.255.0
encapsulation frame-relay
Here is the BGP
R2
router bgp 200
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 136.1.23.3 remote-as 300
neighbor 136.1.245.5 remote-as 500
neighbor 136.1.245.5 description R5
no auto-summary
R5
router bgp 500
no synchronization
bgp router-id 5.5.5.5
bgp log-neighbor-changes
neighbor 136.1.245.2 remote-as 200
neighbor 136.1.245.4 remote-as 400
no auto-summary
R4
router bgp 400
no synchronization
bgp router-id 4.4.4.4
bgp log-neighbor-changes
neighbor 136.1.245.5 remote-as 500
no auto-summary
Here are the deafult tables
R2
Network Next Hop Metric LocPrf Weight Path
*> 28.119.16.0/24 136.1.23.3 0 300 100 54 i
*> 28.119.17.0/24 136.1.23.3 0 300 100 54 i
*> 54.1.3.0/24 136.1.23.3 0 300 100 i
*> 112.0.0.0 136.1.23.3 0 300 100 54
50 60 i
*> 113.0.0.0 136.1.23.3 0 300 100 54
50 60 i
*> 114.0.0.0 136.1.23.3 0 300 100 54 i
R5 NOTICE NEXT HOP
Network Next Hop Metric LocPrf Weight Path
*> 28.119.16.0/24 136.1.245.2 0 200 300 100
54 i
*> 28.119.17.0/24 136.1.245.2 0 200 300 100
54 i
*> 54.1.3.0/24 136.1.245.2 0 200 300 100
i
*> 112.0.0.0 136.1.245.2 0 200 300 100
54 50 60 i
*> 113.0.0.0 136.1.245.2 0 200 300 100
54 50 60 i
*> 114.0.0.0 136.1.245.2 0 200 300 100
54 i
R4 NOTICE NEXT HOP
Network Next Hop Metric LocPrf Weight Path
*> 28.119.16.0/24 136.1.245.2 0 500 200 300
100 54 i
*> 28.119.17.0/24 136.1.245.2 0 500 200 300
100 54 i
*> 54.1.3.0/24 136.1.245.2 0 500 200 300
100 i
*> 112.0.0.0 136.1.245.2 0 500 200 300
100 54 50 60 i
*> 113.0.0.0 136.1.245.2 0 500 200 300
100 54 50 60 i
*> 114.0.0.0 136.1.245.2 0 500 200 300
100 54 i
Next set next hop self on R5
R4#sho ip bgp | b Network
Network Next Hop Metric LocPrf Weight Path
*> 28.119.16.0/24 136.1.245.5 0 500 200 300
100 54 i
*> 28.119.17.0/24 136.1.245.5 0 500 200 300
100 54 i
*> 54.1.3.0/24 136.1.245.5 0 500 200 300
100 i
*> 112.0.0.0 136.1.245.5 0 500 200 300
100 54 50 60 i
*> 113.0.0.0 136.1.245.5 0 500 200 300
100 54 50 60 i
*> 114.0.0.0 136.1.245.5 0 500 200 300
100 54 i
Notice the next hop changed.
--------------------------------------------------------------------
From: "M S" <michaelgstout@hotmail.com>
Reply-To: "M S" <michaelgstout@hotmail.com>
To: narbikk@gmail.com, wan2bccie@gmail.com
CC: ccielab@groupstudy.com
Subject: Re: BGP Doubt
Date: Wed, 11 Jul 2007 20:51:02 -0700
I completely concur.
However, you may use another option.
Create an inbound or outbound route-map and assign the next hop with
the
route-map.
Please reference BGP Design and Implemenation
Page 18.
When a prefix is advertised via eBGP, the next hop is automatically
set
to teh IP address of the eBGP peer that is sending the prefix. If
three
or more peers are sharing the same multiaccess network, however, the
advertising speaker sets the origional speaker on the same segment as
the
next hop, rather than itself. This is called Third-Party next hop.
Mike
I can't lab this now, but this may be an exception to the next hop
self
functionallity.
--------------------------------------------------------------------
From: "Narbik Kocharians" <narbikk@gmail.com>
Reply-To: "Narbik Kocharians" <narbikk@gmail.com>
To: "CCIE W" <wan2bccie@gmail.com>
CC: "Cisco certification" <ccielab@groupstudy.com>
Subject: Re: BGP Doubt
Date: Wed, 11 Jul 2007 09:57:58 -0700
This is the normal behavior, especially when the three routers are in
the
same multi-access networks. EBGP speakers WILL NOT change the next
hop
attribute in these networks. Your solution (Next-hop-self on R2 for
the R3
neighbor) should have worked, and it does, but I think may be what
you
should do is to try the "clear ip bgp *" command and if that does not
work,
perform a Microsoft (Reload). But understand that you do not need to
do any
of these for the next-hop-self command and it should take effect
immediately.
One thing that I noticed in your frame-relay configuration (BY THE
WAY THAT
IS NOT THE PROBLEM HERE) is the following:
Looking at your configuration one thing that I keep seeing is the
"broadcast" keyword at end of the frame-relay map command, there is
no need
for that when configuring BGP.
On 7/11/07, CCIE W <wan2bccie@gmail.com> wrote:
>
> Hi Sadiq,
>
> I am using main interface on all routers with same ip subnet.but
not full
> mesh
>
> R1 ;-
>
> interface Loopback0
> ip address 100.1.1.1 255.255.255.0
> !
> interface Serial1/0
> ip address 10.1.1.1 255.255.255.0
> encapsulation frame-relay
> serial restart-delay 0
> no dce-terminal-timing-enable
> frame-relay map ip 10.1.1.2 102 broadcast
> no frame-relay inverse-arp
>
> router bgp 65101
> no synchronization
> bgp log-neighbor-changes
> network 100.1.1.0 mask 255.255.255.0
> neighbor 10.1.1.2 remote-as 65102
> no auto-summary
>
> SH IP BGP :-
>
> BGP table version is 9, local router ID is 10.1.1.1
> Status codes: s suppressed, d damped, h history, * valid, > best, i
-
> internal,
> r RIB-failure, S Stale
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *> 100.1.1.0/24 0.0.0.0 0 32768 i
> *> 200.1.1.0 10.1.1.2 0 0 65102
i
> R2 :-
>
> interface Loopback0
> ip address 200.1.1.1 255.255.255.0
> !
> interface Serial1/0
> ip address 10.1.1.2 255.255.255.0
> encapsulation frame-relay
> serial restart-delay 0
> no dce-terminal-timing-enable
> frame-relay map ip 10.1.1.1 201 broadcast
> frame-relay map ip 10.1.1.3 203 broadcast
> no frame-relay inverse-arp
> !
> router bgp 65102
> no synchronization
> bgp log-neighbor-changes
> network 200.1.1.0
> neighbor 10.1.1.1 remote-as 65101
> neighbor 10.1.1.3 remote-as 65103
> no auto-summary
> !
>
> SH IP BGP :-
>
> BGP table version is 11, local router ID is 10.1.1.2
> Status codes: s suppressed, d damped, h history, * valid, > best, i
-
> internal,
> r RIB-failure, S Stale
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *> 100.1.1.0/24 10.1.1.1 0 0 65101
i
> *> 200.1.1.0 0.0.0.0 0 32768 i
>
> R3:--
>
> interface Serial1/0
> ip address 10.1.1.3 255.255.255.0
> encapsulation frame-relay
> serial restart-delay 0
> no dce-terminal-timing-enable
> frame-relay map ip 10.1.1.2 302 broadcast
> no frame-relay inverse-arp
> !
> router bgp 65103
> no synchronization
> bgp log-neighbor-changes
> neighbor 10.1.1.2 remote-as 65102
> no auto-summary
>
> SH IP BGP
>
> BGP table version is 13, local router ID is 10.1.1.3
> Status codes: s suppressed, d damped, h history, * valid, > best, i
-
> internal,
> r RIB-failure, S Stale
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> **> 100.1.1.0/24 10.1.1.1 0 65102
65101
> i*
> *> 200.1.1.0 10.1.1.2 0 0 65102
i
>
> Problem is here bold and underline
>
> HTH
>
> Thanks Mark
> -----Original Message-----
>
> From: nobody@groupstudy.com
> [*mailto:nobody@groupstudy.com*<nobody@groupstudy.com>]
> On Behalf Of Sadiq Yakasai
>
> Sent: Wednesday, July 11, 2007 21:17
>
> To: CCIE W
>
> Cc: Cisco certification
>
> Subject: Re: BGP Doubt
>
> hey Mark,
>
> So are you doing a Hub and Spoke setup? If yes, are you using a
multipoint
> sub interface on the hub or point-to-point sub interfaces?
>
> Is possible, can u sketch something out? - Always helps ppl
understand the
> topology..
>
> On 7/11/07, CCIE W <wan2bccie@gmail.com> wrote:
>
> > Dear All,
>
> >
>
> >
>
> > Could someone please help me, in following issue,
>
> >
>
> > Scenario: I have configured 3 dynamips routers connected via FR
switch.
>
> > Inverse-ARP is disabled. 2 PVCs are configured Rtr A to Rtr B, &
Rtr B
>
> > to Rtr C All 3 routers are in different BGP AS & are ebgp peers.
>
> >
>
> > Problem : Routes advertised on Rtr B (by Rtr A) are advertised to
Rtr
>
> > C with next hop IP of Rtr A. (Normally due to EBGP relation, the
next
>
> > hop should have been Rtr B). I think this is happening due to
>
> > Multi-access environment, But when I try setting the
next-hop-self on
>
> > Rtr B for neighbor C, it gives following error
>
> >
>
> > %BGP: next-hop-self is implied for an eBGP peer, there is no need
to
>
> > configure it
>
> >
>
> >
>
> >
>
> > Thanks
>
> > Mark.
>
> >
>
> >
______________________________________________________________________
>
> > _ Subscription information may be found at:
>
> > *http://www.groupstudy.com/list/CCIELab.html*<
> http://www.groupstudy.com/list/CCIELab.html>
>
>
_______________________________________________________________________
>
> Subscription information may be found at:
>
> *http://www.groupstudy.com/list/CCIELab.html*<
> http://www.groupstudy.com/list/CCIELab.html>
>
>
_______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
--
Narbik Kocharians
CCIE# 12410 (R&S, SP, Security)
CCSI# 30832
_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html
------------------------------------------------------------------------
Missed the show? Watch videos of the Live Earth Concert on MSN.
_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html
------------------------------------------------------------------------
See what youre getting intobefore you go there
This archive was generated by hypermail 2.1.4 : Sat Aug 18 2007 - 08:17:40 ART