From: Mohmmad, Imran (Imran.Mohmmad@amd.com)
Date: Wed Jul 11 2007 - 17:41:07 ART
Hi Ben,
Default Candidates in EIGRP:-
default-information in <ACL>
----Erases the default candidate marker from all received routes not
matched by the IP access list <ACL>
default-information out <ACL>
----Erases the default candidate marker from all routes not matched by
<ACL> when they are advertised to EIGRP neighbors
no default-information in
----Does not accept any default candidate markers
no default-information out
----Does not mark any routes as default candidates in outgoing updates.
The router itself still uses the default candidate
markers on the routes in the EIGRP topology database to select its own
gateway of last resort.
we have two router R1------<s0/0>-------<s0/0>----R2 and R2 is having ip
default-network set 192.168.1.0
Example 1:-
R1#
interface Serial0/0
ip address 100.100.100.100 255.255.255.254
serial restart-delay 0
no dce-terminal-timing-enable
router eigrp 1
network 100.0.0.0
no auto-summary
Router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 100.100.100.101 to network 192.168.1.0
100.0.0.0/31 is subnetted, 1 subnets
C 100.100.100.100 is directly connected, Serial0/0
D*EX 192.168.1.0/24 [170/2195456] via 100.100.100.101, 00:00:53,
Serial0/0
R2#
interface Serial0/0
ip address 100.100.100.101 255.255.255.254
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Ethernet1/0
ip address 192.168.1.2 255.255.255.0
full-duplex
router eigrp 1
redistribute connected
network 100.0.0.0
no auto-summary
!
ip default-network 192.168.1.0
R2#sh ip r
*Mar 1 01:07:55.759: %SYS-5-CONFIG_I: Configured from console by
consoleoute
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
100.0.0.0/31 is subnetted, 1 subnets
C 100.100.100.100 is directly connected, Serial0/0
C* 192.168.1.0/24 is directly connected, Ethernet1/0
in this eg router R2 send the route 192.168.1.0 as the default-candidate
route and R1 set the same as the gateway
of last-resort
Example -2
R1#
interface Serial0/0
ip address 100.100.100.100 255.255.255.254
serial restart-delay 0
no dce-terminal-timing-enable
router eigrp 1
network 100.0.0.0
no auto-summary
Router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
100.0.0.0/31 is subnetted, 1 subnets
C 100.100.100.100 is directly connected, Serial0/0
D EX 192.168.1.0/24 [170/2195456] via 100.100.100.101, 00:00:08,
Serial0/0
R2#
interface Serial0/0
ip address 100.100.100.101 255.255.255.254
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Ethernet1/0
ip address 192.168.1.2 255.255.255.0
full-duplex
router eigrp 1
redistribute connected
network 100.0.0.0
no default-information out
no auto-summary
!
ip default-network 192.168.1.0
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
100.0.0.0/31 is subnetted, 1 subnets
C 100.100.100.100 is directly connected, Serial0/0
C* 192.168.1.0/24 is directly connected, Ethernet1/0
In this eg the router R2 is still having the route 192.168.1.0 as the
candidate-default route but due to the filter we have
configured in eigrp to strip all the default-candidate mark it is
advertisng this route without setting the default-candidate marker
Sometimes I have seen that when you change the Default-information in
out to strip the default-candidate marker, you have to
Reset the neighbourship manually to get the same into effect why I
simply dont know.
Regards,
Imran
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Ben
Sent: Wednesday, July 11, 2007 2:05 AM
To: Cisco certification
Subject: How is default-information command under router eigrp used?
Hi
I cann't seem to make sense of how to use the "default-information"
command
under EIGRP. Does anyone here have examples of its usage that might help
me
digest this command.
TIA
Ben
This archive was generated by hypermail 2.1.4 : Sat Aug 18 2007 - 08:17:40 ART