From: Vishal Patel (vpatel@accessproviders.com.au)
Date: Wed Apr 18 2007 - 23:46:23 ART
Hey guys ,
Iam using following config to prioritize voice over a single ATM PVC.
But when I do heavy data download the voice gets affected as well.
I wish to reserve some amount of bandwidth only for voice , don't know
what wrong Iam doing ?
class-map match-any gold
match ip dscp af31 af32 af33
match access-group 152
class-map match-any bronze
match ip dscp af11 af12 af13
match access-group 154
class-map match-any platinum
match ip dscp ef
match access-group 150
class-map match-any titanium
match ip dscp af41 af42 af43
match access-group 151
class-map match-any silver
match ip dscp af21 af22 af23
match access-group 153
class-map match-all voice-test
match ip precedence 5
class-map match-all voice-ef
match access-group 150
policy-map ACTIV-QOS-VOICE+VIDEO+DATA-RT
class platinum
priority percent 60
class titanium
bandwidth remaining percent 40
random-detect dscp-based
set dscp af41
class gold
bandwidth remaining percent 25
random-detect dscp-based
set dscp af31
class silver
bandwidth remaining percent 10
random-detect dscp-based
set dscp af21
class bronze
bandwidth remaining percent 5
random-detect dscp-based
set dscp af11
class class-default
fair-queue
random-detect dscp-based
set dscp default
policy-map voice-ef
class voice-ef
set dscp ef
policy-map voice-test-policy
class voice-test
bandwidth 1024
policy-map policy-voice-test
class class-default
shape average 2048000
service-policy voice-test-policy
interface ATM0/3/0.1 point-to-point
description *** PVC to Activ ***
bandwidth 2048
ip address 172.30.251.38 255.255.255.252
ip nat outside
pvc 0/33
vbr-nrt 2048 2048 1
oam-pvc manage
encapsulation aal5snap
service-policy output ACTIV-QOS-VOICE+VIDEO+DATA-RT
!
interface FastEthernet0/0.20
description ***Voice-VLAN***
encapsulation dot1Q 20
ip address 172.27.1.1 255.255.255.192
service-policy input voice-ef
!
This archive was generated by hypermail 2.1.4 : Tue May 01 2007 - 08:28:36 ART