RE: About RIP SUMMARY

From: Victor Cappuccio (victor@ccbootcamp.com)
Date: Sun Mar 11 2007 - 04:55:08 ART


Hi,

AFAIK, there are 3 ways to send a Summary Address from RIP

Say we have this basic RIP configuration

Sw2(config-router)#int lo 10
Sw2(config-if)#ip add 200.200.44.1 255.255.255.0
Sw2(config-if)#ip add 150.16.1.1 255.255.255.0 sec
Sw2(config-if)#ip add 1.1.25.1 255.255.255.0 sec
Sw2(config)#ip routing
Sw2(config)#router rip
Sw2(config-router)#version 2
Sw2(config-router)#passive-interface default
Sw2(config-router)#no passive-interface Vlan11
Sw2(config-router)#network 1.0.0.0
Sw2(config-router)#network 150.16.0.0
Sw2(config-router)#network 200.200.44.0
Sw2(config-router)#network 200.200.178.0
Sw2(config-router)#no auto-summary

By normal means Ver 2 will send this

1d04h: RIP: sending v2 flash update to 224.0.0.9 via Vlan11 (200.200.178.8)
1d04h: RIP: build flash update entries
1d04h: 1.1.25.0/24 via 0.0.0.0, metric 1, tag 0
1d04h: 150.16.1.0/24 via 0.0.0.0, metric 1, tag 0
1d04h: 200.200.44.0/24 via 0.0.0.0, metric 1, tag 0

1.- Send RIP Ver 1 Updates

interface Vlan11
 ip address 200.200.178.8 255.255.255.0
 ip rip send version 1

1d04h: RIP: sending v1 flash update to 255.255.255.255 via Vlan11
(200.200.178.8)

1d04h: RIP: build flash update entries
1d04h: network 1.0.0.0 metric 1
1d04h: network 150.16.0.0 metric 1
1d04h: network 200.200.44.0 metric 1

2.- Leave Auto-Summary Turn on

Sw2(config-if)#int vlan 11
Sw2(config-if)#no ip rip send ver 1
Sw2(config-if)#router rip
Sw2(config-router)#auto
Sw2(config-router)#do clear ip route *
Sw2(config-router)#

1d04h: RIP: sending request on Vlan11 to 224.0.0.9
1d04h: RIP: sending request on Vlan11 to 224.0.0.9
1d04h: RIP: sending request on Vlan11 to 224.0.0.9
1d04h: RIP: sending v2 flash update to 224.0.0.9 via Vlan11 (200.200.178.8)
1d04h: RIP: build flash update entries
1d04h: 1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
1d04h: 150.16.0.0/16 via 0.0.0.0, metric 1, tag 0
1d04h: 200.200.44.0/24 via 0.0.0.0, metric 1, tag 0

And 3 the one you know- Ip Summary under the interface

HTH

thanks,
Victor Cappuccio.-
Network Learning Inc - A Cisco Sponsored Organization (SO) YES! We take
Cisco Learning credits!
victor@ccbootcamp.com
http://www.ccbootcamp.com (Cisco Training and Rental Racks)
http://www.ccbootcamp.com/groupstudy.html (groupstudy member discounts!)
Voice: 702-968-5100
FAX: 702-446-8012

-----Original Message-----
From: nobody@groupstudy.com on behalf of huangyinxiao@gmail.com
Sent: Sun 3/11/2007 5:39
To: ccielab@groupstudy.com
Subject: About RIP SUMMARY

Hi everyone,

Without using command "ip summary-address rip x.x.x.x", how can I give a
summary address from one rip router to another rip router?

Laurence



This archive was generated by hypermail 2.1.4 : Sun Apr 01 2007 - 06:35:50 ART