circuit-groups

From: Uchil Perera (uchil.groupstudy@yahoo.com)
Date: Sun Feb 25 2007 - 14:21:34 ART


Hi GS,
   
  Can somebody explain how circuit-group load balancing work.
   
  I did the below config accourding to DOC CD, but in spanning tree it shows the second link (Serial 1) blocked. How does it load balance ?
   
  R1#sh run
Building configuration...
  Current configuration : 1028 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$0WsJ$97HhfhZfeg5x0uKOZBspU0
!
no aaa new-model
ip subnet-zero
!
frame-relay switching
!
bridge irb
!
!
interface Loopback0
 ip address 3.3.1.1 255.255.255.0
!
interface Ethernet0
 no ip address
 no keepalive
 bridge-group 1
!
interface Ethernet0.10
!
interface Serial0
 no ip address
 clock rate 2000000
 no fair-queue
 bridge-group 1
 bridge-group 1 circuit-group 1
!
interface Serial1
 no ip address
 clock rate 2000000
 bridge-group 1
 bridge-group 1 circuit-group 1
!
interface BVI1
 ip address 3.3.20.1 255.255.255.0
!
router ospf 1
 router-id 3.3.1.1
 log-adjacency-changes
 network 3.3.20.1 0.0.0.0 area 0
!
ip http server
ip classless
!
!
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
!
end
  
R2
  hostname R2
!
!
ip subnet-zero
!
!
bridge irb
!
!
hub ether 0 1
 link-test
 auto-polarity
!
hub ether 0 2
 link-test
 auto-polarity
!
hub ether 0 3
 link-test
 auto-polarity
!
hub ether 0 4
 link-test
 auto-polarity
!
hub ether 0 5
 link-test
 auto-polarity
!
hub ether 0 6
 link-test
 auto-polarity
!
hub ether 0 7
 link-test
 auto-polarity
!
hub ether 0 8
 link-test
 auto-polarity
!
hub ether 0 9
 link-test
 auto-polarity
!
hub ether 0 10
 link-test
 auto-polarity
!
hub ether 0 11
 link-test
 auto-polarity
!
hub ether 0 12
 link-test
 auto-polarity
!
hub ether 0 13
 link-test
 auto-polarity
!
hub ether 0 14
 link-test
 auto-polarity
!
hub ether 0 15
 link-test
 auto-polarity
!
hub ether 0 16
 link-test
 auto-polarity
!
interface Loopback0
 ip address 3.3.2.2 255.255.255.0
!
interface Ethernet0
 no ip address
 bridge-group 1
 !
interface Ethernet0.10
!
interface Serial0
 no ip address
 no fair-queue
 bridge-group 1
 bridge-group 1 circuit-group 1
!
interface Serial1
 no ip address
 bridge-group 1
 bridge-group 1 circuit-group 1
!
interface BVI1
 ip address 3.3.20.2 255.255.255.0
!
ip classless
ip http server
!
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 0
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
!
end
  R2#
   
  R1#sh span br
  Bridge group 1
  Spanning tree enabled protocol ieee
  Root ID Priority 0
             Address 0050.547f.d0e6
             Cost 647
             Port 3 (Serial0)
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Bridge ID Priority 32768
             Address 0000.0c3e.a523
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
             Aging Time 300
  Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
Ethernet0 128.2 128 100 FWD 647 32768 0000.0c3e.a523 128.2
Serial0 128.3 128 647 FWD 0 0 0050.547f.d0e6 128.3
Serial1 128.4 128 647 BLK 0 0 0050.547f.d0e6 128.4
   
  R2#sh span brief
  Bridge group 1
  Spanning tree enabled protocol ieee
  Root ID Priority 0
             Address 0050.547f.d0e6
             This bridge is the root
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Bridge ID Priority 0
             Address 0050.547f.d0e6
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
             Aging Time 300
  Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
Ethernet0 128.2 128 100 FWD 0 0 0050.547f.d0e6 128.2
Serial0 128.3 128 647 FWD 0 0 0050.547f.d0e6 128.3
Serial1 128.4 128 647 FWD 0 0 0050.547f.d0e6 128.4
  R2#
   
   

 
---------------------------------
Expecting? Get great news right away with email Auto-Check.
Try the Yahoo! Mail Beta.



This archive was generated by hypermail 2.1.4 : Thu Mar 01 2007 - 07:38:48 ART