Static routes with tracking

From: mathew Fer (mathew118@gmail.com)
Date: Fri Jan 19 2007 - 05:12:47 ART


Hi GS / Brians,

I have tested the below configuration successfully with IOS ver 12.4.
The default static route to null 0 is active when IP 1.1.1.1 is reachable
via BGP so that any routes that are not matched in BGP routes (specific
routes) are dropped with null 0, without sending the traffic to WAN.

When the WAN is down, 1.1.1.1 is not learned by BGP so the default route to
Null 0 is removed from the routing table & install the default to dialer 1
which kick in the ISDN dial out with Dialer configuration (with intresting
traffic defined in the configuration) to other end router.

My question is that what are other possible ways to do the same with an IOS
ver 12.1 which does not have the support of Enhanced Tracking.

One of the requirement here is to keep the dialer to use for testing (with a
ping to 192.168.1.1) under normal condition (WAN UP). This prevent us using
the command "backup interface dialer 1" in the configurations.

!
interface FastEthernet0/0
.
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 6.1.1.2 255.255.255.252
 no cdp enable
 frame-relay interface-dlci 100
!
interface BRI0/0
 .
 dialer pool-member 1
!
interface Dialer1
ip address 192.168.1.2 255.255.255.0
 dialer pool 1
 dialer string 4444
 dialer-group 1
  .
!
track 2 ip route 1.1.1.1 255.255.255.255 reachability
!
ip route 0.0.0.0 0.0.0.0 null 0 track 2
ip route 0.0.0.0 0.0.0.0 Dialer 1 220
!
ip route 192.168.1.1 255.255.255.255 Dialer 1 <---- Dial out for testing
!
router bgp 1
.
.
!
access-list 105 permit ip 10.2.1.0 0.0.0.255 any
access-list 105 permit ip any host 192.168.1.1
!
dialer-list 1 protocol ip list 105
!

Thank you for the reply.

mathew



This archive was generated by hypermail 2.1.4 : Thu Feb 08 2007 - 23:46:57 ART