RE: OSPF, iBGP with synchronization enabled and a

From: Bit Gossip (bit.gossip@chello.nl)
Date: Sun Jan 07 2007 - 09:28:16 ART


Group,
another possibility would be putting every spoke in its own OSPF area;
this way the hub will be the ABR which will rewrite every prefix with
its own router-id which then will match with the BGP router-id.
I have labbed it and seams to work (r1 hub, r2 and r3 spokes)
Thanks,
Luca

r1 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

interface Loopback0
 ip address 192.168.255.1 255.255.255.255
!
interface Serial4/0
 description ** frs s1/0 **
 no ip address
 encapsulation frame-relay
 load-interval 30
 serial restart-delay 0
!
interface Serial4/0.122 point-to-point
 ip address 192.168.100.1 255.255.255.252
 frame-relay interface-dlci 122
!
interface Serial4/0.123 point-to-point
 ip address 192.168.100.101 255.255.255.240
 frame-relay interface-dlci 123
!
router ospf 1
 router-id 192.168.255.1
 log-adjacency-changes
 network 192.168.100.1 0.0.0.0 area 2
 network 192.168.100.101 0.0.0.0 area 3
 network 192.168.255.1 0.0.0.0 area 0
!
router bgp 1
 synchronization
 bgp router-id 192.168.255.1
 bgp log-neighbor-changes
 neighbor 192.168.255.2 remote-as 1
 neighbor 192.168.255.2 update-source Loopback0
 neighbor 192.168.255.2 route-reflector-client
 neighbor 192.168.255.3 remote-as 1
 neighbor 192.168.255.3 update-source Loopback0
 neighbor 192.168.255.3 route-reflector-client
 no auto-summary

r2 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

interface Loopback0
 ip address 192.168.255.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 2.2.2.2 255.0.0.0
 load-interval 30
 duplex full
!
interface Serial4/0
 ip address 192.168.100.2 255.255.255.252
 encapsulation frame-relay
 ip ospf network point-to-point
 ip ospf priority 0
 load-interval 30
 serial restart-delay 0
!
!
router ospf 1
 router-id 192.168.255.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 2
 network 192.168.100.2 0.0.0.0 area 2
 network 192.168.255.2 0.0.0.0 area 2
!
router bgp 1
 synchronization
 bgp router-id 192.168.255.2
 bgp log-neighbor-changes
 network 2.0.0.0
 network 192.168.255.2 mask 255.255.255.255
 neighbor 192.168.255.1 remote-as 1
 no auto-summary
!
r3 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

interface Loopback0
 ip address 192.168.255.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 3.3.3.3 255.0.0.0
 load-interval 30
 speed 100
 full-duplex
!
interface Serial0/0
 description ** frs s1/2 **
 ip address 192.168.100.103 255.255.255.240
 encapsulation frame-relay
 ip ospf network point-to-point
 ip ospf priority 0
 load-interval 30
 clock rate 128000
 no fair-queue
!
router ospf 1
 router-id 192.168.255.3
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 3
 network 192.168.100.3 0.0.0.0 area 0
 network 192.168.100.103 0.0.0.0 area 3
 network 192.168.255.3 0.0.0.0 area 3
!
router bgp 1
 synchronization
 bgp router-id 192.168.255.3
 bgp log-neighbor-changes
 network 3.0.0.0
 network 192.168.255.3 mask 255.255.255.255
 neighbor 192.168.255.1 remote-as 1
 no auto-summary
!

r3#show ip route 2.0.0.0
Routing entry for 2.0.0.0/8
  Known via "ospf 1", distance 110, metric 846, type inter area
  Last update from 192.168.100.101 on Serial0/0, 00:17:41 ago
  Routing Descriptor Blocks:
  * 192.168.100.101, from 192.168.255.1, 00:17:41 ago, via Serial0/0
      Route metric is 846, traffic share count is 1

r3#show ip bgp 2.0.0.0
BGP routing table entry for 2.0.0.0/8, version 6
Paths: (1 available, best #1, table Default-IP-Routing-Table,
RIB-failure(17))
  Not advertised to any peer
  Local
    192.168.255.2 (metric 846) from 192.168.255.1 (192.168.255.1)
      Origin IGP, metric 0, localpref 100, valid, internal,
synchronized, best
      Originator: 192.168.255.2, Cluster list: 192.168.255.1

On Fri, 2007-01-05 at 17:36 -0500, Bob Sinclair wrote:
> Sarah,
>
> Here is an idea: how about running two ospf processes on the hub, one per
> spoke, then redistribute between them. Wouldn't the spokes then see
> matching ASBR/BGP rids?
>
> Bob Sinclair
> CCIE 10427 CCSI 30427
> www.netmasterclass.net
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Sarah Kent
> Sent: Friday, January 05, 2007 4:45 PM
> To: Daniel_Steyn@Dell.com; ccielab@groupstudy.com
> Subject: Re: OSPF, iBGP with synchronization enabled and a Route-Reflector
>
> Daniel,
>
> I do see a rib failure on the hub. The hub router, which is also the
> route-reflector, sees the prefix and can synchronize it, because it sees the
> same route-id from the spoke for both bgp and ospf. However, the
> route-reflector injects its route-id when it forwards the bgp prefix to the
> other spoke. The other spoke will not consider the prefix as synchronized,
> because it the route-ids don't match for ospf and bgp.
>
> Is there any way to
> manipulate bgp route-ids per interface or neighbor relationship?
>
> Thanks,
> Sarah
>
> ----- Original Message ----
> From: "Daniel_Steyn@Dell.com"
> <Daniel_Steyn@Dell.com>
> To: icmptype3@yahoo.com; ccielab@groupstudy.com
> Sent:
> Friday, January 5, 2007 4:34:57 PM
> Subject: RE: OSPF, iBGP with
> synchronization enabled and a Route-Reflector
>
> You should be able to configure
> everything and see the BGP routes given
> these requirements, however, you may
> experience a rib failure as the
> OSPF administrative distance is going to be
> lower than the iBGP admin
> distance - so you may not actually see the routes
> populate to the
> routing table.
>
> As always, I may be wrong - but that is just
> my initial guess.
>
>
> -----Original Message-----
> From: nobody@groupstudy.com
> [mailto:nobody@groupstudy.com] On Behalf Of
> Sarah Kent
> Sent: Friday, January
> 05, 2007 2:29 PM
> To: ccielab@groupstudy.com
> Subject: OSPF, iBGP with
> synchronization enabled and a Route-Reflector
>
> Hi GS,
>
> Is it possible to setup
> a network with the following requirements?
>
> 3
> routers in a hub and spoke
> topology.
> Routers are running OSPF, and are iBGP
> peers with synchronization
> enabled.
> The hub is a Route-Reflector.
> Prefixes are
> advertised from one spoke
> to the other.
> All prefixes should be synchronized.
> I know that this would work
> with confederations instead of
> route-reflectors.
> I haven't figured out a way
> to get the prefixes synchronized on the
> spokes using a route-reflector. Any
> ideas?
>
> Thanks,
>
> Sarah
> __________________________________________________
> Do
> You Yahoo!?
> Tired of
> spam? Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com __________________________________________________
> Do
> You Yahoo!?
> Tired of
> spam? Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
> __________________________________________________
> Do You Yahoo!?
> Tired of
> spam? Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Thu Feb 08 2007 - 23:46:55 ART