RE: Multilink PPP over FR

From: Schulz, Dave (DSchulz@dpsciences.com)
Date: Sat Nov 11 2006 - 02:42:56 ART


Nice detail, Brad. Thanks for sharing. Not sure why you have the "no arp frame-relay" command here. FYI....this command has no real function.

Dave Schulz,
Email: dschulz@dpsciences.com

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of Haas, Brad
Sent: Friday, November 10, 2006 12:17 PM
To: Marvin Greenlee; Kulcsar" "Andras" "Benjamin; Adhu Ajit; ccielab@groupstudy.com
Subject: RE: Multilink PPP over FR

Tried this MFR/PPP back to back and it works... debugs below.

!!!!!!!!!!!Begin R1!!!!!!!!!!!!
R1
interface Serial1/0
 no ip address
 encapsulation frame-relay MFR1
 serial restart-delay 0
 no arp frame-relay
!
interface Serial1/1
 no ip address
 encapsulation frame-relay MFR1
 serial restart-delay 0
 no arp frame-relay
!
interface MFR1
 no ip address
 no keepalive
 frame-relay map ip 10.10.10.2 201 broadcast
 frame-relay interface-dlci 201 ppp Virtual-Template1
 no frame-relay inverse-arp
!
interface Virtual-Template1
 ip address 10.10.10.1 255.255.255.252

!!!!!!!!!!!!Begin R2!!!!!!!!!!!!!!!!

R2
interface Serial1/0
 no ip address
 encapsulation frame-relay MFR1
 serial restart-delay 0
 no arp frame-relay
!
interface Serial1/1
 no ip address
 encapsulation frame-relay MFR1
 serial restart-delay 0
 no arp frame-relay
!
interface MFR1
 no ip address
 no keepalive
 frame-relay map ip 10.10.10.1 201 broadcast
 frame-relay interface-dlci 201 ppp Virtual-Template1
 no frame-relay inverse-arp
!
interface Virtual-Template1
 ip address 10.10.10.2 255.255.255.252

!!!!!!!!!!!!!!!!!!!!Debug Output!!!!!!!!!!!!!!!!!!!!!!!
R1#
R1#Show Debug
R1#R1#show deb
Generic IP:
  IP packet debugging is on
PPP:
  PPP packet display debugging is on
Frame Relay:
  Frame Relay packet debugging is on

*Nov 10 11:26:55.827: Vi1 PPP: I pkt type 0x0021, datagramsize 104 link[ip]
*Nov 10 11:26:55.831: IP: tableid=0, s=10.10.10.2 (Virtual-Access1), d=10.10.10.
1 (Virtual-Access1), routed via RIB
*Nov 10 11:26:55.835: IP: s=10.10.10.2 (Virtual-Access1), d=10.10.10.1 (Virtual-
Access1), len 100, rcvd 3
*Nov 10 11:26:55.839: IP: tableid=0, s=10.10.10.1 (local), d=10.10.10.2 (Virtual
-Access1), routed via FIB
*Nov 10 11:26:55.843: IP: s=10.10.10.1 (local), d=10.10.10.2 (Virtual-Access1),
len 100, sending
*Nov 10 11:26:55.843: Vi1 PPP: O pkt type 0x0021, datagramsize 102
*Nov 10 11:26:55.847: MFR1(o): dlci 201(0x3091), NLPID 0x3CF(IP), datagramsize 1
06
*Nov 10 11:26:55.947: Vi1 PPP: I pkt type 0x0021, datagramsize 104 link[ip]
*Nov 10 11:26:55.955: IP: tableid=0, s=10.10.10.2 (Virtual-Access1), d=10.10.10.
1 (Virtual-Access1), routed via RIB
*Nov 10 11:26:55.959: IP: s=10.10.10.2 (Virtual-Access1), d=10.10.10.1 (Virtual-
Access1), len 100, rcvd 3
*Nov 10 11:26:55.963: IP: tableid=0, s=10.10.10.1 (local), d=10.10.10.2 (Virtual
-Access1), routed via FIB
*Nov 10 11:26:55.963: IP: s=10.10.10.1 (local), d=10.10.10.2 (Virtual-Access1),
len 100, sending
*Nov 10 11:26:55.967: Vi1 PPP: O pkt type 0x0021, datagramsize 102
*Nov 10 11:26:55.971: MFR1(o): dlci 201(0x3091), NLPID 0x3CF(IP), datagramsize 1
06
*Nov 10 11:26:56.091: Vi1 PPP: I pkt type 0x0021, datagramsize 104 link[ip]
*Nov 10 11:26:56.095: IP: tableid=0, s=10.10.10.2 (Virtual-Access1), d=10.10.10.
1 (Virtual-Access1), routed via RIB
*Nov 10 11:26:56.099: IP: s=10.10.10.2 (Virtual-Access1), d=10.10.10.1 (Virtual-
Access1), len 100, rcvd 3
*Nov 10 11:26:56.103: IP: tableid=0, s=10.10.10.1 (local), d=10.10.10.2 (Virtual
-Access1), routed via FIB
*Nov 10 11:26:56.107: IP: s=10.10.10.1 (local), d=10.10.10.2 (Virtual-Access1),
len 100, sending
*Nov 10 11:26:56.107: Vi1 PPP: O pkt type 0x0021, datagramsize 102
*Nov 10 11:26:56.111: MFR1(o): dlci 201(0x3091), NLPID 0x3CF(IP), datagramsize 1
06
*Nov 10 11:26:56.187: Vi1 PPP: I pkt type 0x0021, datagramsize 104 link[ip]
*Nov 10 11:26:56.191: IP: tableid=0, s=10.10.10.2 (Virtual-Access1), d=10.10.10.
1 (Virtual-Access1), routed via RIB
*Nov 10 11:26:56.195: IP: s=10.10.10.2 (Virtual-Access1), d=10.10.10.1 (Virtual-
Access1), len 100, rcvd 3
*Nov 10 11:26:56.199: IP: tableid=0, s=10.10.10.1 (local), d=10.10.10.2 (Virtual
-Access1), routed via FIB
*Nov 10 11:26:56.203: IP: s=10.10.10.1 (local), d=10.10.10.2 (Virtual-Access1),
len 100, sending
*Nov 10 11:26:56.203: Vi1 PPP: O pkt type 0x0021, datagramsize 102
*Nov 10 11:26:56.207: MFR1(o): dlci 201(0x3091), NLPID 0x3CF(IP), datagramsize 1
06
*Nov 10 11:26:56.331: Vi1 PPP: I pkt type 0x0021, datagramsize 104 link[ip]
*Nov 10 11:26:56.335: IP: tableid=0, s=10.10.10.2 (Virtual-Access1), d=10.10.10.
1 (Virtual-Access1), routed via RIB
*Nov 10 11:26:56.339: IP: s=10.10.10.2 (Virtual-Access1), d=10.10.10.1 (Virtual-
Access1), len 100, rcvd 3
*Nov 10 11:26:56.343: IP: tableid=0, s=10.10.10.1 (local), d=10.10.10.2 (Virtual
-Access1), routed via FIB
*Nov 10 11:26:56.347: IP: s=10.10.10.1 (local), d=10.10.10.2 (Virtual-Access1),
len 100, sending
*Nov 10 11:26:56.351: Vi1 PPP: O pkt type 0x0021, datagramsize 102
*Nov 10 11:26:56.351: MFR1(o): dlci 201(0x3091), NLPID 0x3CF(IP), datagramsize 1
06
*Nov 10 11:26:59.727: Vi1 LCP: O ECHOREQ [Open] id 38 len 12 magic 0x0027404C
*Nov 10 11:26:59.731: MFR1(o): dlci 201(0x3091), NLPID 0x3CF(PPP), datagramsize
18
*Nov 10 11:26:59.787: Vi1 LCP-FS: I ECHOREP [Open] id 38 len 12 magic 0x0126547E
*Nov 10 11:26:59.787: Vi1 LCP-FS: Received id 38, sent id 38, line up
*Nov 10 11:26:59.791: Vi1 LCP-FS: I ECHOREQ [Open] id 38 len 12 magic 0x0126547E
*Nov 10 11:26:59.791: Vi1 LCP-FS: O ECHOREP [Open] id 38 len 12 magic 0x0027404C
*Nov 10 11:26:59.791: MFR1(o): dlci 201(0x3091), NLPID 0x3CF(PPP), datagramsize
18

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of Marvin Greenlee
Sent: Friday, November 10, 2006 10:42 AM
To: Kulcsar" "Andras" "Benjamin; Adhu Ajit; ccielab@groupstudy.com
Subject: RE: Multilink PPP over FR

Yep, misread and missed the PPP in the question.

--- Kulcsar Andras Benjamin
<Kulcsar.Andras@kfki-lnx.hu> wrote:

> I think your config is multilink frame-relay
> (FRF.16), not multilink PPP over FR.
> What about this:
>
> interface Multilink1
> ip address 174.1.23.2 255.255.255.0
> ppp multilink
> ppp multilink group 1
>
> interface Serial0/0
> no ip address
> encapsulation frame-relay
> !
> interface Serial0/0.203 point-to-point
> frame-relay interface-dlci 203 ppp
> Virtual-Template1
> !
> interface Serial0/0.213 point-to-point
> frame-relay interface-dlci 213 ppp
> Virtual-Template1
>
> interface Virtual-Template1
> no ip address
> ppp authentication chap
> ppp multilink
> ppp multilink group 1
>
> Regards,
> Andras
>
> -----Original Message-----
> From: nobody@groupstudy.com
> [mailto:nobody@groupstudy.com] On Behalf Of Marvin
> Greenlee
> Sent: Friday, November 10, 2006 3:39 PM
> To: Adhu Ajit; ccielab@groupstudy.com
> Subject: Re: Multilink PPP over FR
>
> Config is fairly straightforward.
>
> **********
> frame-relay switching
>
>
> interface MFR1
> no ip address
> frame-relay intf-type dce
> !
> interface MFR1.32 point-to-point
> ip address 150.50.69.1 255.255.255.252
> frame-relay interface-dlci 32
>
> interface Serial0/2/0
> no ip address
> encapsulation frame-relay MFR1
> clock rate 2000000
> !
> interface Serial0/2/1
> no ip address
> encapsulation frame-relay MFR1
> clock rate 2000000
>
> **********
>
> What specific questions do you have about the
> feature?
>
>
> Thanks,
> Marvin
>
> --- Adhu Ajit <adhu_ajit@yahoo.com> wrote:
>
> > Is this an item that one should consider covering
> for the lab exam ?
> >
> > The Cisco documentation on this is not very
> adequate; hence, not
> > able to get a grasp of this feature.
> >
> > Thanks.
> >
> >
> > ---------------------------------
> > Access over 1 million songs - Yahoo! Music
> Unlimited.
> >
> >
>



This archive was generated by hypermail 2.1.4 : Fri Dec 01 2006 - 08:05:46 ART