Re: Q. ip multicast helper: Mcast -> Broadcast -> Mcast

From: sabrina pittarel (sabri_esame@yahoo.com)
Date: Thu Sep 21 2006 - 00:23:49 ART


Hi Russell,
 thanks for the reply...
Could you really get it working with the helper-map on the egress interface on the last hop router?
 I believe Cisco Documentation is not accurate in that. In a Brodcast->Multicast->Broadcast "regular" senario, the mroute helper address should be configured on the *ingress* interface of both the first and the last hop router.
 
 Also, note that the first hop router (that in the example shown by the documentation is the router performing the Broadcast to multicast conversion) has PIM enabled on the interface receiving the broadcast traffic.
  interface ethernet 0
 
    ip directed-broadcast
 
    ip multicast helper-map broadcast 224.5.5.5 120
 
    ip pim dense-mode
 
   
Sabrina
 
 
 
 
----- Original Message ----
From: Russell Kelly (rukelly) <rukelly@cisco.com>
To: sabrina pittarel <sabri_esame@yahoo.com>; shha <shha77@gmail.com>
Cc: ccielab@groupstudy.com
Sent: Wednesday, September 20, 2006 1:33:16 AM
Subject: RE: Q. ip multicast helper: Mcast -> Broadcast -> Mcast

Normally this command is used the other way around :-) i.e. to forward
broadcasts across a MC network. This enables you to set the helper-map
on the first and last hop R3 int 1 and R2 int 4 (not int 3). Have you
tried setting the helper-map on R2 interface 4 only, as I think you will
need pim enabled on r2 int 3 if you have the helper-map on there. As
for directed broadcast - I think this is needed on outbound router
interfaces only - but the univercd eg has it on both....

Try this to see if it works (I tried testing from a router interface
with IP 129.1.17.1) - then you won't need pim enabled on R2 int 3 (I
tried it and it sort of worked - but ran outta time to test) I think
you may need the Ip broadcast-address command on R3 int 1

R3 interface 1:
-----------------

ip forward-protocol udp 31337

interface Serial1/2
ip address 129.1.13.3 255.255.255.0
ip pim dense-mode
ip multicast helper-map 225.25.25.25 192.10.1.255 100
encapsulation ppp

access-list 100 permit udp 129.1.17.0 0.0.0.255 host 225.25.25.25 eq
31337

R3 interface 2:
-----------------

interface Serial1/3
ip address 129.1.23.3 255.255.255.0
ip directed-broadcast
encapsulation ppp

R2 interface 3:
-----------------

ip forward-protocol udp 31337

interface Serial1/1
ip address 129.1.23.2 255.255.255.0
Enc ppp

R2 interface 4:
  -----------------

interface Ethernet0/0
description "to SW1 e0/2"
ip address 192.10.1.2 255.255.255.0
ip directed-broadcast
ip multicast helper-map broadcast 225.25.25.25 100
encapsulation ppp
ip pim dense-mode
ip igmp join-group 225.25.25.25

access-list 100 permit udp 129.1.17.0 0.0.0.255 any eq 31337

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
sabrina pittarel
Sent: 17 September 2006 18:07
To: shha
Cc: ccielab@groupstudy.com
Subject: Re: Q. ip multicast helper: Mcast -> Broadcast -> Mcast

Thank you for the help...I'll try.
 But "ip directed-broadcast" is usually used to allow directed broadcast
traffic to be forworded out of that interface as regular broacast. It
should not affect ingress traffic on the interface (routers always
accept ingress broadcast AFAIK).
 Anyway, IOS works is misterious ways, you never know :-)
 
 Sabrina

----- Original Message ----
From: shha <shha77@gmail.com>
To: sabrina pittarel <sabri_esame@yahoo.com>
Cc: ccielab@groupstudy.com
Sent: Sunday, September 17, 2006 8:08:26 AM
Subject: Re: Q. ip multicast helper: Mcast -> Broadcast -> Mcast

Can you add ip directed-broadcast on R2 interface 3.Normally router
block broadcast traffic.
 

 
 On 9/16/06, sabrina pittarel <sabri_esame@yahoo.com> wrote: Hi, I'm
trying to use the multicast helper feature to convert from multicast to
directed broadcast and into multicast again.
Topology

Mcast transport netw
Source ---------- R3 ---- .....------ R2 ------- Receiver
225.25.25.25 1 2 3 4

On R3 interface 1 I convert 225.25.25.25 into directed broadcast for R2
interface 3 subnet (ex 129.1.23.255) I have no problem getting this
directed brodcast traffic to R2 interface 3.
On R2 interface 3 I convert broadcast back into 225.25.25.25.
On R2 interface 4 I'm statically joining the 225.25.25.25 group (for
testing purposes).
PIM Dense mode is enabled on R3 interface 1, R2 interface 4

I cannot make this working if I don't enable pim on R2 interface 3 as
well.
But if I do so, R2 complains because it is receiving multicast traffic
on an interface where there are no PIM neighbors and the received
traffic is not sourced from the connected network:

*Sep 16 22:16:52.039: %MROUTE-3-NO_PIM_NBR: There is no PIM neighbor on
this IDB: Serial1/1 -Process= "PIM Process", ipl= 0, pid= 132

Has anyone been able to make this working without PIM on R2 interface 3?

The configureation is the following:

R3 interface 1:
-----------------

ip forward-protocol udp 31337

interface Serial1/2
ip address 129.1.13.3 255.255.255.0
ip pim dense-mode
ip multicast helper-map 225.25.25.25 129.1.23.255 100 encapsulation ppp
serial restart-delay 0

access-list 100 permit udp 129.1.17.0 0.0.0.255 host 225.25.25.25 eq
31337

R3 interface 2:
-----------------

interface Serial1/3
ip address 129.1.23.3 255.255.255.0
ip directed-broadcast
encapsulation ppp

R2 interface 3:
-----------------

ip forward-protocol udp 31337

interface Serial1/1
ip address 129.1.23.2 255.255.255.0
ip pim dense-mode <<<<< without it it doesn't work...
 ip multicast helper-map broadcast 225.25.25.25 100 encapsulation ppp

access-list 100 permit udp 129.1.17.0 0.0.0.255 any eq 31337

R2 interface 4:
  -----------------

interface Ethernet0/0
description "to SW1 e0/2"
ip address 192.10.1.2 255.255.255.0
ip pim dense-mode
ip igmp join-group 225.25.25.25

**************************************************
On R2 Without the "pim" cmd on R3 interface 3:
**************************************************

"deb ip packet" and "deb ip mpacket" output:

*Sep 17 01:13:28.622: IP: s=129.1.17.7 (Serial1/1), d=255.255.255.255,
len 44, rcvd 2
*Sep 17 01:13:28.622: UDP src=49182, dst=31337

sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C -
Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP
Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 225.25.25.25), 00:00:03/00:02:56, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/0, Forward/Dense, 00:00:03/00:00:00

(*, 224.0.1.40), 00:00:03/00:02:56, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/0, Forward/Dense, 00:00:03/00:00:00

*************************************
On R2 WITH the ip pim dense command
*************************************

"deb ip packet" and "deb ip mpacket" output:

*Sep 17 01:16:50.618: IP: s=129.1.17.7 (Serial1/1), d=255.255.255.255,
len 44, rcvd 2
*Sep 17 01:16:50.618: UDP src=53508, dst=31337
*Sep 17 01:16:50.618: IP(0): s=129.1.17.7 (Serial1/1) d=225.25.25.25
(Ethernet0/0) id=0, ttl=252, prot=17, len=44(44), mforward

sh ip mroute

IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C -
Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP
Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 225.25.25.25), 00:03:23/stopped, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/0, Forward/Dense, 00:03:23/00:00:00
    Serial1/1, Forward/Dense, 00:01:31/00:00:00

(129.1.17.7, 225.25.25.25), 00:01:33/00:02:58, flags: LT
  Incoming interface: Serial1/1, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/0, Forward/Dense, 00:01:33/00:00:00

(*, 224.0.1.40), 00:03:23/00:02:41, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/0, Forward/Dense, 00:03:23/00:00:00

Sabrina



This archive was generated by hypermail 2.1.4 : Sun Oct 01 2006 - 16:55:41 ART