Re: QOS Tricky Task

From: route flap (routeflap@gmail.com)
Date: Mon Sep 04 2006 - 12:59:42 ART


What about this

Router-1#show run policy-map
Building configuration...

Current configuration : 406 bytes
!
policy-map VOICE
  class VOICE
   priority percent 50
  class class-default
   bandwidth percent 15
policy-map QOSS.1
  class class-default
   shape average 1536000 15360 0
   service-policy VOICE
policy-map VOICE2
  class VOICE
   priority percent 50
  class class-default
   bandwidth percent 25
policy-map QOSS.2
  class class-default
   shape average 1536000 15360 0
   service-policy VOICE2
!
end

Router-1#show run class-map
Building configuration...

Current configuration : 57 bytes
!
class-map match-all VOICE
  match protocol rtp
!
end

Router-1#show run int s1/1.1
Building configuration...

Current configuration : 109 bytes
!
interface Serial1/1.1 point-to-point
 ip address 10.1.1.1 255.255.255.0
 service-policy output QOSS.1
end

Router-1#show run int s1/1.2
Building configuration...

Current configuration : 109 bytes
!
interface Serial1/1.2 point-to-point
 ip address 10.1.2.1 255.255.255.0
 service-policy output QOSS.2
end

Thanks for your invaluable comments
RF

On 9/3/06, Aamir Aziz <aamiraz77@gmail.com> wrote:
>
> Hi there ppl,
>
> A friend of mine forwarded this task to me, i dont have a definite
> answer so any replies are appreciated:
>
> R1's serial interface 1/0 will be used for a customer network by
> having two sub-interfaces. Apply Quality of Service to the
> corresponding sub-interfaces. Customers ip address and bandwidth to be
> allocated as following
>
> 1. 1/0.1 = 10.1.1.1/24 bandwidth 15%
> 2. 1/0.2 = 10.1.2.1/24 bandwidth 25%
> 3. critical voice traffic bandwidth 50%
>
> R1 is a HUB already having a sub-interface s0/0.123 (FR-Multipoint)
> connected to two spoke routers.
>
> This is a possible solution, not sure:
>
> ip access-list extended s0/0.1
> permit ip any 10.1.1.0 0 0.0.0.255
> ip access-list extended s0/0.2
> permit ip any 10.1.2.0 2.0 0.0.0.255
> ip access-list extended VOICE
> permit udp any any range 16384 32767 precedence 5
>
> class-map s0/0.1
> match ip add s0/0.1
> class-map s0/0.2
> match ip add s0/0.2
> class-map VOICE
> match ip add VOICE
>
> Policy-map s0/0.1
> class s0/0.1
> band percent 15
> class VOICE
> band percent 50
>
> Policy-map s0/0.2
> class s0/0.2
> band percent 25
> class VOICE
> band percent 50
>
> map-class frame-relay s0/0.1
> service policy out s0/0.1
> map-class frame-relay s0/0.2
> service policy out s0/0.2
>
> int s0/0
> frame-relay traffic- shaping
> max-reserved-band 90
> int s0/0.1
> class s0/0.1
> int s0/0.2
> class s0/0.2
>
> Please ignore any syntax mistakes as i didnt get time to type it on
> the router, but this logic does it make any sense for the above task??
>
> Thanks
> Aamir
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sun Oct 01 2006 - 16:55:39 ART