IPv6 - Tunnel 6to4 question

From: Danilo Rodrigues (dani.rodrigues@gmail.com)
Date: Sat Sep 02 2006 - 14:13:26 ART


Hi everybody,

I have the following topology and configuration:

 R1(s0/0) --IPv6-- (s1/0)R2(e0/0) --IPv4-- (e0/0)R3(Loopback2 -IPv6)

######### R3 ##########
!
interface Tunnel0
 ipv6 address 2002:101:102::3333/64
 ipv6 enable
 tunnel source Ethernet0/0
 tunnel mode ipv6ip 6to4
!
interface Loopback2
 ipv6 address 2002:101:102:1::3333/64
 ipv6 enable
!
interface Ethernet0/0
 ip address 1.1.1.2 255.0.0.0
!
ipv6 route 2002::/16 Tunnel0
!

######### R2 ##########
!
interface Tunnel0
 ipv6 address 2002:101:101::2222/64
 ipv6 enable
 tunnel source Ethernet0/0
 tunnel mode ipv6ip 6to4
!
interface Ethernet0/0
 ip address 1.1.1.1 255.0.0.0
!
interface Serial1/0
 ipv6 address 2002:101:101:1::2222/64
 ipv6 enable
!
######### R1 ##########
!
interface Serial0/0
 ipv6 address 2002:101:101:1::1111/64
 ipv6 enable
!
ipv6 route 2002::/16 2002:101:101:1::2222
!
#######################

But I got the following results:

######### R3 ##########

R3#ping 2002:101:101:1::2222

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:101:101:1::2222, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/60/68 ms
R3#
R3#
R3#ping 2002:101:101:1::1111

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:101:101:1::1111, timeout is 2
seconds:
.....
Success rate is 0 percent (0/5)

######### R2 ##########

R2#ping 2002:101:102:1::3333

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:101:102:1::3333, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/61/80 ms
R2#
R2#
R2#ping 2002:101:101:1::1111

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:101:101:1::1111, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/36/60 ms

######### R1 ##########

R1#ping 2002:101:101:1::2222

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:101:101:1::2222, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/24/32 ms
R1#
R1#
R1#ping 2002:101:102:1::3333

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:101:102:1::3333, timeout is 2
seconds:
.....
Success rate is 0 percent (0/5)

#######################

So the tunnel works well between R2 and R3 routers, but I couldn't do this
lab work between R1 and R3. Does anybody has any idea ?

Thanks a lot.

Regards,

Danilo



This archive was generated by hypermail 2.1.4 : Sun Oct 01 2006 - 16:55:39 ART