RE: Virtual Link

From: Brian Dennis (bdennis@internetworkexpert.com)
Date: Fri Sep 01 2006 - 20:38:55 ART


hostname R5
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 frame-relay interface-dlci 102 ppp Virtual-Template1
 frame-relay lmi-type cisco
!
interface Virtual-Template1
 ip address 172.16.1.5 255.255.255.0
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 area 10 virtual-link 2.2.2.2
 network 1.1.1.1 0.0.0.0 area 10
 network 172.16.1.5 0.0.0.0 area 10

hostname R6
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 frame-relay interface-dlci 201 ppp Virtual-Template1
 frame-relay lmi-type cisco
!
interface Virtual-Template1
 ip address 172.16.1.6 255.255.255.0
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 10 virtual-link 1.1.1.1
 network 2.2.2.2 0.0.0.0 area 10
 network 172.16.1.6 0.0.0.0 area 10

R5#ping 172.16.1.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms
R5#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - - 172.16.1.6 OSPF_VL0
2.2.2.2 0 FULL/ - 00:00:39 172.16.1.6 Virtual-Access2
R5#show ip ospf virtual-link
Virtual Link OSPF_VL0 to router 2.2.2.2 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 10, via interface Virtual-Access2, Cost of using 1
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
    Adjacency State FULL (Hello suppressed)
    Index 1/2, retransmission queue length 0, number of retransmission 1
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 1, maximum is 1
    Last retransmission scan time is 0 msec, maximum is 0 msec
R5#

R6#ping 172.16.1.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms
R6#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - - 172.16.1.5 OSPF_VL0
1.1.1.1 0 FULL/ - 00:00:35 172.16.1.5 Virtual-Access2
R6#show ip ospf virtual-link
Virtual Link OSPF_VL0 to router 1.1.1.1 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 10, via interface Virtual-Access2, Cost of using 1
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04
    Adjacency State FULL (Hello suppressed)
    Index 1/2, retransmission queue length 0, number of retransmission 1
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 1, maximum is 1
    Last retransmission scan time is 0 msec, maximum is 0 msec
R6#

HTH,

Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
bdennis@internetworkexpert.com
 
Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of beatccielab
Sent: Friday, September 01, 2006 8:25 AM
To: ccielab@groupstudy.com
Subject: Virtual Link

Hi all,

I have problem with my configuration OSPF virtual link over ppp over frame relay..

Configuration Scenario like this :

  area 0 ---R5--- FRS/area10 --- R2--- area24 ---Cat1

my case say: R2 not use subinterface..

i already configure like this :

R5:
interface Serial0/1/0
 no ip address
 encapsulation frame-relay
 frame-relay interface-dlci 501 ppp Virtual-Template1 no frame-relay inverse-arp !
interface Virtual-Template1
 ip address 172.16.1.5 255.255.255.0

router ospf 1
 router-id 1.1.1.1
 area 10 virtual-link 2.2.2.2
 network 1.1.1.1 0.0.0.0 area 10
 network 172.16.1.5 0.0.0.0 area 10

R5#sh ip os nei

Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:00:38 172.16.1.6
Virtual-Access1

R5#sh ip os vi
Virtual Link OSPF_VL0 to router 2.2.2.2 is down
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 5, Cost of using 65535
  Transmit Delay is 1 sec, State DOWN,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

R6:
interface Serial0/1/0
 no ip address
 encapsulation frame-relay
 frame-relay interface-dlci 105 ppp Virtual-Template1 no frame-relay inverse-arp !
interface Virtual-Template1
 ip address 172.16.1.6 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 !
interface FastEthernet0/0.24
 encapsulation dot1Q 24
 ip address 192.1.24.2 255.255.255.0
!
 router ospf 1
 router-id 2.2.2.2
 area 10 virtual-link 1.1.1.1
 network 2.2.2.2 0.0.0.0 area 10
 network 192.1.24.2 0.0.0.0 area 24
!

R2#sh ip os vir
Virtual Link OSPF_VL0 to router 1.1.1.1 is down
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 5, Cost of using 65535
  Transmit Delay is 1 sec, State DOWN,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

R2#sh ip osp nei

Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - 00:00:30 172.16.1.5
Virtual-Access1
3.3.3.3 1 FULL/DR 00:00:35 192.1.24.5
FastEthernet0/0.

Cat1

interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 24
 switchport mode trunk

interface Loopback0
 ip address 3.3.3.3 255.255.255.0

interface Vlan13
 ip address 192.1.24.5 255.255.255.0

router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 24
 network 198.1.24.5 0.0.0.0 area 24

If issued show ip ospf virtual always down whereas if we issued sh ip ospf nei the router another site appears...
Please advice me how to fix it this problem...

Regards,
beatccielab



This archive was generated by hypermail 2.1.4 : Sun Oct 01 2006 - 16:55:39 ART