RE: rip - conditional default origination

From: ismail el-shalh (ishelh_mdsa@yahoo.com)
Date: Tue Aug 08 2006 - 12:00:46 ART


Hi Stephen,
   
   
  let's summarize what I did in my lab,
   
   
  you have three physical interfaces plus one logical interface :
   
  1 - E0
  2 - E1
  3 - S0
  4 - Loopback 0
   
   
  How the condition works with rip is as follows :
   
  in the route map you should match that subnet associated with that particular interface, the match will occur only if the interface status is Up/Up.
   
  it will not match against the presence of the subnet while the interface is down, it will only match if the status of that interface is Up/Up.
   
  If the match occur, then the default route will be propagated according to the set command, for example if I said "set interface Ethernet1" it means send the default route through Ethernet1 and if I said "set interface null0" it means send the default route through null0, now by sending it to Null 0, I mean the propagation should be discarded in that Bucket.
   
  in our case here, I want to generate a default route only if both E0 and S0 is down,
  so suppose both interfaces E0 and S0 is down, this is what will happen :
   
  the first route-map will not match the presence so it will go to the next route-map , again in the second route-map it will not match the presence, so it will go to the third route-map, in the third route-map a match is there because it is a loopback and it is always up so it will propagate the default route through Ethernet 1.
   
  Now I have did this on my lab with assumption that I am right, I will feel great if some more experience in this group can shed more light into this.
   
  Thanks Allot
  Ismail E-Shalh

"Skinner, Stephen" <Stephen.Skinner@rbs.co.uk> wrote: Ismal ,

Can I ask a Question ,

You wrote
in the third route-map I told the router to match the Loopback which is
always up, then it will send the update through ethernet 1 where my other
router is connected to, there the router will receive the default route

Which means the default is being sent out E1 ??.

Then you wrote,

In the third route-map it will match the presence of the loopback so it will
send the default route through Ethernet 1.

Which means the default is being sent out of E1 ??

I thought that the idea was ONLY to send a default out when the two networks
don't exist .

I think I am missing something here , which is why I ask !

Can you please help me !

Stephen Skinner

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]
Sent: 08 August 2006 01:13
To: ismail el-shalh; ccielab@groupstudy.com
Subject: Re: rip - conditional default origination

*** WARNING : This message originates from the Internet ***

Hi Ismail,

This worked perfectly!

Thanks!
-tim

----- Original Message ----
From: ismail el-shalh
To: Tim Chan ; ccielab@groupstudy.com
Sent: Monday, August 7, 2006 4:09:15 PM
Subject: Re: rip - conditional default origination

Hi Tim,

BB2--.254----(192.10.1.0/24)----.4---E1-R4-----E0---(167.1.4.0/24)
|
S0
|
|
(167.1.34.0/24)

R4 should generate a default route and send it to BB2 only if E1 and S0 is
down

Try the following configuration :

router rip
version 2
default-information originate route-map CONDITION network 192.10.1.0
no auto-summary

access-list 10 permit 167.1.4.0 0.0.0.255 access-list 20 permit 167.1.34.0
0.0.0.255 access-list 30 permit 150.1.4.0 0.0.0.255
!
route-map CONNECTED->RIP permit 10
match interface Loopback0
!
route-map CONDITION permit 10
match ip address 10
set interface Null0
!
route-map CONDITION permit 20
match ip address 20
set interface Null0
!
route-map CONDITION permit 30
match ip address 30
set interface Ethernet1

I did the above configuration according to the following :

1- Ethernet 0 has the subnet 167.1.4.0/24
2 -Serial 0 has the subnet 167.1.34.0/24
3- Loopback 0 has the subnet 150.1.4.0

in the first route-map I told the router to match the access-list of
Ethernet 0, if it found it present then it should send the update to
interface null 0

in the second route-map I told the router to match the access-list of
Serial 0, if it found it present i.e. UP/UP then it should send the update
to interface null 0

in the third route-map I told the router to match the loopback which is
always up, then it will send the update through ethernet 1 where my other
router is connected to, there the router will receive the default route

now do the following :

shutdown Ethernet 0 and serial 0
the first route-map will not match, hence it will go to the second
route-map , again the route-map will not match because serial 0 is not
present so it will go to the third route-map.

In the third route-map it will match the presence of the loopback so it
will send the default route through Ethernet 1.

let me know if it works with you

:)

Ismail El-Shalh

Tim Chan wrote:
Correct me if I'm wrong, but this would send out a default out when both
of these networks exist.
(The route-map matches the prefix list, then sends out a 0.0.0.0/0 route)

I need it to be opposite. If these networks DON'T exist, then send it out.

thanks!
-tim

----- Original Message ----
From: uyota oyearone
To: timanji@yahoo.com; ccielab@groupstudy.com
Sent: Monday, August 7, 2006 1:59:42 PM
Subject: RE: rip - conditional default origination

what u can do is, u match the prefixes of the e0/0 and e0/1 example suppose
e0/0 = 10.10.10.0/24 , e0/1= 10.10.20.0/24 you config would look like this
ip prefix-list E0/0_&_E0/1 seq 5 permit 10.10.10.0/24 ip prefix-list
E0/0_&_E0/1 seq 10 permit 10.10.20.0/24 !
route-map CONDITIONAL_DEFAULT permit 10
match ip addre prefix-list E0/0_&_E0/1
!
router rip
default-information originate route-map CONDITIONAL_DEFAULT cheers, UYOTA

From: Tim Chan
Reply-To: Tim Chan
To: ccielab@groupstudy.com
Subject: rip - conditional default origination
Date: Mon, 7 Aug 2006 12:14:59 -0700 (PDT)
>Hi all,
>
>I'm trying to send a default route out a serial interface, only if two of
it's ethernet interfaces are down.
>So when eth0/0 and eth0/1 are down, then send a 0/0 route out it's serial
0/0 interface.
>
>Conditional default origination seems to send it out based on what it
matches in the route-map. How
>do I set it up so it sends it out on routes that are not there?
>
>This is using RIPv2.
>
>Thanks!
>-tim



This archive was generated by hypermail 2.1.4 : Fri Sep 01 2006 - 15:41:56 ART