Why don't these routes show in the EIGRP Topology?

From: Joe Gagznos (joegagznos@comcast.net)
Date: Sat Jul 29 2006 - 22:56:35 ART


I have 2 routers connected through frame relay (routers R1 and R2). I am
running PPP over Frame Relay with the use of a virtual template on each
side. On R1, I have two connected interfaces that I would like to advertise
to R2. Here are the relevant configs on both R1 and R2:

 

R1

 

interface Ethernet0/0.1

 encapsulation dot1Q 5

 ip address 10.0.1.1 255.255.255.0

!

interface Ethernet0/0.2

 encapsulation dot1Q 55

 ip address 10.0.2.1 255.255.255.0

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

 frame-relay interface-dlci 503 ppp Virtual-Template1

 no frame-relay inverse-arp

!

interface Virtual-Template1

 ip address 10.0.0.1 255.255.255.0

!

router eigrp 10

 network 10.0.0.0 0.0.0.255

 network 10.0.1.0 0.0.0.255

 network 10.0.2.0 0.0.0.255

 metric weights 0 1 1 1 0 0

 no auto-summary

 eigrp router-id 1.1.1.1

 

R1#ping 10.0.0.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 60/61/64 ms

R1#

 

R1#sh ip eigrp neig

IP-EIGRP neighbors for process 10

H Address Interface Hold Uptime SRTT RTO Q Seq

                                            (sec) (ms) Cnt Num

0 10.0.0.2 Vi1 13 00:10:40 1 3000 0 19

 

R1#sh ip eigrp top

IP-EIGRP Topology Table for AS(10)/ID(1.1.1.1)

 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status

 

P 10.0.2.0/24, 1 successors, FD is 282603

        via Connected, Ethernet0/0.2

P 10.0.1.0/24, 1 successors, FD is 282603

        via Connected, Ethernet0/0.1

 

 

R2

 

interface Loopback0

 ip address 2.2.2.2 255.255.255.0

!

interface Serial1/0

 no ip address

 encapsulation frame-relay

 frame-relay interface-dlci 305 ppp Virtual-Template1

 no frame-relay inverse-arp

!

interface Virtual-Template1

 ip address 10.0.0.2 255.255.255.0

!

router eigrp 10

 network 10.0.0.0 0.0.0.255

 metric weights 0 1 1 1 0 0

 no auto-summary

 eigrp router-id 2.2.2.2

 

R2#ping 10.0.0.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 60/61/64 ms

R2#

 

R2#sh ip eigrp neig

IP-EIGRP neighbors for process 10

H Address Interface Hold Uptime SRTT RTO Q Seq

                                            (sec) (ms) Cnt Num

0 10.0.0.1 Vi1 10 00:09:43 1 4500 0 19

 

R2#sh ip eigrp top

IP-EIGRP Topology Table for AS(10)/ID(2.2.2.2)

R2#

 

 

When I do a debug ip eigrp on R2, R2 is seeing the routes come in from R1.
Why would R2 not be installing these routes into the topology table?

 

R2#clear ip eigrp neig

R2#

*Mar 1 00:46:52.231: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 10.0.0.1
(Virtual-Access1) is down: manually cleared

*Mar 1 00:46:52.979: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 10.0.0.1
(Virtual-Access1) is up: new adjacency

R2#

*Mar 1 00:46:57.139: IP-EIGRP(Default-IP-Routing-Table:10): Processing
incoming UPDATE packet

*Mar 1 00:46:57.139: IP-EIGRP(Default-IP-Routing-Table:10): Int 10.0.2.0/24
M 4294967295 - 4294967040 2585600 SM 282603 - 256000 25600

*Mar 1 00:46:57.139: IP-EIGRP(Default-IP-Routing-Table:10): Int 10.0.1.0/24
M 4294967295 - 4294967040 2585600 SM 282603 - 256000 25600

R2#sh ip eigrp top

IP-EIGRP Topology Table for AS(10)/ID(2.2.2.2)

R2#

 

Any one have any ideas on what I am doing wrong here?

 

Regards,

Joe Gagznos



This archive was generated by hypermail 2.1.4 : Tue Aug 01 2006 - 07:13:48 ART